• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

S2 810, unusual boot issue (official firmware)

Search This thread

shinymetal

New member
Apr 3, 2018
3
0
Hello and greetings,

I am looking for some help from the gurus here.

I bought this S2 off of ebay, as broken, no power.
plugged in with adequate power supply, the power button was not responding.
I then tried launch recovery mode, and nothing.
Then I found that this tablet would start with download mode enabled.
naturally the battery was flat, but by cancelling download moded, the tablet booted into the system.
the tablet had 5.1.1 and after allowing the tablet battery to charge up to 100%, I then performed a factory reset from within the tablet, and then restarted the tablet to check for issues.
on reboot, the tablet just went black, and again the power button, nor recovery mode would start the tablet, but here i was again able to start the tablet with download mode (cancelling dl mode when initialized).
(i did manage to enter recovery mode, im not sure, i think i was repeatedly trying the button combos and it worked. the recovery menu is untouched vanilla no twrp was installed. i delete the cache, and again performed a factory reset from the recovery console. still, no change in the power button responsiveness from power off)

the next thing I tried was to update the firmware, by grabbing official firmware from updato, and secondarily from samsung-firmware org as a backup source.
both firmwares are official release, 7.0 nougat.
ran odin, and successfully updated the firmware using the file from updato, and the tablet is now running nougat.
everything works great, except when the unit is shut down the power button alone still will not turn the tablet on. (this was the same issue as before i updated the rom to 7.0)

so the next rabbit hole i dug into was creating a bootloader file to see if that would help this issue (extracted the files and compiled into md5 bootloader using Cygwin), the bootloader flashed fine, but still no change to the power button issue. (the Cygwin method can be used to create samsung 4 files repair, but really doesn't do much if you already have the single fat file (firmware))

a couple other oddities:
occasionally the android system installer will go into erase mode, after performing a firmware install from odin, and not complete or reboot.
the system also for the first few seconds after leaving the download mode has graphical artifacts on the screen, just before the samsung logo appears. usually in the bottom half of the screen which are just random blocky colors.

i am pressed for time, and cannot add any more details at the moment, I'll get back later.

any wisdom or insight would be fantastic,
thank you.