S20FE 5GHz WiFi speed issues

Search This thread

chromaniac

Member
Oct 2, 2021
24
4
Gurgaon, India
hey @chromaniac is it good to buy S20FE 5G now? I'm currently using S10 Lite.
It's hard to recommend S20FE5G over S10Lite because performance difference is negligible. Battery life is also still pretty good and I got the phone on launch day. You do get a better camera, Qi charging and water resistance. Apart from that, you are essentially getting a pretty similar phone. I loved the phone though. It just feels better in hands even though size difference is very negligible (display is 0.2" smaller iirc). But the wifi issues were noticeable enough regularly so I decided not to keep the phone. It might get fixed in a software update.

Another thing to consider is that FE launched with Android 10 so both phones have same update schedule. Both would get Android 12 and 13. FE should get a few months more of security updates.

If you are happy with S10L, I would suggest waiting for a while. It's likely Samsung would keep the price of Fe low and the same deals would remain available frequently in coming months. By that time, it should be clear if Samsung would fix the issues many folks are facing. And we might end up getting the S21 FE sometime early next year. Which might turn out to be a better phone to upgrade to.
 

ARx07

New member
Oct 9, 2021
3
0
It's hard to recommend S20FE5G over S10Lite because performance difference is negligible. Battery life is also still pretty good and I got the phone on launch day. You do get a better camera, Qi charging and water resistance. Apart from that, you are essentially getting a pretty similar phone. I loved the phone though. It just feels better in hands even though size difference is very negligible (display is 0.2" smaller iirc). But the wifi issues were noticeable enough regularly so I decided not to keep the phone. It might get fixed in a software update.

Another thing to consider is that FE launched with Android 10 so both phones have same update schedule. Both would get Android 12 and 13. FE should get a few months more of security updates.

If you are happy with S10L, I would suggest waiting for a while. It's likely Samsung would keep the price of Fe low and the same deals would remain available frequently in coming months. By that time, it should be clear if Samsung would fix the issues many folks are facing. And we might end up getting the S21 FE sometime early next year. Which might turn out to be a better phone to upgrade to.
Thanks for the advice Man. I'll go with the Moto Edge20 Pro or wait few months to grab thr S21 FE directly.
 

chromaniac

Member
Oct 2, 2021
24
4
Gurgaon, India
i would personally not recommend going to moto. they do promise two android updates but they have a history of not delivering on their promises. samsung has been doing a whole lot better with updates. but yeah, if that's not an important factor, i guess it should be fine.
 

ARx07

New member
Oct 9, 2021
3
0
i would personally not recommend going to moto. they do promise two android updates but they have a history of not delivering on their promises. samsung has been doing a whole lot better with updates. but yeah, if that's not an important factor, i guess it should be fine.
I'm unable to find any other good phone in 35-40k Price Range except Moto Edge20 Pro. Updates doesn't really matter for me xD. If you have any suggestions for Good devices then you're most welcome
 

Knightofrepublic

Senior Member
May 11, 2014
95
10
It's been very long since I logged into XDA, and probably too late for Amazon replacement. 😢

This is my 1st affordable flagship phone and sad to see so many people facing this issue.

I bought it in the same sale, 2 October midnight, delivered 5 October morning. It had August patch on it.

BUT I just saw this thread only this morning.

I don't use Wi-Fi internet, but I did order a TP-Link archer C60 AC1350 router for high-speed data transfer/offline streaming from my PC. It's not even shipped yet😬.

Whenever I do get this router, I could check the issue for you guys.

I did do a few file transfers over Wi-Fi with a different phone and my PC using hotspot, but honestly it neither took long enough, nor would it have been revealing even if it did (The PC adapter is bottlenecked by 150 mbps Wi-Fi n).

If I may make a suggestion here, I'd say this: since all of you are saying this issue looks like throttling (initially speed is great, later it stumbles to a crawl, Temps get high), might it be a good idea to turn on "enhanced processing" option,and run the tests again? It's found in more battery settings (or you can search for those 2 words. I'll be attaching a screenshot anyway.)

Perhaps that'd ignore artificial thermal limits imposed on wifi.

Or maybe those of you willing to do it, could downgrade to One UI 2.5 and check it there as well?
 

Attachments

  • Screenshot_20211012-094900_Device care.jpg
    Screenshot_20211012-094900_Device care.jpg
    270.1 KB · Views: 117
  • Like
Reactions: viv29

piotrekbx

New member
Aug 11, 2021
3
3
It's been very long since I logged into XDA, and probably too late for Amazon replacement. 😢

This is my 1st affordable flagship phone and sad to see so many people facing this issue.

I bought it in the same sale, 2 October midnight, delivered 5 October morning. It had August patch on it.

BUT I just saw this thread only this morning.

I don't use Wi-Fi internet, but I did order a TP-Link archer C60 AC1350 router for high-speed data transfer/offline streaming from my PC. It's not even shipped yet😬.

Whenever I do get this router, I could check the issue for you guys.

I did do a few file transfers over Wi-Fi with a different phone and my PC using hotspot, but honestly it neither took long enough, nor would it have been revealing even if it did (The PC adapter is bottlenecked by 150 mbps Wi-Fi n).

If I may make a suggestion here, I'd say this: since all of you are saying this issue looks like throttling (initially speed is great, later it stumbles to a crawl, Temps get high), might it be a good idea to turn on "enhanced processing" option,and run the tests again? It's found in more battery settings (or you can search for those 2 words. I'll be attaching a screenshot anyway.)

Perhaps that'd ignore artificial thermal limits imposed on wifi.

Or maybe those of you willing to do it, could downgrade to One UI 2.5 and check it there as well?
It's the same for me with enchanced processing and without it.
 
  • Like
Reactions: gallgamer

piskorz84

New member
Apr 1, 2022
3
0
I wanted to ask if the problem was resolved. I bought a phone in Poland at the end of February and my wifi also slows down to 6MB / s. Is my phone broken or do they all work the same way?
 

screege

Senior Member
Sep 28, 2008
66
5
Bought this for my daughter the same issue I have a 1 Gbps connection every phone and device works fine except this, mine is manufactured in Vietnam and I have installed all the software updates, has anyone found a solution? Definitely is software related since it works fine for a few minutes and then drops. This one is manufactured in Vietnam and has a date of December 21

Regards
 
Last edited:

jbrizz

Senior Member
Dec 28, 2009
83
11
I had the same problem. I have Ubiquiti wireless APs in my house (AC Pro and AC LR), the issue occured on both model of APs. My connection speed is 1000/550 and immediately after connection I would get 650/550 (AC 2x2 wireless maximum speed), but it would slow down to anywhere from 8 to 30 after a few minutes. Disconnecting and immediately reconnecting would get it going fast again but only for a few minutes.

I would guess it only affects certain wireless environments, but I didn't have the phone long enough to test anywhere else.

I think it is a problem only Samsung can fix via a firmware update so I returned the phone for a refund.
 

dang3rzone

Member
Aug 29, 2021
17
3
No fix? Just got a new s20 Fe 5G, and it will reach 500mb+ at first, but after a while it goes down to 16mb tops :(
 

Kush1906

New member
Aug 7, 2022
1
0
Hi,

I'm trying to resolve my WiFi problems on Samsung S20 FE 5G. When I download large files (games, updates, big apps) WiFi speed drops from 300 Mbps (that's my provider speed) to < 10 Mbps or even completely stops. It happens after a few minutes of download (sometimes less) - the estimated download time goes from few minutes to few hours. If I continue to download speed usually goes up again after another few minutes. Or I can restart wifi/put phone in airplane mode/restart it - it restores normal WiFi speed.
What I've already tried but didn't help:
- reset phone network settings
- reset router to factory settings and tried changing some of its options
- changed WiFi channel
- checked in safe mode of the phone
- tried without my silicone case on the back of the phone (as it might be some overheating issue)
- set my WiFi network as unmeasured in the phone settings (don't know really if that's the correct name of this setting in English)
- set WiFi connection to use phone MAC address instead of random one
- disabled automatic switching to mobile data when wifi connection quality is poor
- update the phone to latest August version (Android 11)
- wipe cache partition
- turned on enchanced processing

On other devices in my network connection is stable with 300 Mbps - checked with Speedtest.net. On 2.4 GHz WiFi problem also occur but only sometimes - on 5 GHz it happens every time. I also didn't notice it on LTE.

It seems that it might be some overheating issue so I've installed CPU monitor to check it - during download temperature went up from 30 Celsius degrees to over 50, then the connection speed dropped, temperature went down to about 40 degrees Celsius and after some time the speed increased again.

Is there any thing I can also do before returning phone to Samsung service?
Idk about you but i have a mesh system and i faced the same problem. I resolved it by disabling wifi fast roaming in router settings.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hi,

    I'm trying to resolve my WiFi problems on Samsung S20 FE 5G. When I download large files (games, updates, big apps) WiFi speed drops from 300 Mbps (that's my provider speed) to < 10 Mbps or even completely stops. It happens after a few minutes of download (sometimes less) - the estimated download time goes from few minutes to few hours. If I continue to download speed usually goes up again after another few minutes. Or I can restart wifi/put phone in airplane mode/restart it - it restores normal WiFi speed.
    What I've already tried but didn't help:
    - reset phone network settings
    - reset router to factory settings and tried changing some of its options
    - changed WiFi channel
    - checked in safe mode of the phone
    - tried without my silicone case on the back of the phone (as it might be some overheating issue)
    - set my WiFi network as unmeasured in the phone settings (don't know really if that's the correct name of this setting in English)
    - set WiFi connection to use phone MAC address instead of random one
    - disabled automatic switching to mobile data when wifi connection quality is poor
    - update the phone to latest August version (Android 11)
    - wipe cache partition
    - turned on enchanced processing

    On other devices in my network connection is stable with 300 Mbps - checked with Speedtest.net. On 2.4 GHz WiFi problem also occur but only sometimes - on 5 GHz it happens every time. I also didn't notice it on LTE.

    It seems that it might be some overheating issue so I've installed CPU monitor to check it - during download temperature went up from 30 Celsius degrees to over 50, then the connection speed dropped, temperature went down to about 40 degrees Celsius and after some time the speed increased again.

    Is there any thing I can also do before returning phone to Samsung service?
    2
    He claims to not have such issues. He's running the latest update as well, so I'm leaning towards believing that this is not a software issue. Anyways, I got a direct replacement booked by calling Amazon (thanks for the heads up, I'd have had to deal with the technician if done through app)

    Hoping this doesn't occur on the replacement unit. Other than this issue I've really come to like the phone. Fingers crossed!
    1
    Would do in a couple of hours. It's just annoying that Amazon would not offer a replacement for manufacturing fault within the first week of purchase as per their own policy. And is forcing me to deal with third party outlets who are not going to understand the wi-fi stability issue on this device. They have a stupid app that tests phone and of course, it found my phone properly functional.
    Dude call them don't use that ****ty app to find the issue request a call directly rn!
    1
    when the device gets a little warm.
    yup. this is exactly what happened during the restore process. phone was on charge and it was restoring and updating around 100 apps. internet was extremely slow at the time.

    i have a feeling that this is a software issue. samsung is throttling wifi to save on battery or something. BUT. they have had almost a year to optimize wi-fi on this phone.

    october update might have a fix assuming they know about this issue. but it is currently available only in europe. it's unlikely india is getting it this week. would have been nice to test out wifi after installing it.
    1
    It's been very long since I logged into XDA, and probably too late for Amazon replacement. 😢

    This is my 1st affordable flagship phone and sad to see so many people facing this issue.

    I bought it in the same sale, 2 October midnight, delivered 5 October morning. It had August patch on it.

    BUT I just saw this thread only this morning.

    I don't use Wi-Fi internet, but I did order a TP-Link archer C60 AC1350 router for high-speed data transfer/offline streaming from my PC. It's not even shipped yet😬.

    Whenever I do get this router, I could check the issue for you guys.

    I did do a few file transfers over Wi-Fi with a different phone and my PC using hotspot, but honestly it neither took long enough, nor would it have been revealing even if it did (The PC adapter is bottlenecked by 150 mbps Wi-Fi n).

    If I may make a suggestion here, I'd say this: since all of you are saying this issue looks like throttling (initially speed is great, later it stumbles to a crawl, Temps get high), might it be a good idea to turn on "enhanced processing" option,and run the tests again? It's found in more battery settings (or you can search for those 2 words. I'll be attaching a screenshot anyway.)

    Perhaps that'd ignore artificial thermal limits imposed on wifi.

    Or maybe those of you willing to do it, could downgrade to One UI 2.5 and check it there as well?
    It's the same for me with enchanced processing and without it.