Question S22+ stuck in bootloop with download mode screen

Search This thread

Poteco

New member
Sep 18, 2023
1
0
Hello,

My girlfriend's S22+ has been in a boot loop since last Saturday. This started spontaneously when we were on the bus and she wasn't using her phone. The phone shut down and kept restarting. I tried restarting the phone by pressing volume down and the power button at the same time, unfortunately to no avail. I also tried to enter recovery mode, which also didn't work. The phone kept restarting. Sometimes the phone would start up and she could enter her SIM PIN code and unlock the phone, but after a maximum of 1 minute it would turn off again and the boot loop would continue.

Finally the blue screen of the download mode started automatically.
See images below:
IMG20230916130332.jpg
IMG20230916131108.jpg

(The calculated hash has a different value on both images?)

Considering the error "Hash of data does not match digest in descriptor." After some Googling this seemed to me to be a firmware problem.

After restarting the phone while it was connected to the laptop, I got another error message in download mode:
IMG20230916211037.jpg


The device is still under warranty, but if it is sent via the provider, the entire device will be reset to factory settings. My girlfriend has valuable data on her device that she does not want to lose. I read in another topic (https://forum.xda-developers.com/t/...k-bootloader-and-flash-official-firmware-noob -friendly.4404351/) that it shouldn't be that difficult to reflash the official firmware.

After this I downloaded the firmware again. Since the original PDA has number S906BXXS2BWA2 (as seen in the first image), I searched again for exactly this version. I assumed EUX for the region, although I am not entirely sure whether this is correct.
Because the data on it is very important, I left CSC and USERDATA empty in Odin, as described in the guide above.

After some problems flashing the firmware, we finally managed to install this firmware. Unfortunately, when restarting after the new firmware has been installed, I still cannot get beyond download mode. At first I got the same message as in the first image. After another restart I get a new error message:
IMG20230918193706.jpg


My girlfriend is really devastated about this and I really hope we can save her data.
Does anyone please have a solution for me to get the data or flash the firmware properly so that the device can start again (without losing data)?

Thanks in advance!

Kind regards,
Poteco
 

coolpixs4

Senior Member
Mar 7, 2011
620
189
Suddenly ?!

Does the device activate auto download and update software? If it is YES, then should it be a software bug issue, another case it might be the MMC partition of the device is defected.

It should go to the A/S center and ask for help to keep the data by directly reading MMC

Or you can try with older firmware version flash (same binary) with keep CSC & User data
 
Last edited: