• We are moving to xdaforums.com!

    Posts made between now and when the migration is complete will not be carried over.
    You will be automatically redirected once the migration is complete.

S4 Mini i9195 only vibrates, ODIN mode boots, data recovery

Search This thread


New member
Jun 3, 2023

my Galaxy S4 Mini GT-i9195 died last weekend out of nothing. Battery was empty, I started it, it boots and switched off again. After I tried to charge it, nothing happens but when I longpress the power button it vibrates one time and the screen stays black.
The phone has TWRP and LineageOS on it and worked fine for some years.

What I've done and what I know:
1) Changed all but the main pcb, I have the same device again and switched all other parts. Same issue, so I'm sure the issue is on the motherboard.
2) Meassured battery current when off 0mA, when on 130-180mA
3) Meassured voltages, 1.8v and 3.0v are there when I switch the phone on
3) Meassured CMD pin on eMMC, the CPU is alive and tries to access the eMMC

What I don't know currently
1) Is the eMMC working correctly
2) Is any other hardware defect?
3) Is there some data corruption on any part of the eMMC?

Before I try to solder something on the phone I would like to test all other ways to recover my data.
The hardware itself is not important, but it would be nice to get the data. The SDcard that was used looks like the data is encrypted, so I suppose the userdata on the eMMC is encrypted as well. This means I hope to get the phone to boot to decrypt all this again.

I've seen that it could be possible to boot the phone from SDCard. Does anyone know how this oculd work?
I have a universal eMMC reader that supports the eMMC used, but don't know if it will work as long as the CPU is powered on.

Has anyone a idea what could be defect or how I can do a further diagnose of the phone to resuce my data?

Hope someone can help. Thanks!


Forum Moderator
Staff member
@krater42 Welcome to XDA. When you joined, you agreed to follow the Forum Rules. Please take a moment to review them now, with special attention paid to Rule 5:
5. Create a thread topic or post a message only once, this includes external links & streaming media.
As a large forum, we don't need unnecessary clutter. You're free to edit your message as you like, so if you do not receive an answer, revisit your message and see if you can describe your problem better. Not everyone is online at the same time so it might take a while before you receive an answer.
  • You can bump your unanswered question once every 24 hours
  • Duplicate threads and posts will be removed
  • Always post in an existing thread if a topic already exists, before creating a new thread.
  • Use our search function to find the best forum for your device.
The duplicate post you created will be removed.


New member
Jun 3, 2023
Sorry for that, read the 5. rule too late. What do you think, were is the best place for this topic? Which one should I delete?


New member
Jun 3, 2023
Okay, new information. I ****ed up the key combination and now as I do it right, I can boot into ODIN mode.
I tried to read out the pid with heimdall and this doesn't works. On the other phone I tried the same and it works. So I suppose it's not a issue of my setup.