S4 will not automatically connect to 5Ghz Wi-FI Network

Search This thread

trenzterra

Senior Member
Dec 5, 2010
373
43
Anyone experiences this bug with the GS4 too?

When I toggle Wi-Fi off and on, it does not automatically connect to my 5GHz network. Instead, it just says 'Saved, Secured'. I must manually select the network before it connects to it.

However, for 2.4GHz networks, toggling Wi-Fi off and on will automatically search for a 2.4Ghz to connect.
 

acasals

New member
Jun 2, 2013
1
3

Same problem here. No clues so far.

---------- Post added at 02:36 AM ---------- Previous post was at 02:29 AM ----------

Same problem here. No clues so far.

OK - just solved it. Go to your router settings for the 5GHz network and change the channel from "Auto" to 36 or 44 - both are reportedly working fine for another reported Samsung glitch but I'm guessing the real problem here is the "Auto" setting. Hope it helps.
 

DarkPrince917

New member
Nov 20, 2010
3
0
Worked!

Thank you. The problem for me was on my GS3 (d2spr). My 2.4GHz would connect but the 5GHz would stay saved and not connect.

All the recent Roms that I flash have this problem. When I flashed back to the older roms, the 5GHz worked fine. Changing the channel worked.
 
Feb 8, 2013
39
6
Wireless RT-N66U N

Thanks I have been having problems with my Galaxy Note 2 not auto connecting to my N 5Ghz working 100% now from changing setting from auto to 36 or 44 awesome
 

klau1

Senior Member
Jan 1, 2008
1,793
389
Turns out it's because of this:

There's a better fix for this.

In /system/etc/wifi there are two files:
nvram_net.txt and nvram_net.txt.us

The installed one is for Great Britain, and the other one (.us) is for the United States.

Rename nvram_net.txt to nvram_net.txt.gb and rename nvram_net.txt.us to nvram_net.txt
This makes two changes. changes "ccode" to "ccode=US" and adds "regrev=5".

This bug affects many of Galaxy line.
 
  • Like
Reactions: Slash8915

dcmoors

New member
Nov 21, 2017
1
0
A bettter solution? Involves no hacking

Same problem here. No clues so far.

---------- Post added at 02:36 AM ---------- Previous post was at 02:29 AM ----------



OK - just solved it. Go to your router settings for the 5GHz network and change the channel from "Auto" to 36 or 44 - both are reportedly working fine for another reported Samsung glitch but I'm guessing the real problem here is the "Auto" setting. Hope it helps.

The above method worked for me, but I experimented and found a possible better solution:-

My Talktalk router uses the same SSID for 2.4 and 5 GHz bands. I tried changing the SSID for the 5GHz band by adding "5GHZ" to the end of the name.
The phone fails to detect the SSID when scanning for networks, however if on the phone wi-fi settings page I scroll to the end, click Add a Network, manually enter the new SSID, select the correct security method and enter the password, the phone connects.
Thereafter, if I turn wi-fi off and on, the phone then always connects automatically to the 5GHz SSID.
Both SSIDs are now displayed in the list of networks previously accessed, so I can switch from one to the other if needed.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3

    Same problem here. No clues so far.

    ---------- Post added at 02:36 AM ---------- Previous post was at 02:29 AM ----------

    Same problem here. No clues so far.

    OK - just solved it. Go to your router settings for the 5GHz network and change the channel from "Auto" to 36 or 44 - both are reportedly working fine for another reported Samsung glitch but I'm guessing the real problem here is the "Auto" setting. Hope it helps.
    1
    Turns out it's because of this:

    There's a better fix for this.

    In /system/etc/wifi there are two files:
    nvram_net.txt and nvram_net.txt.us

    The installed one is for Great Britain, and the other one (.us) is for the United States.

    Rename nvram_net.txt to nvram_net.txt.gb and rename nvram_net.txt.us to nvram_net.txt
    This makes two changes. changes "ccode" to "ccode=US" and adds "regrev=5".

    This bug affects many of Galaxy line.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone