[S905x] Help with Mi Box (Android TV MDZ-16-AB) Bootloader Unlock And Root

Search This thread

Novamaster

New member
Aug 28, 2020
1
0
Can someone help me change the language from Chinese to English. I have tried everything and I am lost. Thanks
 

bigtalker

Senior Member
May 20, 2007
295
62
Can someone help me change the language from Chinese to English. I have tried everything and I am lost. Thanks

If you truly own model mdz-16-ab, selecting a different language from among the several dozens supported is a simple click of the remote when you're in settings menu.

What version androidtv is currently running?
 

tonypur

Member
May 3, 2013
20
3
Re-install stock launcher

I removed the stock launcher some time ago and can't remember the exact commands used, and I'm not able to get the stock launcher reinstalled and working.

It looks like I used the commands 'pm uninstall -k --user 0 com.google.android.leanbacklauncher' and 'pm uninstall -k --user 0 com.google.android.tvlauncher' when on Oreo. Does anyone know how to reverse these commands?


Edit: Answering my own question, I found the command 'adb shell cmd package install-existing com.google.android.tvlauncher' and 'adb shell cmd package install-existing com.google.android.leanbacklauncher' reverses the above commands.

I'm not sure why I wanted to go back to the stock launcher. It's horrible.
 
Last edited:

cyber_anandh

New member
Mar 3, 2022
2
0
Hi I'm using mi box 4, i trying more then 3 days to unlock bootloader but i did not succeeded, can any one help me to unlock bootloader and install the custom rom
 

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    Found the link for google's servers: android.googleapis.com/packages/ota/xiaomi_once_once/87cf61497f0f6c6ed49ff22bc9b8bd3d3167b9e5.zip
    and latest Android 6.0 r750 in case you want to revert: android.googleapis.com/packages/ota/xiaomi_once_once/4798e23749378f1bc5a7a072b2d9351a980abbfb.zip
    Happy Easter everyone!
    10
    I was able to get this rooted, but haven't been able to unlock the bootloader.
    1. Download MiBOX3S_USA_once_r454.zip from 4PDA.ru unrar it and put it on a USB stick.
    2. Turn on adb from the developer options, connect, and "adb reboot recovery"
    3. Unplug the USB cable and plug in the USB stick. Choose "Install from EXT">"From UDISK", and flash the update.
    4. Reboot it and plug the USB cable back in. Re-enable usb debugging (if your settings were cleared) then disable dm-verity by typing "adb root" then "adb disable-verity" and then "adb reboot"
    5. Once it reboots, you are now free to modify the system partition as you see fit by typing "adb root" then "adb remount". you are effectively 'rooted' at this point.

    I went further and manually installed SuperSU to enjoy some rooted app goodness, but to be honest, it was a pain.

    One thing I noticed is that the most recent OTA wipes your changes, so you may want to disable updates until I can come up with a more elegant solution:

    Code:
    adb root
    adb shell pm disable com.google.android.gms/.update.SystemUpdateService
    adb shell pm disable com.google.android.gms/.update.SystemUpdateService$ActiveReceiver
    adb shell pm disable com.google.android.gms/.update.SystemUpdateService$Receiver
    adb shell pm disable com.google.android.gms/.update.SystemUpdateService$SecretCodeReceiver
    adb shell pm disable com.google.android.gsf/.update.SystemUpdateActivity
    adb shell pm disable com.google.android.gsf/.update.SystemUpdatePanoActivity
    adb shell pm disable com.google.android.gsf/.update.SystemUpdateService
    adb shell pm disable com.google.android.gsf/.update.SystemUpdateService$Receiver
    adb shell pm disable com.google.android.gsf/.update.SystemUpdateService$SecretCodeReceiver

    ** edit **
    I have a bootloader unlock authorization for this device from xiaomi, but I can't seem to get it into either bootloader mode or EDL mode. Any help on this front would be appreciated.
    10
    supersu script

    The attached script will install supersu after following my previous guide.

    12/19/2016 -- updated script --

    The script represents the steps I manually took to install supersu, and should work, but is itself untested. You can open up the .bat file with notepad to see what's going on.

    Unzip the attached file on your desktop or somewhere, then double click InstallScript.bat

    IMPORTANT (As I've stated previously): Due to an issue with SElinux, make sure USB Debugging is ALWAYS ON prior to rebooting the box, otherwise you'll need to reinstall the firmware.

    If you hang after a reboot, do this:
    1. in your connected computer, in a shell, type "adb root"
    2. type "adb shell setenforce 0"
    This can only be done if usb debugging is set to ON prior to the reboot, otherwise you'll need to reinstall the firmware.
    8
    USA MDZ-16-AB updated supersu script

    I believe I've corrected to bootloop issue and submit an updated script.
    8
    this isn't related to root but here's the beta nougat update for those interested
    mega nz/#!xaZgBCrY!l65tcGGt9izhZ2k1HCtka6w3H5-3qXSmq_sBcZn6uy8