Question samsung a22 4G SM-A225F TWRP GSI rom download

Search This thread


New member
Mar 29, 2023
Hi everyone,

I'm writing this blog post to ask for some help from the XDA community. I have a Samsung A22 SM-A225F and I want to install a custom ROM on it, preferably an Android 12 GSI. However, I'm having some trouble getting it to boot properly.

I'm following the directions on this blog post which claims to have successfully installed Android 12 GSI on the same device. The steps I'm following are as follows:
  1. Use Odin tool to flash the stock verified ROMs on my phone to start from zero.
  2. Flash the (magisk patched.tar) file on AP
  3. Boot to Android and set it up then install Magisk app to check for root (I'm doing this because it doesn't work otherwise)
  4. Flash TWRP and run multidisabler then boot again to check if everything is working.
  5. Finally flash the system.img, I'm not sure about vbmeta so I'm skipping it.
But I keep getting a bootloop no matter what I try, I've tried wiping cache and everything.

Weirdly enough I have flashed stock Android like two days ago except that it actually booted to set up but it didn't detect the network and kept mini rebooting from time to time.

I've tried the steps in that blog for Android 11 to flash crDroid but that also didn't work, I've also tried flashing crDroid even when following the steps for Android 12. Still no success.

I'm wondering if anyone has any idea what I'm doing wrong or what I can do to fix this issue. I've read some other guides on how to install custom ROMs and GSIs on Samsung devices without TWRP but they seem too complicated for me.

If anyone can help me out or point me in the right direction, I would really appreciate it. Thanks in advance! and i'll gladly provide any information required when i have time as it's currenlty night time