Samsung A30 Stuck in Donwloading... (Download Mode)

Search This thread


Mar 10, 2018
Tried to download TWRP onto my unrooted device (Galaxy A30 exynos) with Odin and now my phone is stuck on "downloading" screen. When I try to cancel (restart phone) it goes to the startup/booting screen for less than a second and then jumps back to "downloading". It says this at the top left corner of the screen:
recovery: Error validating footer (6) CUSTOM RECOVERY VBMETA A305F D0S60UD3. 38308538R

The bootloader is unlocked.
Using Odin 3.14
and downloaded twrp from the official website.

SO what can I do now to fix it like either go back to how it was or successfully flash twrp. I have tried flashing stock firmware doesn't work I get error on ODIN. I tried to flash only the vbmeta.tar from an earlier twrp.img I found on XDA that didnt work as well. How can I fix this? Or maybe go back to how it was. Thanks in advance.


Senior Member
Apr 3, 2014
Samsung Galaxy A52 4G
Looks like vbmeta is preventing you to boot your device. It's responsible for checking the integrity of your phone and it's detecting that you have flashed an unofficial recovery.img

I'm surprised that no guides mention about disabling vbmeta. I don't know if flashing a blank vbmeta and flashing a disabled vbmeta are the same thing though. I usually patch my AP_ file with the Magisk app and inside there's always a patched vbmeta to prevent this type of situation.

Maybe someone with the actual device can share an actual disabled vbmeta.img

OR, you can just install your stock recovery and flash TWRP later


May 30, 2021

Just ran into this one...

Thnx @ShaDisNX255

Here's a packed tarball of official TWRP 3.6.1_9-0 (latest at time of writing) with patched vbmeta.img

original vbmeta.img from stock A305FDDU6CVG2 Android 11 (latest at time of writing)
Patched with magisk 23

Just boot into recovery and flash as usual to get root