Samsung Galaxy A8 SM-A530F stuck on Samsung logo after recovery boot

Musmur

New member
Jan 22, 2021
3
0
11
Hello All,

I have a galaxy a8 that I tried to boot into download mode to check if my drivers are working on the PC and it's stuck on the Samsung logo now. The problem is that I have data on it that are important and I have to save otherwise I would perform factory restart or flash it with regular CSC with Odin. I tried flashing the latest official firmware with HOME_CSC binary but it's still stuck.

I also tried simple stuff as cleaning cash and leaving it off for a day to power-drain but it's still stuck.
Can somebody please advise on any tips that I should try I been trying to unblock it for days

Thank you in advance
 

Sportsmaster

Member
Jan 15, 2016
10
0
21
Have your phone serviced at a phone repair shop. You don't have the tools to recover your phone properly. You messed up now pay for professional help. To put it bluntly. Learn your lesson and don't play with your phone.
 

Adil Tariq

Senior Member
May 29, 2015
149
45
48
Hey man, you said you cleared the cache it means you can boot into twrp recovery mode, right? If you can, just boot into recovery mode and connect your device to pc/ laptop, it will be connected via MTP. After this you can copy any and all data from your device. If you want your app data as well, make a nandroid backup of your device from twrp ( doesn't matter if you jave boot loop) and after formating your phone you can use titanium backup to extract app data feom nandroid backup. Hope this helps...