• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Samsung Galaxy Tab A 8.0 SM-T290 2019, unable to unlock bootloader

Search This thread
Apr 7, 2019
9
1
Can anyone with this device provide the exact steps to unlock the bootloader. I have tried the many ways offered via google search and none seem to work. I have USB debugging and OEM unlock allowed in the device settings. I can boot into the bootloader via keys and using ADB. I've tried various key combos to get to the page (supposedly available) that allows one to switch the bootloader from locked to unlocked - no luck.

All help appreciated.
 
Apr 7, 2019
9
1
Do you mean that the command fastboot oem unlock doesn't work?
Note that: Unlocking bootloader wipes all device's data!
Thanks for your reply and new suggestion. No that does not work either. I go to bootloader download mode, enter the command "fastboot oem unlock" and get "waiting on device". I am connected to the device as I get a response when queried "adb devices". Any other thoughts/suggestions?
 

XDHx86

Senior Member
Nov 1, 2017
333
1
57
openuserjs.org
Samsung Galaxy Star
Thanks for your reply and new suggestion. No that does not work either. I go to bootloader download mode, enter the command "fastboot oem unlock" and get "waiting on device". I am connected to the device as I get a response when queried "adb devices". Any other thoughts/suggestions?
You're supposed to boot the device to fastboot/bootloader by adb reboot bootloader not download mode.
Also to detect the device in fastboot the command is fastboot devices
Please if you're new to this stuff then don't do it. May I ask why you're trying to unlock bootloader?
 
Apr 7, 2019
9
1
You're supposed to boot the device to fastboot/bootloader by adb reboot bootloader not download mode.
Also to detect the device in fastboot the command is fastboot devices
Please if you're new to this stuff then don't do it. May I ask why you're trying to unlock bootloader?
Again, thanks for your reply. I have previously installed Lineage on a Fire HD8. So not quite a newbie but everyone is new once - right? I am trying to install Lineage on this SM-T290.
The command "fastboot devices" is not returning anything but "adb devices" does which leads me to believe my hardware connections are correct. "adb reboot bootloader" does take me to the bootloader but it indicates download mode.

I suspect I am missing something simple. Your help is appreciated. Thanks
 

XDHx86

Senior Member
Nov 1, 2017
333
1
57
openuserjs.org
Samsung Galaxy Star
You need to enable OEM unlock and debugging mode first. And make sure the PC is allowed to debug on your phone.
Also if fastboot command doesn't return anything then most likely you need the correct device driver, you can get it from here.
Alternatively you can try this method:
  1. Boot to download mode.
  2. Long press volume up. This will wipe your data and automatically reboot.
  3. After reboot you should have unlocked bootloader and OEM unlock option greyed out in the settings.
Installing custom ROM doesn't make your device better.
 
Apr 7, 2019
9
1
You need to enable OEM unlock and debugging mode first. And make sure the PC is allowed to debug on your phone.
Also if fastboot command doesn't return anything then most likely you need the correct device driver, you can get it from here.
Alternatively you can try this method:
  1. Boot to download mode.
  2. Long press volume up. This will wipe your data and automatically reboot.
  3. After reboot you should have unlocked bootloader and OEM unlock option greyed out in the settings.
Installing custom ROM doesn't make your device better.
Thanks but still no go.
  • I have enabled usb debugging and enabled OEM unlock (both done previously)
  • I have (had) installed latest drivers previously
  • adb devices returns my unit data
  • adb reboot bootloader command puts device in "download mode !!"
  • fastboot devices returns "waiting on device"
  • fastboot oem unlock also returns "waiting on device"
  • Attempted your alternative method, no go
I understand custom ROM doesn't make device better. I like the learning challenge. Hope you understand. Appreciate your help thus far and any other ideas you might have.
 

Heeni

Senior Member
Dec 25, 2020
82
17
Auckland NZ
Here's how I did it.

Enable Developer mode, usb debug, OEM unlock (you've already done those, by the sound of things).

Power the tablet OFF.

Have your USB cable plugged into the computer but NOT the tablet.

Hold the volume up AND volume down keys simultaneously, then connect the USB cable.

The tablet will vibrate and show a blue-green screen, with Warning at the top and a white triangle with an exclamation mark at the bottom. (This is different from download mode.)

From here, long-press volume up to go into device unlock mode. Follow the instructions.
 
Apr 7, 2019
9
1
Here's how I did it.

Enable Developer mode, usb debug, OEM unlock (you've already done those, by the sound of things).

Power the tablet OFF.

Have your USB cable plugged into the computer but NOT the tablet.

Hold the volume up AND volume down keys simultaneously, then connect the USB cable.

The tablet will vibrate and show a blue-green screen, with Warning at the top and a white triangle with an exclamation mark at the bottom. (This is different from download mode.)

From here, long-press volume up to go into device unlock mode. Follow the instructions.
Thanks again but no luck. Let's start with some basics:
  • My device is a Galaxy Tab A SM-T290 8.0 2019 one UA core version 2.1
  • Android 10
  • When I, with power off, press both UP & DOWN volume keys simultaneously, wait a few seconds, insert the USB cable (already in computer), I get a vibration but then a circle with a lightning bolt that shows the battery charge status. The screen does not go blue-green and there is no warning.
  • I have tried releasing the buttons after the vibration and after I see the battery power circle. No change.
I continue to appreciate your help but feel I am missing something simple or my device is not same as yours.

Let me know if you have given up!
 

Heeni

Senior Member
Dec 25, 2020
82
17
Auckland NZ
Thanks again but no luck. Let's start with some basics:
  • My device is a Galaxy Tab A SM-T290 8.0 2019 one UA core version 2.1
  • Android 10
  • When I, with power off, press both UP & DOWN volume keys simultaneously, wait a few seconds, insert the USB cable (already in computer), I get a vibration but then a circle with a lightning bolt that shows the battery charge status. The screen does not go blue-green and there is no warning.
  • I have tried releasing the buttons after the vibration and after I see the battery power circle. No change.
I continue to appreciate your help but feel I am missing something simple or my device is not same as yours.

Let me know if you have given up!
I see that your tablet has One UA core.

That may make a difference. I can't remember now where I saw it (somewhere on these forums), but I recall seeing that One UI Core is more locked down than the "ordinary" One UI version. Incidentally, I get the same response as you if I plug the tablet into a charger (not computer) while pressing both volume keys.

I'll mention at this point that I'm on the point of going back to stock and relocking the bootloader, because I've not been able to have a custom ROM or recovery and a screenlock (PIN, password, or pattern) at the same time, and no one seems to know any workaround for this. I'm starting to wonder if my tablet is somehow odd. :)

It's a nice piece of hardware, but a right pain to do any mods to, and Samsung's extra security "features" can cause problems.
 
Apr 7, 2019
9
1
I see that your tablet has One UA core.

That may make a difference. I can't remember now where I saw it (somewhere on these forums), but I recall seeing that One UI Core is more locked down than the "ordinary" One UI version. Incidentally, I get the same response as you if I plug the tablet into a charger (not computer) while pressing both volume keys.

I'll mention at this point that I'm on the point of going back to stock and relocking the bootloader, because I've not been able to have a custom ROM or recovery and a screenlock (PIN, password, or pattern) at the same time, and no one seems to know any workaround for this. I'm starting to wonder if my tablet is somehow odd. :)

It's a nice piece of hardware, but a right pain to do any mods to, and Samsung's extra security "features" can cause problems.
Hey! Once again want to thank you for hangin' in with me on this. So, it seems we have slightly different machines. I purchased mine at COSTCO. They offer a lot of good stuff at low prices. I've noticed, however, they tweak their offerings a little bit so they can honestly say "you can't get this somewhere else." Perhaps the difference in our machines explains that.

I definitely had my unit plugged into the USB port on my computer, not a power supply.

My only purpose in attempting this was the satisfaction of doing it and having two tablets with different operating systems.

Thanks again for your help. All the best!
 
  • Like
Reactions: Heeni

Heeni

Senior Member
Dec 25, 2020
82
17
Auckland NZ
Here's the reference to One UI Core that I was thinking of: https://forum.xda-developers.com/t/root-for-sm-t290-tab-a-8-0-2019.3965624/post-84355183

I'm not based in North America, and the local market isn't big enough to have retailer-specific variants (or, at least, I've never heard of any), so I probably have a standard item. But from what I've read, specially locked-down items are reasonably common in the US. Which doesn't make it any less frustrating. :mad:
 
Apr 7, 2019
9
1
Here's the reference to One UI Core that I was thinking of: https://forum.xda-developers.com/t/root-for-sm-t290-tab-a-8-0-2019.3965624/post-84355183

I'm not based in North America, and the local market isn't big enough to have retailer-specific variants (or, at least, I've never heard of any), so I probably have a standard item. But from what I've read, specially locked-down items are reasonably common in the US. Which doesn't make it any less frustrating. :mad:
I read the post and tried the extra step of holding the up volume key when the power screen came on. It also didn't work. Unless something new shows up, my quest to unlock this bootlocker is over. I'll find some other technical challenge to chase.

I had the thought of contacting Samsung to see if they would tell me how to do this. My unit is well out of warranty so why should they care? Likely they wouldn't tell me anything but .....

I'm on Denver CO. Where are you? In my work and fun travels I've had the opportunity to visit many parts of the world. Perhaps I've been to your country?

Again thanks for all your help. I could not have gotten as far as I did without it.
 

bignikescar

Member
Aug 29, 2010
19
2
I read the post and tried the extra step of holding the up volume key when the power screen came on. It also didn't work. Unless something new shows up, my quest to unlock this bootlocker is over. I'll find some other technical challenge to chase.

I had the thought of contacting Samsung to see if they would tell me how to do this. My unit is well out of warranty so why should they care? Likely they wouldn't tell me anything but .....

I'm on Denver CO. Where are you? In my work and fun travels I've had the opportunity to visit many parts of the world. Perhaps I've been to your country?

Again thanks for all your help. I could not have gotten as far as I did without it.


Try method below. It worked for me.
 

lewmur

Senior Member
Apr 30, 2011
1,857
399
Try method below. It worked for me.
Holding vol up and down, with the tablet off, and plugging in the USB from PC to tablet, works. And it makes no difference which end of the cable you plug in last, so long as the buttons are already pressed before both ends are attached.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I see that your tablet has One UA core.

    That may make a difference. I can't remember now where I saw it (somewhere on these forums), but I recall seeing that One UI Core is more locked down than the "ordinary" One UI version. Incidentally, I get the same response as you if I plug the tablet into a charger (not computer) while pressing both volume keys.

    I'll mention at this point that I'm on the point of going back to stock and relocking the bootloader, because I've not been able to have a custom ROM or recovery and a screenlock (PIN, password, or pattern) at the same time, and no one seems to know any workaround for this. I'm starting to wonder if my tablet is somehow odd. :)

    It's a nice piece of hardware, but a right pain to do any mods to, and Samsung's extra security "features" can cause problems.
    Hey! Once again want to thank you for hangin' in with me on this. So, it seems we have slightly different machines. I purchased mine at COSTCO. They offer a lot of good stuff at low prices. I've noticed, however, they tweak their offerings a little bit so they can honestly say "you can't get this somewhere else." Perhaps the difference in our machines explains that.

    I definitely had my unit plugged into the USB port on my computer, not a power supply.

    My only purpose in attempting this was the satisfaction of doing it and having two tablets with different operating systems.

    Thanks again for your help. All the best!