• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Samsung Galaxy Tab Pro 10.1 (SM-T525) TWRP twrp-3.0.2-0-picassoltexx.img ,Odin fails to flash. [FIXED]

Search This thread
Hi maybe someone has any ide what I do wrong here.
I am trying to install TWRP (latest available for SM-T525 - 10.1 inches LTE), but after tryin all Odin versions available and at least two versions of TWRP I'm stuck.

This is the output from odin (tried to run as admin/non admin) at least 2 invocations. MD5 sum verified - ok.

<ID:0/004> Added!!
<ID:0/004> Odin engine v(ID:3.1401)..
<ID:0/004> File analysis..
<ID:0/004> Total Binary size: 10 M
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> NAND Write Start!!
<ID:0/004> SingleDownload.
<ID:0/004> twrp-3.0.2-0-picassoltexx.img
<ID:0/004> FAIL!

<ID:0/004>
<ID:0/004> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)


Additionally on the tablet screen I get newline in red :
Unsupport dev_type

The blue progress bar is few pixels wide but it gets stuck as well and I have to restart the tablet to get back to the system or to the recovery.

Any ideas are really highly appreciated.
Thanks in advance.

P.S. This is annoying when the device is getting more and more unusable because of the software (now youtube is not working anymore on this old kitkat 4.4.2) while the hardware is doing well.




FIXED:
I had to rename the image file to recovery.img - it helped.
 
Last edited:

Dencjusz

New member
Apr 14, 2017
2
0
How did you managed to flash that recovery? I have also softbricked my T525 :( - reboots only to fastboot (Odin mode), but Odin can't even recognize it (not even PC sound of plugged device etc.). Stuck on Lineage bootloop and rebooting twrp (wrong version probably:(.