Screen Off = WiFi Off: How to Fix?

Search This thread

benjimen

Senior Member
Oct 18, 2007
206
0
My WiFi shuts off every time my screen blanks out. I can see this being good if I were on battery, but personally only use WiFi when plugged into A/C. Is there a registry edit that'll change this 'feature' and leave WiFi running?! Thanks!
 

Snapphane

Senior Member
Sep 10, 2008
71
1
Yeah, that fix would be nice!

I noticed that Skype by-passes idle-mode in it's software and that's one way to fix it. To bad that not all apps do that...
 

gastonfama

Member
Aug 31, 2008
11
0
Buenos Aires
If you use it only when charging, you can configure your cruise to stay on when the device is charging.
Mi cruise is in Spanish, so i will translate the options as i think it must be in english.
Go to START, CONFIGURATION, SISTEM, ENERGIE, ADVANCED
And there you can configure the options to turn off the device when is on battery and when it is charging.
Hope it will be usefull.
 

benjimen

Senior Member
Oct 18, 2007
206
0
That was an answer to a different question, perhaps someone will find your tip useful. Thanks though.

The question is how to stop WiFi from shutting off when the screen blacks out, whether or not it's plugged into AC.

If you use it only when charging, you can configure your cruise to stay on when the device is charging.
Mi cruise is in Spanish, so i will translate the options as i think it must be in english.
Go to START, CONFIGURATION, SISTEM, ENERGIE, ADVANCED
And there you can configure the options to turn off the device when is on battery and when it is charging.
Hope it will be usefull.
 

02xda2

Senior Member
Jul 4, 2005
283
12
Hi, Benjimen, did you check Schap's Advanced Config 3.2.0.0, there are some settings for Wifi. I haven't tweaked/tested any of them since I don't use much of Wifi. Hope it may help you.
 

benjimen

Senior Member
Oct 18, 2007
206
0
Thanks -- I've read about that, but haven't tried it. Was really hoping someone knew the registry tweak to accomplish it, looks like I'm out of luck though :(

It sounds like you're 'guessing' it might be a feature? Does anyone who has tried the program actually know and care to post factual info? I took a look at the info for the software, and it does't appear to be one of the tweaks, at least not in the example screens.

Hi, Benjimen, did you check Schap's Advanced Config 3.2.0.0, there are some settings for Wifi. I haven't tweaked/tested any of them since I don't use much of Wifi. Hope it may help you.
 
Last edited:

gastonfama

Member
Aug 31, 2008
11
0
Buenos Aires
I have the Schap's Advanced Config 3.1.0.0 installed and i cant find enything about that, only to shutdown the wifi if there is no activity....
I alsa didnt know that there was a 3.2.0.0 version, will try to check that out later.
Chears.

PS: sorry benjimen if my previous post didnt help...:(
 

Rudegar

Retired Moderator
Jul 16, 2003
12,496
49
45
DK
the problem is when one click the power button one dont
turn off the screen

one suspend the device power most systems down

you can get programs which just turn off the screen
which would leave the wifi on
but the device run out of batt pretty fast if it's
not suspented
 

benjimen

Senior Member
Oct 18, 2007
206
0
In Polaris.Aserg.WM61.WWE ROM WMP plays when the screen is switched off, Probably you can check with him for your requirement.
...doesn't make a whole lot of sense, as this topic is regarding WiFi. Thanks though...
...you can get programs which just turn off the screen which would leave the wifi on but the device run out of batt pretty fast if it's not suspented...
...yes, you can get lots of programs to do lots of things -- would be relevant of you to provide an example, which programs are you referring to? Again, not interested in what WiFi does to the battery, but thanks for that reminder ;)
 

Snapphane

Senior Member
Sep 10, 2008
71
1
benjimen, as was given as a tip changing the time-out is a working temporary solution.

I did something similar with a software that allowed me to make "user profiles". The "work" profile had a longer time-out just to keep my wi-fi active :)
 

snworf

New member
Sep 21, 2008
1
0
How frustrating I saw this topic and thought it would help me do what the OP is trying to do, but it's just a bunch of non-answers Don't people read the original question before answering?
 

benjimen

Senior Member
Oct 18, 2007
206
0
Thanks for trying Rudegar, but who really wants to install another layer of junk just to accomplish what should be an option.

Thank you 02xda2, I found a tweak in the thread you linked to, the registry entries did the trick! Here they are for anyone who might be interested:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Power\State\Suspend\{98C5250D-C29A-4985-AE5F-AFE5367E5006}
-change (Default) DWORD Dec to 1
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Power\State\Resuming\{98C5250D-C29A-4985-AE5F-AFE5367E5006}
-change (Default) DWORD Dec to 1
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Power\State\Unattended\{98C5250D-C29A-4985-AE5F-AFE5367E5006}
-change (Default) DWORD Dec to 1
If you need to change it back, the default entry for all of them (at least on my Cruise) was set to 4
 
Last edited:

milukr

Member
Apr 24, 2008
12
0
enble wifi on stanby mode

My WiFi shuts off every time my screen blanks out. I can see this being good if I were on battery, but personally only use WiFi when plugged into A/C. Is there a registry edit that'll change this 'feature' and leave WiFi running?! Thanks!

Enable schaps advanced config 3.2 -> menu -> more settings -> connections and check "enable wifi on standby mode"

cheers
 

Attachments

  • clipboard.jpg
    clipboard.jpg
    39.4 KB · Views: 61

benjimen

Senior Member
Oct 18, 2007
206
0
Thanks, but I got it with just the registry entry. I've always had bad luck with the do-it-all tweaker programs, at some point set something I shouldn't and mess something up.

I was looking for a way to do it via a registry edit, and found it thanks to another poster here -- if anyone is looking to do the same it's a couple posts back, or click here.

Enable schaps advanced config 3.2 -> menu -> more settings -> connections and check "enable wifi on standby mode"

cheers