[Script/APK] S2E (simple2ext): app2sd for CyanogenMod7

Search This thread

alexk1781

Member
Dec 4, 2007
25
8
0
Florence
I'm having a problem with S2E on my HTC Droid Incredible. I had been managing the dreaded "low storage space" message through a combination of a [relatively] small number of apps, regular app cache clearing, and the occasional clear data for a few of the more space hungry apps. I've grown tired of that, so I decided to try S2E. Everything works great with it except what I need the most. :) I've got plenty of room for my apps, app cache, Dalvik cache, etc. but that stupid 150MB limit for Application Data (data\data) is driving me crazy. I have multiple email accounts that I have to maintain a fairly lengthy history on, due to how and how often I use my phone for those purposes. That takes up a lot of app-data space. Several other apps I use, including a couple for business purposes, are also at least somewhat hungry storage hogs. As I mentioned, I can clear data on a few apps to make the notification go away but, at this point, I'm only getting down to about 25MB of free space after clearing data on the apps I can stand to clear. Bottom line, I can move the Applications, Private Apps, Dalvik Cache, and Download Cache to the sd-ext partition but I cannot move the Application Data (data\data) to the sd-ext partition. I can select it but, no matter how long I leave it nor how many times I reboot, it just keeps saying "Reboot is Required!" and never moves it to the sd-ext partition. I can un-check the others and the next reboot will move them back to the phone then re-check them and it will move them back to the sd-ext partition. It just seems to completely ignore the checking of the Application Data box.

Because of the way my app/cache/storage usage tends to run I would like to put my Applications, Private Apps, and Application Data on the sd-ext partition and leave the Dalvik Cache and Download Cache on the phone for a little better performance.

Here's what I've got:
- HTC (Verizon) Droid Incredible
- Model: ADR6300
- ROM: CyanogenMod-7-11162011-Nightly-Inc
- Android Version 2.3.7
- Baseband Version: 2.15.00.07.28
- 16GB Patriot Class 6 MicroSD card

Here's what I've tried:
1) Did full CWM Backup
2) Backed up MicroSD card.
3) Installed S2E
4) Used ROM Manager / CWM to format the SD Card with a FAT32 primary partition for storage and a 512MB Ext3 Primary Partition for the sd-ext partition.
5) Restored backed up MicroSD card files to the FAT32 partition.
6) Wiped cache partition and Dalvik Cache in CWM and booted into CM7.
7) Opened S2E, and selected Applications and Private Applications to be moved.
8) Rebooted the phone.
9) Launched S2E to check the status. Success.
10) Used FreeSpace and DiskManager to verify storage usage. Success, except for the fact that this did nothing to alleviate the storage space used / restricted for use for the data\data partition.
11) Performed steps 7-10 for the Dalvik Cache - success.
12) Performed steps 7-10 for the Application Data, having decided that this was going to be the only way to alleviate the problem --- unsuccessful.
13) Unchecked the Application Data checkbox and rebooted the phone.
14) Performed step 12 again - still unsuccessful.
15) Did some google/xda searching, finally ending up reading this entire thread.
16) Performed steps 13-14 again, unsuccessfully.
17) Following the advice of someone somewhere in this thread, I alternated letting the phone sit for a while with multiple reboots for about a day - still unsuccessful.
18) Read this thread and searched some more and decided to try an Ext4 partition instead of Ext3, increasing the size while I was at it.
19) Performed full backup in CWM.
20) Backed up MicroSD card.
21) Formatted MicroSD Card, creating FAT32 Primary Partition for storage and a 1GB Ext4 Primary Partition for the sd-ext partition.
22) Wiped cache partition and Dalvik Cache in CWM.
23) Restored MicroSD card and sd-ext partition.
24) Booted into CM7, everything was fine.
25) Opened S2E, checked the Application Data box, and rebooted - still no luck.
26) Played the reboot, reboot, wait, reboot, wait, reboot, reboot, wait game for a few hours - no luck at all.



I've downloaded the latest CM7 Nightly - July 2012, I believe - and installing that will be my next step unless I can get this working with my current ROM. I like this ROM - it works great, it's stable, and other than the frigging low storage space problem I've had no issues with it.


So, before I go that route, does anyone know anything else I can do to get the Application Data moved to the sd-ext partition with my current ROM?

Should I just go ahead and flash the newer ROM without messing with it anymore? Is there anything I should be wary of, any tips or tricks, and/or anything I should know before flashing this newer ROM?


Thanks.
 

sushdroid

Member
Feb 20, 2012
33
2
0
Bangalore
When I installed it and rebooted, it gave multiple app force close after the reboot and hence i had to reflash the rom. Any idea what went wrong? And can someone please tell me how to configure the settings safely so as to avoid this again?

I use CM 7.2 nightly on a GT-I5510 and a 1.4 GB ext4 partition on a class 6 samsung 8 GB SD card.
 

Zippy1970

Senior Member
Nov 8, 2005
132
9
38
S2E p------ me off.

I've been trying to get S2E to work for two days now. I'm running (a newly flashed) AmericanAndroid and I am trying to get it to store apps on the SD card.

First thing I did was create an EXT3 partition on my SD-Card using Partition Wizard on Windows. Next I installed S2E through the Play Store. Mind you, at that point S2E was the first thing I installed on my phone.

When I started S2E, it didn't see the EXT partition. Repartitioned the SD-Card, tried EXT4, reflashed the phone with AmericanAndroid, installed S2E. Still nothing. In the past two days, I tried everything I could think of but nothing worked. S2E never saw the EXT partition. Until today. I did the exact same thing I've done many times before now. Repartitioned the SD card (15GB FAT32 + 1GB EXT3), reflashed the phone, installed S2E. Rebooted.

This time it took a bit longer for the phone to start and when I started S2E it saw the EXT partition for the first time! It was also the first time I was able to tick any of the available move options.

So I ticked "Applications", "Application Data" and "Dalvik Cache" and rebooted the phone.

Again it took (much) longer for the phone to boot. When it was done booting, I checked if the EXT partition was mounted and if it contained any apps. It was and it did. I saw it had moved S2E to SD-Ext/App.

To test if it would automatically install new apps on the EXT partition, I started Play Store and installed a random app (Sky Maps to be precise). During the installation process, my phone rebooted spontaeously. I tried many times but each time my phone reboots. Either in the middle of downloading the app, or during installation.

You can see a video of this behavior on YouTube.

Oddly enough, the S2E icon has disappeared from my Launcher screen. It's still in my list of installed apps, but it's launcher icon has disappeared.

And the phone keeps rebooting randomly and I'm getting a million-and-one "Force Close" errors.

I'm getting incredibly frustrated by now. Anyone know what I'm doing wrong here?
 
Last edited:

alexk1781

Member
Dec 4, 2007
25
8
0
Florence
An update to my previous post...

Even though I hadn't received any replies to my previous post I went ahead and installed the latest nightly ROM update.

No change. It still seems to just ignore the checkmark next to the Application Data setting.

Any ideas? Anyone?


Sent from my HTC Droid Incredible using Tapatalk 2
 

karaern

Senior Member
May 24, 2008
858
85
0
beyond northern pole
An update to my previous post...

Even though I hadn't received any replies to my previous post I went ahead and installed the latest nightly ROM update.

No change. It still seems to just ignore the checkmark next to the Application Data setting.

Any ideas? Anyone?


Sent from my HTC Droid Incredible using Tapatalk 2

perhaps it should sound a little weird explanation but i found that when u full back up automatic restore is done by recovery or titanium back up that kind of problems are seen. when i made a back up recovery manually, i mean application by application by ttitanium back upm then the s2e is working without problems. of course i am also confused, because applications are seem to be in ext4 but after around 200 applications installed, i also see that low storage problem.
still dunno what to do.
 

optimusodd

Senior Member
Mar 15, 2011
586
153
0
Is there any way to manually chooses and stop some apps moving to the ext3/ext4 partition while keeping S2E installed ?Or any option that allows you to choose what you want to move to ext partiton/SD card/Internal memory ?
 

mwburden

Member
Feb 4, 2010
19
0
0
sd-ext not mounting?

I got a brand new 32GB microSDHC for my T-Mobile G2 running Cyanogenmod 7.1.

I used Clockwork to partition the new microSDHC with a 4GB ext4 partition and the rest FAT32.

I moved the contents of my old microSDHC to the FAT32 partition of the new microSDHC

I installed S2E, selected to move apps to the ext, and rebooted.

When the boot finished, nothing had moved. After some investigation, I found that sd-ext wasn't mounted.

I tried executing 05mountsd manually, and found that it does, in fact, properly mount sd-ext.

I installed links2sd, and it looks like /system/etc/init.d/11link2sd is executing properly, because the ext4 partition gets mounted on /data/sdext2.

As a final test, I added the line: echo "I was here" > /data/test.txt into the beginning of 05mountsd and rebooted again. No test.txt was created.

The permissions on 05mountsd appear to be correct:
-rwxr-x--- 1 root root 1541 Sep 30 09:45 05mountsd

Any idea why 11link2sd is executing, but 05mountsd doesn't seem to be?
 

mwburden

Member
Feb 4, 2010
19
0
0
After uninstalling link2sd and removing 11link2sd (apparently the uninstall for link2sd isn't very good about cleaning up stuff that link2sd leaves behind!), the ext partition was still mounting on /data/sdext2,

After some investigation, I found that link2sd had also added a /system/etc/install-recovery.sh script that was mounting the ext partition (and again, the link2sd uninstall did a crummy job of cleaning up after)

So I thought "Aha!", and I changed "/data/sdext2" to "/sd-ext" in /system/etc/install-recovery.sh and rebooted. After rebooting, I found that the ext partition is *STILL being mounted on /data/sdext2, even though my change to /system/etc/install-recovery.sh is still in place.

I'm currently running: find / -type f -exec grep -H sdext2 {} \;
to find anything else that's referencing /data/sdext2, but that will will take a while.

In the meantime, anyone know what I need to do to get the ext partition to mount correctly on /sd-ext?

I'm also wondering what ELSE the link2sd uninstall left behind...

---------- Post added at 01:19 PM ---------- Previous post was at 12:53 PM ----------

OK, looks like the answer is that links2sd renamed /system/bin/debuggerd to debuggerd.bin, and created a new /system/bin/debuggerd with the commands to do the mount and then execute debuggerd.bin.

It looks like links2sd takes a "shotgun" approach and stuffs the mount code in every script it can think of that might get executed at boot time, hoping that one of them will actually execute (and I'm still wondering what else it left behind!)

So I changed "/data/sdext2" to "/sd-ext" in /system/bin/debuggerd, and now the ext partition is mounting on /sd-ext.

Renaming debuggerd to debuggerd.bin and replacing it with a script seems like the kind of thing that a newbie developer that didn't know the correct way to get a script to execute at boot time might kludge a way to execute it. Unfortunately, I don't know the correct way that this should be done under Android, either, so at the moment I'm stuck with my modification of link2sd's kludge.

Anyone got any bright ideas for me?

---------- Post added at 01:37 PM ---------- Previous post was at 01:19 PM ----------

OK, sd-ext is correctly mounting, but S2E still isn't moving applications.

I enabled "Applications" in S2E, rebooted, and /sd-ext is still empty (except for a "lost+found" directory.)
 

OlegKrikun

Senior Member
Dec 11, 2008
61
118
0
St. Petersburg
S2E 3.0.0 Alpha 1

New test version of S2E avalible for downloading!
ChangeLog:
- Added compatibility with CM10 (untested)
- View and share last simple2ext boot log
- Light theme
- and more...

I have no device to test S2E, if you can test this version, do it!
This maybe not work on all cm version (7,9 or 10).
Backup you system before installing it!

Download: S2E 3.0.0 Alpha 1
 

xp24002000

Member
Apr 16, 2007
37
7
0
1. at mine (MildWild CM5.0 - CyanogenMod7.2) ..it always show "Moving from /data to /sd-ext, Reboot is required!" After reboot, still show the same thing... on all my checkmarks, but everything else is ok, application, private and dalvik cache are on sd-ext, applications is instaling on sd-ext and memory space info is ok.

2. with latest version s2e 3.0.2 every reboot time is up to 5 minute, in previously s2e 2.2.1 do not have this problem, my normal reboot is up to 40sec.
 

Attachments

  • 2012.10.20-09.55.10.jpeg
    2012.10.20-09.55.10.jpeg
    159.5 KB · Views: 332
  • 2012.10.20-09.55.29.jpeg
    2012.10.20-09.55.29.jpeg
    122.1 KB · Views: 292
  • 2012.10.20-09.55.48.jpeg
    2012.10.20-09.55.48.jpeg
    146.7 KB · Views: 274
Last edited:

Rex Dart

New member
Apr 3, 2012
2
0
0
Sorry if this has been asked before, but is CM7 necessary to use S2E? I'm using a stock (but rooted) Xperia Play / R800, and S2E just does not see my 2nd SD partition (ext3). Should I expect it to, or not?
 

unknown_anonymous

Senior Member
Dec 5, 2012
74
6
0
Sorry if this has been asked before, but is CM7 necessary to use S2E? I'm using a stock (but rooted) Xperia Play / R800, and S2E just does not see my 2nd SD partition (ext3). Should I expect it to, or not?

It didnt worked for me in stock....After installing cm it works flawlessly
Try it yourself
 

bassmadrigal

Senior Member
Jun 4, 2010
1,293
515
133
37
Newport News, Virginia
bassmadrigal.com
Sorry if this has been asked before, but is CM7 necessary to use S2E? I'm using a stock (but rooted) Xperia Play / R800, and S2E just does not see my 2nd SD partition (ext3). Should I expect it to, or not?

It didnt worked for me in stock....After installing cm it works flawlessly
Try it yourself

Most (if not all) stock ROMs have no support for sd-ext partitions. You would need to run a custom ROM that does support it (CM being one of the ones that does).
 

Negroid

Senior Member
Sep 25, 2010
126
16
38
Houston
i had this app running on cm10 for the sensation correctly, but when i did a fresh flash of the rom and tried to add s2e, it wont boot past the htc screen (so the boot animation doesnt even show) no matter how long i wait. does anyone know what exactly went wrong?
 

jan1jan1

Member
Sep 8, 2008
16
0
0
Having a strange issue. The option to move application data to ext is grayed out, and the total size isn't reported.

4c69ff91-06b4-8542.jpg


It looks like newer versions of S2E don't have the toggle for "advanced options" in Settings anymore, so I'm not sure what's going on.

I've tried uninstalling S2E and reinstalling, but the issue remains.

Sent from my Nexus One using xda app-developers app

I have the same issue.
Anyone can help?
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone