• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Secure Check Fail : recovery.img error on samsung A20s (SM-A207f) after flashing Magisk

Search This thread

Problem 1: First I tried to install magsik using twrp but I don't know after flash twrp it boot to download mode showing something like this [ <!> or <.> ( I don't remember clearly ) there was also an error saying (dev_block) ] so twrp not working on my devices​

Problem 2: Then i tried to install magisk by patch method after flashing using Odin [ it got flashed successfully ] but when I tried to boot it automatically boots to download mode and showing [ Secure Check Fail: recovery ] (i was able to recover my devices)

How I fix these problems I really wanted to root my device

*Bootloader is unlocked*

Device INFO

Model: SM-A207F
BUILD: QP1A. 190711.020A207FXXU2BUD4
Baseband Version: A207FXXU2BUC1
ONE UI: 2.0
Android: 10


If these problems didn't get fixed can I use an older version of android ( 9.0 ) to root my device
You needto add the su binary to android though i think there are some guidelines online
Ye, I have read some guides but the problem is to install SU binary I have to flash no-verity-opt-encrypt and for that, I have to use TWRP but TWRP is not working the only device and Thanks

Does Samsung Devices support fastboot if doesn't can I install it (I have a20s how I put that in recovery mode) ??

and Thnaks in Advance
Last edited: