Serious malfunction with Mi 10t lite

Search This thread

lux aeterna

Senior Member
May 11, 2014
79
5
Xiaomi Mi 10T Lite
One of the things I noticed first on the cell phone was that the screen did not respond at a specific spot (just where you answer the call). Later the screen stopped responding at random spots. I noticed it on gboard and it appeared mainly at the spot where the answer button appears. However, it was not just that spot and the problem was not consistently present. It was often but not permanent. That is, if I repeated the swipe procedure 2nd or 3rd time at the same point the screen would work normally (except for the spot for answering the call which was permanently dead). I also noticed the non-response of the screen through an application that you drag your finger and it leaves an imprint. A little later the cell phone stopped charging. It could not connect to the computer either. It was completely dead!

1st service: I took it to the technician believing that it has two problems, one with the screen and another one related to charging. The technician changed the charging plug, repaired the motherboard with reflow and flashed it. The phone started charging again, and here the strange things begin. The service man kept it close to 10 days but could not notice any problems on the screen! I found this strange and in fact I was sceptical, but when I took it in my hands the screen worked perfectly!

After the 1st service: A month later the touch screen problems started again. This time however they appeared in random spots. Of course there were spots points where I could notice it more frequently, but in general the spots that touch screen would not respond were random. As before, the 2nd or 3rd time I would swipe the same spot the problem would disappear. Until it reappeared, of course. I continued to operate the phone normally, having accepted that it would have this buzz. Unfortunately though , the phone died again!

2nd "service": I took it to the technician againand a few days later he called me to tell me that my phone was working and that the only thing he did was was to unplug and plug the battery. This seemed strange to him, but he thought it was probably a system failure that was resolved by removing and putting back the battery.

After the 2nd "service": So I took the cell phone, which was working normally, both the charge and the screen, and I left. 2-3 days later, the screen started having the same problem, and no later than a month the device died again!

3rd "service": I took it to the technician again and the phone worked just by unplugging an plugging a cable that connects the battery to the phone! No charging problem, no screen problem!

Do you have any idea what could be wrong and all this happening?