Setting up C.T.R.L.R in RetroArch

Search This thread

Kokosnuss

Member
Dec 28, 2014
27
16
Hi everyone!

I noticed that some of you are having problems getting the C.T.R.L.R to work with RetroArch. Here is what I did.

Go to Settings > Input and uncheck Configuration Autodetection > Enable. Scroll down and open Player 1 Custom Binds. For each button open the configuration menu, select Detect and press the appropriate button on your C.T.R.L.R in GameSmart mode. It's useful to continual switch between mouse mode for easily operating the configuration menu and GameSmart mode for assigning the single buttons.

At the end your configuration should look like this:

Up Button: Dpad Up
Down Button: Dpad Down
Left Button: Dpad Left
Right Button: Dpad Right
A Button: Button B
B Button: Button A
X Button: Button Y
Y Button: Button X
Start Button: Button Start
Select Button: Media Play Pause (see annotation below)
L1 Button: Button L1
R1 Button: Button R1
L2 Button: Unbound (see annotation below)
R2 Button: Unbound (see annotation below)
L3 Button: ThumbL
R3 Button: ThumbR

Better use one of the media buttons instead of the Back button for Select to be able to access the RetroArch GUI during gameplay if Settings > Input > Back behavior was set to GUI toggle.

The button setup menu doesn't recognize the L2 and R2 buttons. Nevertheless they work properly in cores which support them.

If you have got a second controller repeat this procedure with Player 2 Custom Binds.

Using analog sticks

Support for analog sticks depends on emulation cores. From the RetroArch GUI set Settings > Input Options > Device Type: Joypad w/ Analog and Analog D-pad Mode: Dual Analog. Then check the Core Options for a controller type option, for example Dualshock Analog Toggle: Enabled on Mednafen PSX or Pad 1 Type: Analog on PCSX ReARMed.

Unfortunately PCSX ReARMed only supports the left analog stick as an alternative for the DPAD and only for the first controller. Using both sticks equivalent to turning on the analog mode on an original PlayStation Dual Shock controller doesn't seem to work.

Issues

Currently I don't get the anolog sticks to work with emulation cores even if I set Settings > Input Options > Device Type: Joypad w/ Analog and Analog D-pad Mode: Dual Analog. If anyone has an idea please let me know.

Troubleshooting

Sometimes your second controller isn't recognized by emulation cores even if it works in the main menu. Quit RetroArch, restart it and start a game using your second controller. Now both controllers should work. Please note that not every core supports multiple controllers, for example bSNES does, SNES9x doesn't.
 
Last edited:
  • Like
Reactions: gwaldo

gwaldo

Senior Member
Dec 30, 2013
511
68
Melb.
xpcoin.com
The button setup menu doesn't recognize the L2 and R2 buttons. Nevertheless they work properly in cores which support them.

Good thread, I don't use retroarch, I found it not as up to date as the main emu apps but it's a nice 'all in one' app
But re L2/R2, these are analog triggers and some emulators don't recognize them, switch the CTRLR to PC mode, it changes R2/L2 to digital and should work 'digitally'

re the 'anolog sticks' that's really strange search google, see if the emulator supports PS3/4, x360, etc analog sticks?
It could be limited (programmed) to only moga pads etc and hasn't (yet?) implemented google's controller standard.
Ask on their forums for google controller standard support.
There's many apps that haven't caught up, it's still newish 1-2years old now.
 

Kokosnuss

Member
Dec 28, 2014
27
16
Thank you for your feedback.
@gwaldo
When I switch to PC mode the back button doesn't work as back button. Therefore I prefer using GameSmart mode.
@opiate81
I didn't have any luck trying nightlies so far. Will wait for the next stable release.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Okay, I found a solution for using analog sticks. See edited post.
    1
    Hi everyone!

    I noticed that some of you are having problems getting the C.T.R.L.R to work with RetroArch. Here is what I did.

    Go to Settings > Input and uncheck Configuration Autodetection > Enable. Scroll down and open Player 1 Custom Binds. For each button open the configuration menu, select Detect and press the appropriate button on your C.T.R.L.R in GameSmart mode. It's useful to continual switch between mouse mode for easily operating the configuration menu and GameSmart mode for assigning the single buttons.

    At the end your configuration should look like this:

    Up Button: Dpad Up
    Down Button: Dpad Down
    Left Button: Dpad Left
    Right Button: Dpad Right
    A Button: Button B
    B Button: Button A
    X Button: Button Y
    Y Button: Button X
    Start Button: Button Start
    Select Button: Media Play Pause (see annotation below)
    L1 Button: Button L1
    R1 Button: Button R1
    L2 Button: Unbound (see annotation below)
    R2 Button: Unbound (see annotation below)
    L3 Button: ThumbL
    R3 Button: ThumbR

    Better use one of the media buttons instead of the Back button for Select to be able to access the RetroArch GUI during gameplay if Settings > Input > Back behavior was set to GUI toggle.

    The button setup menu doesn't recognize the L2 and R2 buttons. Nevertheless they work properly in cores which support them.

    If you have got a second controller repeat this procedure with Player 2 Custom Binds.

    Using analog sticks

    Support for analog sticks depends on emulation cores. From the RetroArch GUI set Settings > Input Options > Device Type: Joypad w/ Analog and Analog D-pad Mode: Dual Analog. Then check the Core Options for a controller type option, for example Dualshock Analog Toggle: Enabled on Mednafen PSX or Pad 1 Type: Analog on PCSX ReARMed.

    Unfortunately PCSX ReARMed only supports the left analog stick as an alternative for the DPAD and only for the first controller. Using both sticks equivalent to turning on the analog mode on an original PlayStation Dual Shock controller doesn't seem to work.

    Issues

    Currently I don't get the anolog sticks to work with emulation cores even if I set Settings > Input Options > Device Type: Joypad w/ Analog and Analog D-pad Mode: Dual Analog. If anyone has an idea please let me know.

    Troubleshooting

    Sometimes your second controller isn't recognized by emulation cores even if it works in the main menu. Quit RetroArch, restart it and start a game using your second controller. Now both controllers should work. Please note that not every core supports multiple controllers, for example bSNES does, SNES9x doesn't.
    1
    Just use the latest nightly build, it doesn't need to be configured
    https://www.dropbox.com/sh/91sakv0qdyxjx9f/AAAKWBfDHBtIQtNfnp4rlyXea?dl=0
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone