[Settings] Tweaks to lower CPU temperature and scaling

Search This thread

rob rich

Senior Member
Jan 18, 2013
1,892
1,267
Kronach
So, here is a little review

Using razor kernel and the files from this thread with ondemand governor.

1: Antutu score is very good because the thermal engine kicks in later (normally it throttles at 50°C/122°F two of the big cores to 1113 GHz and disables the other two cores).

2: Phone stays much cooler because mostly only 1 of the big cores is running.

3: Because of only 1 core running and less heating, battery life is very good. As you can see, 4 hours screen on (with surfing, Facebook and over 1 hour gaming) and still 40% battery left.

Good work :)
 

Attachments

  • 1439756988377.jpg
    1439756988377.jpg
    35.3 KB · Views: 903
  • 1439757122556.jpg
    1439757122556.jpg
    35.8 KB · Views: 909
  • 1439757145036.jpg
    1439757145036.jpg
    112.5 KB · Views: 893
  • 1439757166337.jpg
    1439757166337.jpg
    108.1 KB · Views: 834

Keasby

Senior Member
Jul 2, 2010
483
177
@Keasby,
on new init.qcom.post_boot.sh you have too many zero in power cluster
echo 11136000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq

just a heads up :)

Thanks, figured it out right now, was a mistake du to copy - paste :(
Sorry guys, I'm rewriting it just now.

EDIT:

Links up again with fixed values!
 
Last edited:

Keasby

Senior Member
Jul 2, 2010
483
177
Hey folks,

there are 2 new configs up!
Added one with interactive governor and a second one with a combination between ondemand and interactive!
Please report how it works!

Edit: I'm using miui 7 version 5.8.20
 
Last edited:

Keasby

Senior Member
Jul 2, 2010
483
177
how about the heating issue now on this phone??

Well, it looks like the cpu and thermal control is better in Miui 7, but the hardware is the same, so it heats up a bit ;)
But the advantage of my configs are that the performance won't drop as early as on stock configs.
 

reza36

Senior Member
Jul 20, 2011
53
4
Well, it looks like the cpu and thermal control is better in Miui 7, but the hardware is the same, so it heats up a bit ;)
But the advantage of my configs are that the performance won't drop as early as on stock configs.

@Keasby i've done flashing miui polska 5.8.20 rom and check the cpu frequency using "aida64" application.. when cpu idle core 2,3,4,5,6,7 looks sleeping and they wake when cpu using... and im using your init.qcom.post_boot.sh (interactive big cluster & ondemand little cluster) when idle just core 3 and 4 its look sleeping.. can you make another core sleeping while idle / not use? thanks bro..
 

Keasby

Senior Member
Jul 2, 2010
483
177
@Keasby i've done flashing miui polska 5.8.20 rom and check the cpu frequency using "aida64" application.. when cpu idle core 2,3,4,5,6,7 looks sleeping and they wake when cpu using... and im using your init.qcom.post_boot.sh (interactive big cluster & ondemand little cluster) when idle just core 3 and 4 its look sleeping.. can you make another core sleeping while idle / not use? thanks bro..
Well I can have a look into it, have you tried to use the ondemand or interactive file?
 

reza36

Senior Member
Jul 20, 2011
53
4
Well I can have a look into it, have you tried to use the ondemand or interactive file?

i'm sorry keasby for very late respon of your reply... here my backup polska boot.sh

https://drive.google.com/file/d/0B4qBXOz8QSmASEdIQzU3RXhXcW8/view?usp=sharing

but i'm now using polska 5.8.20 newer version (31-8-2015).. while using stock boot.sh polska just only 2 core sleeping when idle (is different when im using old 5.8.20 polska because another core is sleeping too when idle) i dont know why keasby but im now using your boot.sh ( interactive & ondemand mode)..

hope you can make another core sleep when idle keasby thanks..
 
Last edited:

alternativshik

Senior Member
Mar 30, 2011
57
14
On stock kernel and dev 5.8.20 firmware I found some bug with GPU frequency - when GPU's load is 0% it works on 400MHz, but, if you start scroll or something else, that up GPU load to 40-60%, frequency DOWN to 220MHz. It should be UPper, Not LOWER. Looks like somebody in Xiaomi revert this two values. It's possible to change this frequencies with your shell script?
 
Last edited:

Keasby

Senior Member
Jul 2, 2010
483
177
i'm sorry keasby for very late respon of your reply... here my backup polska boot.sh

https://drive.google.com/file/d/0B4qBXOz8QSmASEdIQzU3RXhXcW8/view?usp=sharing

but i'm now using polska 5.8.20 newer version (31-8-2015).. while using stock boot.sh polska just only 2 core sleeping when idle (is different when im using old 5.8.20 polska because another core is sleeping too when idle) i dont know why keasby but im now using your boot.sh ( interactive & ondemand mode)..

hope you can make another core sleep when idle keasby thanks..

Thanks, I'll look into it!


On stock kernel and dev 5.8.20 firmware I found some bug with GPU frequency - when GPU's load is 0% it works on 400MHz, but, if you start scroll or something else, that up GPU load to 40-60%, frequency DOWN to 220MHz. It should be UPper, Not LOWER. Looks like somebody in Xiaomi revert this two values. It's possible to change this frequencies with your shell script?

I looked into this, seems like it's kernel related and not easily possible to change via shell script... Let me see if it's possible.


My device touches 59° using this thermal config,and I'm on interactive governor.Is it normal?

That's okay, the thermal config runs a bit higher than the stock one before thermal throttling kicks in.
 

migueldbr

Senior Member
Nov 30, 2011
1,879
510
Coimbra
Thanks, I'll look into it!




I looked into this, seems like it's kernel related and not easily possible to change via shell script... Let me see if it's possible.




That's okay, the thermal config runs a bit higher than the stock one before thermal throttling kicks in.

about that gpu bug, did you manage to do anything with it?i noticed that too
 

kolslorr

Member
Dec 11, 2008
46
8
Thanks for this! Using it with Resurrection Remix seems to be perfect so far, no need to use any third party kernel at all.

Only tradeoff is perhaps worse battery life and phone gets a bit hotter some times, but not a big deal for me.

Sent from my Mi 4i using XDA Free mobile app
 

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    Everyone of us know that the Snapdragon 615 heats up a little bit ;)
    To avoid the high scaling an temperature just while browsing or idle I made some changes too the boot.sh file and want to share it with you.
    I'm running these settings now for about 2 weeks (CM12.1 and now PAC Rom) with RaZorReborn kernel, but it should work with other kernels or Miui too!

    To use this do the following steps:

    1. Backup the stock "init.qcom.post_boot.sh" from /system/etc/ (for example with Root Explorer, just copy it to your SD card or PC...)
    2. Download the file and place it in /system/etc/ (for example with Root Explorer)
    3. Set permissions to rw-r--r--
    4. Reboot device

    For changing thermal.conf do the same as above, just with the "thermal-engine-8939.conf" file. With this tweaked config the device heats more up but should run faster!


    Note:
    For Miui OTA updates you have to restore the original files and unroot the device!





    "init.qcom.post_boot.sh" changes:

    Code:
    [U]24.08.2015:[/U]
    - added latest Miui 7 changes
    - added 2 download options for scaling governor -> ( Ondemand, Interactive and combination of Ondemand [little] and Interactice [big] )
    - Tested on Miui 7
    
    
    [U]19.08.2015:[/U]
    - added low power modes (sched_spill_load /// sched_spill_nr_run /// sched_upmigrate_min_nice)
    
    [U]17.08.2015:[/U]
    - Bug fixes
    
    [U]17.06.2015:
    [/U]- cpu idle load thresholds 
    - HMP scheduler (big.Little cluster related) settings
    - settings for perf cluster
    - settings for power cluster
    - setprop ro.min_freq
    - fix sched_mostly_idle_nr_run (wrong path in original file)
    - set "ondemand" as default CPU governor
    - set "simple_ondemand" as default GPU governor
    - Reduced file size a lot!!


    "thermal-engine-8939.conf" changes:


    Code:
    - SS-CPU0       (thermal throttling while charging - devices get's hotter and trottle later)
    - XO_GPU_MONITOR       (GPU trottle later)

    Downloads:


    init.qcom.post_boot.sh (ondemand governor)

    init.qcom.post_boot.sh (interactive governor)

    init.qcom.post_boot.sh (ondemand & interactive governor)



    thermal-engine-8939.conf





    Note:
    I'm not responsible due to device damage caused by e.g. wrong settings!



    Information:

    Created: 2015-06-17
    Last Updated: 2015-08-24
    3
    So, here is a little review

    Using razor kernel and the files from this thread with ondemand governor.

    1: Antutu score is very good because the thermal engine kicks in later (normally it throttles at 50°C/122°F two of the big cores to 1113 GHz and disables the other two cores).

    2: Phone stays much cooler because mostly only 1 of the big cores is running.

    3: Because of only 1 core running and less heating, battery life is very good. As you can see, 4 hours screen on (with surfing, Facebook and over 1 hour gaming) and still 40% battery left.

    Good work :)
    1
    Well, found a cheecky 1 by 1 copy at Miui Official Forum, that someone posted there.
    Too bad that those guys copy this stuff and post it as their own work...

    Will update today with more settings.
    1
    @Keasby,
    on new init.qcom.post_boot.sh you have too many zero in power cluster
    echo 11136000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq

    just a heads up :)
    1
    Thunderzap is crashing on my phone. Any alternatives?

    Sent from my Mi 4i using Tapatalk
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone