• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Share Now App and Xiaomi.eu rom - Problem

Search This thread

JKDO

Member
Jun 21, 2015
33
3
Hey there,

I use always the latest xiaomo.eu weekly and I have problems with share now app. I can only uses smart fortwo cars and thats all. All the other cars cause error like "this car is not compatible to your phone system". I think the problem is, that the app somehow sees that the phone is unlocked and rooted (with magisk), as a friend is using miui global without problems. Tried magisk hide without improvment

Any solutions?
 

glacierfog

New member
Jun 11, 2021
1
0
Bit late answer:

You need to hide magisk itself by installing it under a different name (you can do that in magsik settings).

Then do the following:
  1. Delete all app data of share now and uninstall it. Reboot
  2. Install share now again and do not open it
  3. Go to Magisk and hide the sahre now app (make sure to hide all packages)
  4. Reboot again (without it did not work for me)
  5. now start the app and it should look like you are unrooted.
This way it worked for me.