[SHARED][RECOVERY][OFFICIAL] TWRP-3.2.3 for Redmi 6

Search This thread

vess_csm

Senior Member
Sep 18, 2010
209
12
So basically there is no root and custom roms for redmi 6? I would at least like to uninstall all the things that where on the phone. Guess I'll return it :(
 

Che0063

Senior Member
Aug 19, 2018
53
14
I can live without having a custom ROM since I like the look of MIUI, but I really want a root method. It seems that tWRP has many issues and basically does not work as intended, am I correct? Surely somebody has rooted MIUI on the Redmi 6 cereus?
 

Che0063

Senior Member
Aug 19, 2018
53
14
plus BL needs to be unlocked 1st

I'm curious as to how long did you have to wait for the Bootloader unlocking time? On my previous Redmi 5A it was 720hrs or 30 days, yet for some people here I see its either 15 days or 30 days. Somebody even had to wait for 60 days!

I'm getting the China version with the China ROM. I can understand half the Chinese and I don't want to risk installing Global ROM in case of a brick. So I want to root to get rid of stock China-store, and bloatware
 

timonoj

Senior Member
Oct 22, 2010
473
62
Hong Kong
Hi guys! I don't seem to be able to install any bootloader! Can you guys help me? The phone says already on the bootscreen it's unlocked, so I guess that annoying process at least worked. However, the fastboot flash doesn't seem to go anywhere.

Code:
$ adb reboot fastboot
* daemon not running; starting now at tcp:5037
* daemon started successfully
The phone reboots to fastboot without a blip. So far, so good. Now, from fastboot:

Code:
$ fastboot flash recovery twrp-3.4.0-2-cereus.img 
target reported max download size of 134217728 bytes
sending 'recovery' (22394 KB)...
OKAY [  1.291s]
writing 'recovery'...
OKAY [  0.354s]
finished. total time: 1.645s
...Hum. Nothing happens on the screen. No acknowledgement of any kind. Just the same fastboot screen. I then try:
Code:
$ fastboot boot twrp-3.4.0-2-cereus.img 
downloading 'boot.img'...
OKAY [  1.236s]
booting...
OKAY [  0.052s]
finished. total time: 1.288s
The phone promptly reboots....to the normal Xiaomi image. No TWRP, nothing. If I manually shut it down and boot to recovery, by pressing Volume UP + Power, I get the factory Xiaomi recovery menu. No TWRP whatsoever. So the phone seems to return A-OK whenever I flash something, but it seems to do nothing! Any ideas what might be going on? And again, on the boot screen it always shows it's unlocked now. But yeah...flashing doesn't seem to stick.

EDIT: Just for further testing, I tried the same with the Chinese translated TWRP (inside the TWRP-3.3.0-0423-REDMI6-CN-wzsx150-fastboot_translated.zip), but that went nowhere either.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    twrp.png


    TWRP is an open source, community project. A custom recovery is used for installing custom software on your device. This custom software can include smaller modifications like rooting your device or even replacing the firmware of the device with a completely custom “ROM” like LineageOS or OmniROM.

    Im not a developer of this, i just shared it here :)

    Downloads & Device trees

    Telegram Group
    4
    My Treble gsi roms flash feedback :
    LOS15.1 has worked well, but didn't like go apps.
    Tested pixel experience, but rom didn't boot, loop on TWRP.
    After that, impossible to reflash LOS15.1, loop on TWRP...

    So I flashed MIUI10 to have a phone alive.
    2
    can you share it? and which twrp do you use?

    take a look at this video it should give you instructions to root: https://youtu.be/YI2CtIIPVaI :good:
    2
    For those of having problems installing TWRP..
    This is my solution

    First, unlock bootloader.
    Get twrp recovery file.
    In command line (If cmd doesnt work do it in Windows POWERSHELL)
    adb reboot bootloader
    fastboot flash recovery twrp.img
    once finished
    fastboot boot twrp.img
    and after typing this just keep holding VOL UP.
    Until screen is black for like 10 seconds press power button twice(or once) and twrp will show up
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone