Shield Android TV rooted

Search This thread


Senior Member
Sep 12, 2010
Should be able to upgrade in place. Working on finding the right TWRP to get me far enough to root ....


Senior Member
Sep 10, 2010
I would just wait for the prerooted image from nvidia dev guys... Can't be more then a few days out

Sent from my Nexus 6P using Tapatalk


Senior Member
Sep 10, 2010


Senior Member
Sep 20, 2014
Thanks for the explanation & link. So basically avoids the need for twrp. The current 3.0 image with root is on that page.
edit: Sorry, false alarm. I saw Vulkan support is included in OS images with versions >= 3.0.0. and just assumed.
Last edited:


Senior Member
Feb 20, 2015
So thetering boot recovery like we used for the amazon fire 7" tab thats what i mention before good job Shane


Senior Member
Dec 10, 2012
Samsung Galaxy S21
You have to have a sd card to push supersu to the shield?

Edit- i figured out what i asked. Had to use an sd card, and the above method worked, i used the most recent recovery from 02_22. Now if my understanding is correct, the only ROM out, full android, can not be flashed on 3.0? Is that correct?

Sent from my Sammy S6 using Revolution 1.0
Last edited:


Oct 24, 2015
I seen the following on the SHIELD Developer OS Images page. So are all of use just running around chasung our tail ?

Currently Shipping Rooted SHIELD Android TV Image
Instructions & Downloads
NVIDIA provides a rooted OS image for SHIELD ANDROID TV that matches the currently shipping public OTA. To flash the rooted image to the SHIELD Android TV, download the image for your specific device and follow the instructions listed on the Download Center entry.

Vulkan support is included in OS images with versions >= 3.0.0.


Sep 4, 2008
I've tested the "NVidia developer os image", I've followed the procedure: it installs the last version, but it's not rooted.
Do I have missed a point?


Senior Member
Mar 24, 2011
Near Kennedy Space Center, Florida
I seen the following on the SHIELD Developer OS Images page. So are all of use just running around chasung our tail ?

Currently Shipping Rooted SHIELD Android TV Image
Instructions & Downloads
NVIDIA provides a rooted OS image for SHIELD ANDROID TV that matches the currently shipping public OTA. To flash the rooted image to the SHIELD Android TV, download the image for your specific device and follow the instructions listed on the Download Center entry.

Vulkan support is included in OS images with versions >= 3.0.0.

I was confused by this also.


Senior Member
Sep 23, 2012
adb backup also not working for me, disabled and re-enabled USB debugging, tried doing so with and without reboot, no change. Same issue as previously posted by someone else, the Shield does not ask for confirmation on screen to backup. Someone posted a solution somewhere to try enabling and disabling some developer desktop password, but the shield does not seem to have that option. A backup of stock would have been nice, but I am not overly concerned.

After following all the rooting steps and entering sudo fastboot oem unlock run for a few hours, and coming back to see no longer did my TV display a message 'please wait...', I entered the command fastboot boot twrp- but terminal just output: < waiting for device >, which it hangs on, and nothing changes on the TV screen. I tried to select continue or reboot from the Fastboot menu, in case that is necessary but missing from the guide, but something else was selected and a picture of an Android laying on his back with a hazard sign in its stomach appeared! Thankfully after cold rebooting the Shield did boot, although I had to run through the set up again.

I then followed the steps from this guide again, although this time when I enter sudo fastboot oem unlock it outputs:

...(bootloader) Bootloader is already unlocked.
[ 0.004s]finished. total time: 0.004s

I then entered the command fastboot boot twrp- and it again hangs on '< waiting for device >', with nothing changing on the screen, I just see the Cboot version, instructions on how to navigate, and the Fastboot menu: continue, boot recovery kernel, reboot, poweroff, forced recovery - am I supposed to select one of these before entering the command to boot the image?
If I kill the attempt with ctrl-c (Ubuntu 15.10) and enter adb devices it shows none are detected, although there were not long ago as I was able to boot into Fastboot in the first place with adb reboot. If I try the boot twrp command with a sudo before it the output is different:

downloading 'boot.img'...
FAILED (command write failed (Protocol error))
finished. total time: 0.000s

What can I do to boot the image please?
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 27
    I just managed to get TWRP running on the new Shield console, and installed SuperSU successfully. Two caveats: the display is upside down, and the USB host ports don't work. I had to plugin a mouse via an OTG cable in order to interact with it. ETA: That's only an issue when booted to TWRP. Everything's working fine in the stock ROM after rooting.

    - enable developer tools / USB debugging
    - adb push /sdcard
    - adb reboot bootloader
    - fastboot oem unlock
    - fastboot boot twrp-
    - unplug USB cable, connect mouse via USB, install SuperSU

    TWRP boot image is attached. Off to explore...

    EDIT: by request, some more detailed instructions:

    • On the Shield device, head to Settings -> About, and click "Build number" 7 times. This will enable Android's Developer options.
    • Go to Settings -> Developer options, and enable USB debugging.
    • Install the ADB/fastboot drivers and utilities if you don't already have them. When "adb devices" shows your Shield, you're good to go.
    • Download and extract from this thread.
    • Head to the SuperSU forum and download the latest version.
    • Open a command prompt and navigate to the directory where you downloaded everything. (Google this for your OS if you don't know how).
    • With the Shield still booted, run "adb push /sdcard" (change to appropriate file name). This will upload the SuperSU update zip to your device, which you'll install from TWRP.
    • If that worked fine, run "adb reboot bootloader". Your device should shut down, and display the Fastboot screen after a few seconds.
    • FOLLOW THE NEXT THREE INSTRUCTIONS AT YOUR OWN RISK. This WILL wipe all your user data, back it up with ADB first if you want to preserve it. DISCLAIMER #2: I have no idea if there are any DRM keys or anything that get wiped when this is done (this was the case on my Xperia Z3 Compact). I will say that Grid streaming still works fine after doing this.
    • This step will unlock your bootloader to enable booting unsigned images.
    • Run "fastboot devices" and make sure your Shield is visible.
    • Run "fastboot oem unlock" and follow the prompts on the screen. Your bootloader is now unlocked.
    • Now, boot the TWRP image with: "fastboot boot twrp-" - Note: I used this instead of "fastboot flash" so I could keep the stock recovery around, to grab an image of it after rooting.
    • You should now see a TWRP recovery menu (upside down for now).
    • Connect a keyboard or mouse via OTG cable, and select "Install", navigate to your SuperSU zip, select it, and follow the prompts.
    • Click "reboot" and you should now be rooted.
    Quick warning for Pro owners: OEM Unlock takes about 92 minutes. Just be warned and ready for it...
    Well, life has finally caught up to me. I need to take a break for a couple weeks. I may work on some small stuff during that time, but I won't be making any big pushes for anything. If somebody else wants to pick up and finish sooner, everything I've done is on Github. The patches against multirom are here (of interest are the ones with aarch64 in the name) and the repo can be used to build cm, twrp, and multirom (only twrp working, of course). The cm-12.1-mrom branch of the foster kernel has the attempt at a kexec patch. Don't know if it works because multirom hasn't worked right yet. Last I tried, the fdt patch didn't compile, so that might need reverted and fixed. CM is like I mentioned last post, no change there. And somehow, the twrp recovery image needs to slim down 3-4 MB. Probably easiest to trim the kernel and split the defconfig for cm and twrp.
    Doh instructions mean touch button on the shield itself lmao - I was thinking it was the controller smh. in the end i just hardware rebooted back into fastboot mode and now im trying to flash zulus custom system img to console. Not sure what step i missed as I followed instructions to a T just seems like after unlocking bootloader it was done for some reason.

    @zulu99 - I dled your system img of 125 mb and when i go to flash it only appears to be writing smaller size 64578 kb / 23221 kb).

    target reported max download size of 67108864 bytes
    erasing 'system'...
    OKAY [ 0.405s]
    sending sparse 'system' (64578 KB)...
    OKAY [ 1.563s]
    writing 'system'...
    OKAY [ 3.630s]
    sending sparse 'system' (23221 KB)...
    OKAY [ 0.583s]
    writing 'system'...
    OKAY [ 0.864s]
    finished. total time: 7.045s

    Also, when i follow your instructions for ./fastboot -w it just hangs there and does nothing (should it take 30+ min?).

    @op - I also tried booting and flashing twrp recovery linked in your first post and was unable to get into recovery using either method.

    I think imma just try and go back to the stock ota since not having much luck does anyone have any ideas how to flash that back via fastboot? Lollipop roms look much different so all Im seeing is a boot.img and this dat file which looks it probably has everything in due to its size but not sure what to do with it.

    The rar file is 245MB and when you extract the system.img the size of system.img is 665MB

    I think you have problem with your pc / usb otg cable, specially if the command fastboot -w, that just clear user data , not work.

    On shield is just little hard to go in bootloader mode:

    HW method:
    Disconnect power cable
    Insert USB OTG cable and make sure to connect other end to a host PC
    Connect power cable to SHIELD
    Quickly start pressing power button for ~3 seconds
    Do not hold the button and connect power supply afterwards
    HDMI TV should be always connected to SHIELD

    The first day was hard to go in fastboot, wont to others devices, but after 2 or 3 times, all is simple and work well.
    I flashed my Shield millions times.

    So. The the important fact is that with full android firmware the device became really useful. Work very well and the hardware is strong.
    Specially you can have all android apps without limitations directly from Google Play.

    For the controller i can use it wired but with the trick above i can use it also from my couch. Tested many things and all work very well.

    But i repeat, this is just the start.

    I hope to see a specific thread for this device in xda forum so i can help better.
    Not really sure where to put this since there's no Shield TV section but once you root it you can enable hardware mpeg-2 decoding pretty easily

    In an adb shell run the following:
    su -
    mount -oremount,rw /system

    download /system/etc/media_codecs.xml

    Add the following to the <decoders></decoders> section:
            <MediaCodec name="OMX.Nvidia.mpeg2v.decode" type="video/mpeg2">
                <Feature name="adaptive-playback" />

    Re-upload the file to the device replacing the current one. Reboot the device and mpeg-2 decoding will be enabled. You can also do this for vc1 by adding the following:
            <MediaCodec name="OMX.Nvidia.vc1.decode" type="video/vc1">
                <Feature name="adaptive-playback" />

    Your first version I used adb shell and just manually installed su from twrp so unsure if it worked as I don't have the proper cable for mouse control :(