SHRP Recovery bootloop after flashing a ROM (although rom is fine)

Search This thread

NewtonPL

Member
Jun 12, 2022
24
8
Hello,
As the title suggests, I've flashed a custom rom (EvolutionX to be exact), upon booting it up, mediatek Ims stops working, but that appears only on boot so it's not that big of a deal.
However, Upon rebooting into recovery (through system or via vol up+power) i get greeted by the SHRP logo but it powers off and on.
Fastboot mode works just fine, ROM works too, the recovery doesnt want to work though. I had the phone modded for 2 weeks and this is the first time this happened.
Any idea on i can fix it? I've already tried flashing the same recovery via fastboot but to no avail, i get an error saying:
fastboot: error: cannot load 'SHRP_v3.1_stable-Official_CD6-1630047089': Permission denied
That's weird, because my phone has an unlocked bootloader.
Any help would be greatly appreciated!
 

HaroldTech312

New member
Jun 25, 2022
4
0
Friend Maybe you had a small error in the firmware of your device, if I'm not mistaken I think that later the equipment will be in a hardbrick and you will have to wait for the bootloop cycle to pass, which is when the battery runs out and you will have to resort to SP Flash Tool to fix mobile

I hope I have helped you, it is something that I have learned
 

NewtonPL

Member
Jun 12, 2022
24
8
Friend Maybe you had a small error in the firmware of your device, if I'm not mistaken I think that later the equipment will be in a hardbrick and you will have to wait for the bootloop cycle to pass, which is when the battery runs out and you will have to resort to SP Flash Tool to fix mobile

I hope I have helped you, it is something that I have learned
i will try flashing stock xiaomi and then install a custom rom again
 

HaroldTech312

New member
Jun 25, 2022
4
0
i will try flashing stock xiaomi and then install a custom rom again
try it I can't guarantee you anything but if it comes back and the same thing happens it means that the rom is not compatible with your mobile and you will have to look for another one

If you still have doubts tell me that I can try to help you
 

NewtonPL

Member
Jun 12, 2022
24
8
the ROM was glitchy and broke the recovery, i flashed miui a11 and flashed everything again, works now