• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Simcard lost connection (had to re-enter sim pin)

Search This thread

ChromeFR

Senior Member
Sep 16, 2008
82
4
Yesterday I received my Mi10, what a beautiful device. But I ran into a problem today:

While I was navigating in Google Maps my phone suddenly switched to lockscreen and I had to re-enter my sim pin. Like I was doing a hot swap. Only then did the phone reconnect to the network. This has happened once but I've never had this with another phone before. The sim card is new, clean and carefully inserted.

I hope this was a software bug and not a hardware issue...do you guys recommend requesting a device swap (other mi10) already? Is this a know problem?
 
Last edited:

Mattari

New member
Dec 14, 2018
2
0
I bought MI10 three days ago and this morning it lost the SIM connection and there is no way for making it recognized by MI10.
The same SIM works fine on my old MI6 and no other SIM works on MI10.
I have also tried to hard reset it, but nothing changes.

Do you think it is a hardware problem? After 3 days?
 

hnide777

New member
Aug 11, 2020
1
0
I have same problem, mi Mi 10 isn't reading my sim card anymore, looks like HW problem because it is sometimes working but I have to try to insert it maybe 30 or more times :(
And from today it is not reading sim card anymore.