[SM-A500X] Live Demo Unit can't flash bootloader?

Search This thread

Ing_Emperor

Member
May 24, 2013
28
5
Hello,

i have a Samsung Galaxy A5 (2015) SM-A500X Live Demo Unit.
It came with it's stock Kitkat ROM and does not find any updates, but i know that there is a 6.0 update for this phone. So i tried to modify the DBT-Germany Stock 6.0 that i downloaded with those guides:
https://www.reddit.com/r/oculus/comments/40rsdv/if_you_get_a_samsung_s6_live_demo_unit_store/
https://forum.xda-developers.com/showthread.php?t=2349948

In the first guide i could only remove the "modem.bin" but both the other files are not in the stock Rom .tar file. i tried to Flash it anyway, but Odin gave me an error that it couldn't Flash one part, the phone showed some error in download mode "couldnt Flash secured" or something like that. i think the Partition is missing for a specific file?
So i used the second guide and removed EVERYTHING besides the files which are Name in the guide (like stated there), the Flash in Odin went fine, but the phone only shortly Shows the Splashscreen and then Comes back to download mode which tells "Could not do normal boot"
Then i began to Panic, because recovery was dead too...
So i could save the phone, i flashed the twrp recovery, i could atleast go into a working recovery and then i was able to restore the backup of the stock Rom (glad i did this one)

So the phone is working again, at least. But could somebody tell me what i have to do to Flash the 6.0 stock Rom?

Or: Do i really Need to do this since i only want to use lineageos (Nougat), but in the guide it is telling me, that i Need to have at least the marshmallow bootloader and modem. i know that a LDU has no modem but what about the bootloader?

I am very sorry for my bad english! :angel:

I would really appreciate some help...

Thanks a lot!
 
Last edited:

Ing_Emperor

Member
May 24, 2013
28
5
Thanks for the answer, this was also the ROM i modified, but if i flash it unmodified with Odin, i always get this log:
<ID:0/004> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/004> Odin engine v(ID:3.1207)..
<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> NAND Write Start!!
<ID:0/004> SingleDownload.
<ID:0/004> aboot.mbn
<ID:0/004> FAIL! (Auth)
<ID:0/004>
<ID:0/004> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)


On the phone:
"Secure Check Fail: aboot"


It seems that the bootloader is somewhat locked?

I can still flash a recovery (TWRP) and this is working, the kitkat stock Rom is also working (from backup in TWRP) but i cant get anything else to work, especially lineageOS doesnt boot :/

EDIT:
Slowly i begin to understand: https://techusall.com/solved-secure-check-fail-aboot-error-flashing-firmware/
If i am right, my baseband/bootloader ist not compatible with the normal A500FU so i can't update it?! So there's no solution to this Problem?! :(
Ok, i think this is the end... I even tried to flash the 4.4 Stock ROM for A500FU but it still get the damn aboot.mbn auth error. I think the bootloader on demo phones is somewhat locked and can't be flashed at all, so i am stuck with Kitkat Bootloader preinstalled. So i only can flash 4.4 ROMs i think, this is sad :/
Especially because there is official 6.0 for this phone.
 
Last edited:

Ing_Emperor

Member
May 24, 2013
28
5
I still have the same Problem. Does some dev have some advanced Knowledge of those Errors?
It would be okay if it's simply not possible, so i can sell the unit again, but i would like to be sure to not waste an opportunity to use this nice device.