Smartphone Lenovo A820

thienvandac

Senior Member
Sep 13, 2011
146
7
0
I have (almost) working 4.2.1, but it seems to mess up with other people's touchscreens, while it's fine on my replaced one.
So I don't have a way to test on my phone if it's going to be ok on other devices.
You can create beta version :D of course we know sometimes it not work but at least try something new.
 

intern25

New member
Aug 12, 2013
4
0
0
I followed benz0076:s thread and installed the rom. And now my phone is bricked.. It looks like installing just fine @ CWD but then the installation is ready and the phone reboots, after the "3G" screen there is only black.

How should I continue from here?

Sorry for being noob, ive searched the forums but all they are using the flashtool and benz0076:s guide was not. Now im completely screwed.

And there was no actual reason to start messing with these roms... Just curiousity. :rolleyes:

I did a backup with CWM and its not working neither. Says about MD5 error.



link to the thread I followed: http://forum.xda-developers.com/showthread.php?t=2301212
 
Last edited:

wafflestyx

Member
Aug 3, 2013
26
4
0
Got a an a820 today.
Followed the steps here to root techjunction.in/guides/root-lenovo-a820.html
Installed MIUI v5 (v1.3.2) from slatedroid.com/topic/72057-lenovo-ideaphone-a820/page__view__findpost__p__830745
Everything seems fine.
Put in SIM card nothing, Mobile networks > Network operators > Choose Automatically > errror: "Can not connect to network try again later"
(going to manual only shows AT T 2G still same error)

Thinking it might be the ROM I installed Infrared's Lenovo A820 - V2.2 from needrom

Same thing as before, doesn't want to register to the network.
Doesn't seem like it would be a defected unit since when I have is search under manual AT&T 2G shows up.
Is there a patch somewhere for the phone network driver?

I saw a post about losing your IMEI. Under user status > IMEI info > mine is listed so I guess Im ok there?

Any ideas?
 

intern25

New member
Aug 12, 2013
4
0
0
Already update to my "case".

I tried to fix this problem by flashing with flashtools the Official Lenovo rom. And now even the volume+- & power isnt doing anything... :cowboy:

Flashing went through "the first step" and even the green circle came out. But then I tried to download the flash recovery, the flashtools came up with an error : "BROM ERROR S_FT_ENABLE_DRAM_FAIL (4032). This guide was from other forum and the guide poster seems to be so arrogant that he dont bother answering to anyone.


Ever since the same error comes up when I try to flash it again... And phone is completely dead. This must be the end of the story here? Whole day fighting with this and have no any other ideas what to try next.

I would be very happy if someone could help me with this, If there is anything to do.
 

splitpea

Member
Jul 18, 2012
9
1
0
Already update to my "case".

I tried to fix this problem by flashing with flashtools the Official Lenovo rom. And now even the volume+- & power isnt doing anything... :cowboy:

Flashing went through "the first step" and even the green circle came out. But then I tried to download the flash recovery, the flashtools came up with an error : "BROM ERROR S_FT_ENABLE_DRAM_FAIL (4032). This guide was from other forum and the guide poster seems to be so arrogant that he dont bother answering to anyone.


Ever since the same error comes up when I try to flash it again... And phone is completely dead. This must be the end of the story here? Whole day fighting with this and have no any other ideas what to try next.

I would be very happy if someone could help me with this, If there is anything to do.
Try using flashtools and the new factory S147 rom from the comment section here. I was able to get my phone completely back to stock last night, including recovery, using this rom.

---------- Post added at 08:29 AM ---------- Previous post was at 08:24 AM ----------

Has anyone had trouble with video playback on this phone? I get really slow playback in every video streaming app I try, and It's been this way with both stock & custom roms.

This is what video playback looks like

I've never encountered this on an android device before, though it seems like it may be hardware acceleration related?
 

VKoding

Member
Jul 8, 2013
5
0
0
I have got an official rom file on sd card from my phone supplier and when I start the SP Flash tool program that came with it, it gives a error message:
"Access violation at address 005D90CE in module `Flash_tool.exe`. Write of address 00000000.
When I click ok on the error message the window with the message closes also the flash tool closes.

I tried another SP flash tool I have downloaded that works and when selecting the scatter file from the original, it says wrong file format.

So how can I flash this rom ?
It also have some back up and other files with it. Also containes a zip file, perhaps I can install from sd card ?
Did you manage to solvw this?
 

intern25

New member
Aug 12, 2013
4
0
0
Try using flashtools and the new factory S147 rom from the comment section here. I was able to get my phone completely back to stock last night, including recovery, using this rom.

---------- Post added at 08:29 AM ---------- Previous post was at 08:24 AM ----------

Has anyone had trouble with video playback on this phone? I get really slow playback in every video streaming app I try, and It's been this way with both stock & custom roms.

This is what video playback looks like

I've never encountered this on an android device before, though it seems like it may be hardware acceleration related?
I did get the phone working after all. The trick was a new preloader from this post. http://forum.xda-developers.com/showpost.php?p=42026715&postcount=833
 

I.nfraR.ed

Senior Member
May 9, 2013
234
275
0
Sofia
I did get the phone working after all. The trick was a new preloader from this post. http://forum.xda-developers.com/showpost.php?p=42026715&postcount=833
I just saw your problem when you have already fixed it, but yes - not all phones seem to work with every A820 preloader/rom version combination.
I've had one A820 from the newer batches which didn't want to work with the preloader from my personal A820 (from the early batches).
Good thing is there are a lot of variants to try, A820 is a rather popular phone. Some people with other phones are not as lucky as we are, because they have only 1 official firmware and almost non-existent custom roms.

-----------------------------------------------------------------------------
Btw, anyone willing to test the latest build of 4.2.1? - confirmed not working, link is removed

You should be brave enough and expect your touchscreen to be messed up after the installation.
You should also know how to flash a firmware from FlashTools and advanced recovery, so people with some experience needed.


There's a 100% working solution for "broken" touchscreen which I described here.
By 100% success I mean - so far the success rate is 100% for over 10 phones, but there's always a possibility it doesn't work on your particular sample, although it's 99% sure it will.

I would test it myself, but my phone isn't affected anymore and I'm able to install and use any MTK6589 firmware from other phones as long as it boots to desktop. For example I was able to install official A830 firmware and almost everything worked out of the box, except screen rotation and camera. But it will lead to touchscreen issues on any other "normal" A820, so I'm not able to test.

  1. Download the latest test firmware from my dev-host folder: link removed
  2. Copy to scdcard and install through advanced recovery - twrp or cwm, but properly modded, which means - adapted for A820 with proper device model. I've added a device string check in the install script and it won't work on non-proper recovery.
    You can download and install my CWM 6.0.3.2.
    Make sure you have a full nandroid backup on external sdcard before rom installation, this is a must!
    Install script formats system and data partitions.
  3. When the phone reboots, if it doesn't get to desktop, then try factory reset and fix permissions from CWM.
  4. Verify if the touchscreen is fine, if it's not then follow the instructions described in the link provided above.
  5. Report the outcome here.

It is rather difficult for me to test these 4.2.1 versions, because all of them are working on my phone, but seem to mess up other people's touchscreens :(
 
Last edited:

wafflestyx

Member
Aug 3, 2013
26
4
0
A few posts back I said I couldn't connect to my phones network, and that its only says emergency calls only.
Since then I have tried quite a few ROMs and posted on other boards.
I have used FlashTools for firmwares S135/138/139/147 and still nothing.

If this was a hardware issue would it still say emergency calls only and when I scan for a network, display one?

I'm getting to the point of just cutting my losses and throwing it on ebay or give it to the kids to play games on.
Open to any ideas to try.
 

I.nfraR.ed

Senior Member
May 9, 2013
234
275
0
Sofia
A few posts back I said I couldn't connect to my phones network, and that its only says emergency calls only.
Since then I have tried quite a few ROMs and posted on other boards.
I have used FlashTools for firmwares S135/138/139/147 and still nothing.

If this was a hardware issue would it still say emergency calls only and when I scan for a network, display one?

I'm getting to the point of just cutting my losses and throwing it on ebay or give it to the kids to play games on.
Open to any ideas to try.
Maybe ask friends on different networks/carriers to lend you their sim cards for a while and test if they work in your phone.
 

intern25

New member
Aug 12, 2013
4
0
0
A few posts back I said I couldn't connect to my phones network, and that its only says emergency calls only.
Since then I have tried quite a few ROMs and posted on other boards.
I have used FlashTools for firmwares S135/138/139/147 and still nothing.

If this was a hardware issue would it still say emergency calls only and when I scan for a network, display one?

I'm getting to the point of just cutting my losses and throwing it on ebay or give it to the kids to play games on.
Open to any ideas to try.

Have you tried to enable roaming? My phone didnt work at first because of my network works for some reason only in roaming mode.
 

splitpea

Member
Jul 18, 2012
9
1
0
  1. Download the latest test firmware from my dev-host folder: A820_signed_081513_174918.zip
  2. Copy to scdcard and install through advanced recovery - twrp or cwm, but properly modded, which means - adapted for A820 with proper device model. I've added a device string check in the install script and it won't work on non-proper recovery.
    You can download and install my CWM 6.0.3.2.
    Make sure you have a full nandroid backup on external sdcard before rom installation, this is a must!
    Install script formats system and data partitions.
  3. When the phone reboots, if it doesn't get to desktop, then try factory reset and fix permissions from CWM.
  4. Verify if the touchscreen is fine, if it's not then follow the instructions described in the link provided above.
  5. Report the outcome here.

It is rather difficult for me to test these 4.2.1 versions, because all of them are working on my phone, but seem to mess up other people's touchscreens :(
So I tried this on my A820. It booted up okay but the touchscreen was all screwed up. Thankfully your instructions for recovering worked, so you can count 11 phones and your 100% recovery rate is safe.

I am using your custom recovery and installed the zip with that. any other info I can give that will help? It looked really nice from the boot screen, I just couldn't really use it.
 
  • Like
Reactions: I.nfraR.ed

I.nfraR.ed

Senior Member
May 9, 2013
234
275
0
Sofia
So I tried this on my A820. It booted up okay but the touchscreen was all screwed up. Thankfully your instructions for recovering worked, so you can count 11 phones and your 100% recovery rate is safe.

I am using your custom recovery and installed the zip with that. any other info I can give that will help? It looked really nice from the boot screen, I just couldn't really use it.
Ok, thanks for the test. I really don't know where and what to look for in order to make it work on other phones.
No other info required.
Taking down the link now.

I would ask those 10 people (or less) to report it here. Thank you.
That's not the point. They were all non-experienced users and it took a lot of time to guide them through the whole process of restoring the phone to a working state.
That's why I posted here. If you don't want to help, it's fine, I don't obligate anyone to try.
If I've misunderstood the hidden message in your words, then accept my apologies.
 
Last edited:

EgZipper

Member
Aug 11, 2013
10
0
0
Just received Lenovo A820,its fast,good design,and you can nitice the quality of the camera.I got from etotalk and they installed their rom,i replaced the launcher because it was kinda weird and used Apex Launcher.The battery life for now is good,i have been playing games and chatting on Facebook for 5hours and the battery is almost 50%. So far i like it :)

Sent from my Lenovo A820 using xda app-developers app
 

golatificon

Member
May 30, 2013
16
1
0
has any1 tried installing navigon? i did install but got Registration error: Network connection bad, something like that, also Navigon works on other phones that i saw