[SODP][ROM][AOSP][XZ2, XZ2C, XZ3] SonyAOSP 11 [BETA]

pmatj

Member
Apr 13, 2019
30
8
8
Woopsi

1. As I wrote: Longpress on the homescreen and deactivating it in the settings. 🙃
2. Hmm, I would add it to the bug tracker if it isn't there already. I never use multiple profiles. :)
1) Hm, I feeling stupid right now but I do not find any setting (see attached video)
2) By writing "I would add" you mean that you will add it... Just kidding. I'll check the SODP-Bugracker first and post a Bug-Report [Done]
 

Attachments

Last edited:

MartinX3

Recognized Contributor
Sep 14, 2014
5,640
2,796
253
Mars
martinx3.github.io
1) Hm, I feeling stupid right now but I do not find any setting (see attached video)
2) By writing "I would add" you mean that you will add it... Just kidding. I'll check the SODP-Bugracker first and post a Bug-Report [Done]
1. Wtf. Then my memories about android 10 fooled me and android 11 is different.
Probably you need a different launcher or send a bug report to google https://source.android.com/setup/contribute/report-bugs
2. Thank you :D
 

pmatj

Member
Apr 13, 2019
30
8
8
Hm, OK. In that case, I'll switch to anotehr launcher but now I'm facing one more really strange thing... was curious why the phone is so still and I didnt got any WhasApp-Login-SMS.... And now I'm facing trouble with the Modem (I think):
I can start a phone call but neither me nor my partner can hear anyhting and I do not receive any messages anymore

What kind of Network type do I need to set (Germany/O2, so I guess it is not CDMA :cool: )
There's also a message about Open Devices ModemConfig:
Modem -Konfiguration S77.1
Firmware-Datei: mcfg_sw/generic/euro/tef_o2/vlvw/de/mcfg_sw.mbn
 

MartinX3

Recognized Contributor
Sep 14, 2014
5,640
2,796
253
Mars
martinx3.github.io
Hm, OK. In that case, I'll switch to anotehr launcher but now I'm facing one more really strange thing... was curious why the phone is so still and I didnt got any WhasApp-Login-SMS.... And now I'm facing trouble with the Modem (I think):
I can start a phone call but neither me nor my partner can hear anyhting and I do not receive any messages anymore

What kind of Network type do I need to set (Germany/O2, so I guess it is not CDMA :cool: )
There's also a message about Open Devices ModemConfig:
Modem -Konfiguration S77.1
Firmware-Datei: mcfg_sw/generic/euro/tef_o2/vlvw/de/mcfg_sw.mbn
That's weird
I use the selection "LTE/TD-SCDMA/XDMA/EVDO/GSM/WCDMA" to get my 2G/3G+/4G+ in O2 Germany :)

The message is normal and there you can see, that the specific mobile provider file got loaded. :D
 

bruno$0

Senior Member
Mar 26, 2014
357
137
63
Hello guys.

I have a XZ3 and i use my phone to pay account with google pay. Is it safe to unlock the bootloader and flash this rom? Can i use this rom with google pay?

Thx in advance!
 
Last edited:

PCRath

Member
Jan 22, 2021
15
0
11
i get "invalid sparse file format at header magi" at system and vendor
after erase, it will write, but hang in the next step.

I understand this right?
Delete all "Other".sin files
select a with fastboot
Flash stock with newflasher
select b with fastboot
Flash stock with newflasher
Boot from a till desktop
Boot from b till desktop
Flash SW_binaries_for_Xperia_Android_11_4.14_v3a_tama.img to oem_a
Flash SW_binaries_for_Xperia_Android_11_4.14_v3a_tama.img to oem_b
  1. Extract the payload.bin from the .zip file
  2. Extract the .img files with the Playload Dumper
  3. fastboot flash boot_a boot.img
  4. fastboot flash boot_b boot.img
  5. fastboot flash dtbo_a dtbo.img
  6. fastboot flash dtbo_b dtbo.img
  7. fastboot flash system_a system.img
  8. fastboot flash system_b system.img
  9. fastboot flash vbmeta_a vbmeta.img
  10. fastboot flash vbmeta_b vbmeta.img
  11. fastboot flash vendor_a vendor.img
  12. fastboot flash vendor_b vendor.img
  13. fastboot -w (Wipes your internal storage and the userdata)
  14. Continue with the normal installation

Then it will stop at system, because he take the 4GB file send something and die... (second picture)

It is the same if i not take the 2014 original google driver. The XZ2 adb driver (sa0118adb.inf) from the website make the same
 

Attachments

Last edited:

MartinX3

Recognized Contributor
Sep 14, 2014
5,640
2,796
253
Mars
martinx3.github.io
i get "invalid sparse file format at header magi" at system and vendor
after erase, it will write, but hang in the next step.

I understand this right?
Delete all "Other".sin files
select a with fastboot
Flash stock with newflasher
select b with fastboot
Flash stock with newflasher
Boot from a till desktop
Boot from b till desktop
Flash SW_binaries_for_Xperia_Android_11_4.14_v3a_tama.img to oem_a
Flash SW_binaries_for_Xperia_Android_11_4.14_v3a_tama.img to oem_b
  1. Extract the payload.bin from the .zip file
  2. Extract the .img files with the Playload Dumper
  3. fastboot flash boot_a boot.img
  4. fastboot flash boot_b boot.img
  5. fastboot flash dtbo_a dtbo.img
  6. fastboot flash dtbo_b dtbo.img
  7. fastboot flash system_a system.img
  8. fastboot flash system_b system.img
  9. fastboot flash vbmeta_a vbmeta.img
  10. fastboot flash vbmeta_b vbmeta.img
  11. fastboot flash vendor_a vendor.img
  12. fastboot flash vendor_b vendor.img
  13. fastboot -w (Wipes your internal storage and the userdata)
  14. Continue with the normal installation

Then it will stop at system, because he take the 4GB file send something and die... (second picture)

It is the same if i not take the 2014 original google driver. The XZ2 adb driver (sa0118adb.inf) from the website make the same
Problably the dumper wrote garbage as vendor/system
Try to only flash boot and dtbo (if you not already done that) and flash the .zip image in the recovery.
Or in TWRP.
I'll update this readme, since multiple users got this problem.
 

PCRath

Member
Jan 22, 2021
15
0
11
After i update my XZ2 to official Android 10 i got many microphone problems. Low volume first and after updates the problem, that it is silent after 3 sec in whatsapp.
Sony Support can´t help, i buy XZ3, same problem. Sony will refund my XZ3 ( i wait till now).
So i flash yesterday Android 9 back and everything works. I think i let it be, till AOSP 11 is stable on it. Maybe after that too, because it react and start very faster with 9, than 10

But now i get a new problem: the camera preview is black, bu i can make photos, without see what i do...
 
Last edited:

MartinX3

Recognized Contributor
Sep 14, 2014
5,640
2,796
253
Mars
martinx3.github.io
After i update my XZ2 to official Android 10 i got many microphone problems. Low volume first and after updates the problem, that it is silent after 3 sec in whatsapp.
Sony Support can´t help, i buy XZ3, same problem. Sony will refund my XZ3 ( i wait till now).
So i flash yesterday Android 9 back and everything works. I think i let it be, till AOSP 11 is stable on it. Maybe after that too, because it react and start very faster with 9, than 10

But now i get a new problem: the camera preview is black, bu i can make photos, without see what i do...
As far as I know there was a bit wrong in the audio configuration files of the stock 10 ROM (and the same configurations got used in the custom ROMs)
Problably it got better now with the newest 11 release.
Otherwise please comment here
Or open a new issue if the problem is not listed in one of them
 

MartinX3

Recognized Contributor
Sep 14, 2014
5,640
2,796
253
Mars
martinx3.github.io
i have installed stock Android 9, because 11 wont flash
First try xperifirm to download the newest stock 10 for your region and then newflasher to flash it (will do a fullwipe by default)
Then boot it and use the camera
Then your baseband and partitions are upgraded to the newest patch level
This is also needed if you wnat to use newer custom roms.
 

PCRath

Member
Jan 22, 2021
15
0
11
OK, flash a/b stock Android 10, your boot and dtbo, flash with adb sideload in recovery mode, have install your ZIP file, stuck at silver android (it´s moving)
 

MartinX3

Recognized Contributor
Sep 14, 2014
5,640
2,796
253
Mars
martinx3.github.io
OK, flash a/b stock Android 10, your boot and dtbo, flash with adb sideload in recovery mode, have install your ZIP file, stuck at silver android (it´s moving)
If it is stuck on boot please flash the OEM for Android 10
You may be affected from a bug in the OEM.img for 11
 

PCRath

Member
Jan 22, 2021
15
0
11
As mentioned in the bug tracker the camera is work in progress and gcam is currently not available (which is also mentioned in the first page).

You could try the apps "Open camera" and "HedgeCamera"
ok and what about SD-Card? Will both not work in recovery (i flash with adb sideload) and in OS. I try 2 ones, that work in this phone before