• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[SOLUTION:] Can't Establish a reliable connection to the server/Playstore No Connect

Search This thread

QYOBZ

Senior Member
Sep 5, 2012
147
333
Quezon City, Philippines
CREDITS GOES TO: to crazzzzy (and many other users) (pandawill) for posting this solution.

WARNING: YOU MAY LOSE ALL YOUR DATA BY DOING THIS.

Issues:
- Account sync OFF permanently with the message: "Sync is currently experiencing problems".
- Signing in Google Apps fails showing message: "Can't establish a reliable connection to the server"

Possible Cause:
- system file named 'hosts' (/etc/hosts) points to a Google server that changed IP, thus blocking access to Apps.

Possible Solution:
edit 'hosts' file (/etc/hosts) deleting or commenting (adding a # at the beginning) the old line

Please do it at your own risk.

How to do it:

METHOD 1

1.- ROOT your device (of course)

2.- Editing the file
You will need a proper editor
Download and Install Total Commander and open it
OR DOWNLOAD BELOW

3.- Browse with Total Commander to root/etc
(hint: on the right side of the screen there's a shortcut to system folder.. look for etc/ and you will find it)
Tap mount R/W
Long tap on "hosts" > edit file > Totalcmd-Editor

Open etc/hosts and edit the file. Just put # before 74.125.93.113 android.clients.google.com.

4.- SAVED

Edited file should look like this:

127.0.0.1 localhost
#74.125.93.113 android.clients.google.com

remember: based on my own observation it should be look like this:

127.0.0.1(just one space)localhost
#74.125.93.113(just one space)android.clients.google.com

5.- Turn OFF your device.
6.(Not Necessary, Go to Next Step. But if the problem persist do Factory Reset..) Got it on Recovery Mode, Factory Data Reset, wipe data.
7. Reboot your device.
8. Once the phone reboots, input your google account information when the phone asks for it.
9.- Sync to your account and contacts

METHOD 2:

1. Make sure you have a ROOT ACCESS on your Device.
2. Install Root Explorer, Run App, Grant SU Access.
3. Browse root / etc... at the top of your screen you will see mount R/O and mount R/W...
4.Tap mount R/W
5.Look for host file, long press it and open with text editor.
6. just Add # (pound sign) on the first number.
like this:

#74.125.93.113(just one space)android.clients.google.com

SAVE IT and Reboot.
Now you can connect to Google Play very well.

UPDATE: 08/22/13

If above method fail to connect you properly or have some issue on wireless connection, revert the host file to its original state
and install this app on playstore:
https://play.google.com/store/apps/details?id=com.treb.hosts&hl=en

run app and choose your prefer edit.

Another Way Playstore not working after Installing/Uninstalling Freedom App?

- Go to Root Explorer and Mount R/W then delete Hosts file under system/etc/
- Reboot
- Shutdown & Boot to Recovery
- Wipe Cache/Dalvik Cache
- Reboot
- Presto! back to normal.

Edit:
Removed Attached Files you may download it on Google Playstore. :)

Total Commander: https://play.google.com/store/apps/details?id=com.ghisler.android.TotalCommander

Root Explorer: https://play.google.com/store/apps/details?id=com.speedsoftware.rootexplorer

Note: You may use your favorite File Manager as long as it can browse up to the root of your Phone..

Download Other File Managers:
Root Browser: http://forum.xda-developers.com/showthread.php?t=1338582 (Credits to the Devs)
ES Explorer: http://forum.xda-developers.com/showthread.php?t=2210417 (Credits to the Devs)

Note: If ABOVE method doesn't work for you... reflash rom would be your final choice!

JUST A SIMPLE CLICK ON THANKS BUTTON... WILL GLADLY APPRECIATED!
ACTIONS SPEAK LOUDER THAN WORDS SO YOU MAY CLICK THANKS BUTTON RATHER THAN THANK ME ON REPLY...
 
Last edited:

saif858

New member
Jul 2, 2012
3
2
I read your solution but when i saw my host file there was a different ip address

127.201.26.224 android.clients.google.com
mtalk.google.com

i comment both of them and did what you said but it didn't work the first time
2nd time i did that and it worked


Thanks
 
Last edited:

MANOJ5329

Member
Jul 24, 2012
33
3
Bangalore
Same Error

Even i have 127.122.124.92 android.clients.google.com mtalk.google.com ip, so did u change this ip to 74. or did u add the new ip below the local host portion???

---------- Post added at 03:58 PM ---------- Previous post was at 03:43 PM ----------

Ok Thanks a lot it really worked now, now this might help for some one if u have the same error as i got. No 74.125.93.113 ip present below local host (127.122.124.92 android.clients.google.com mtalk.google.com ip present ). so just copy this (#74.125.93.113 android.clients.google.com) below 127.0.0.1 localhost , and that worked for me....
 
  • Like
Reactions: twinzerz211

therafman

New member
Oct 2, 2010
1
0
Thank You!

Thank you for the info, it worked on my Chines tablet as it stopped working all of a sudden.
I had a feeling that it was something like this, just had no clue how to go about it... and why the hell are they using hard-coded IP addresses anyway???

BTW, just fixing the HOST file and rebooting fixed it for me.
 

benjieb

Senior Member
Sep 24, 2008
305
67
Paris
THANKS! Browsed all over the net to find a solution to this issue!

Tried many things and was about to decide to sell my GNex and upgrade to nexus 4!

Thanks to this thread and you all I am a happy GNex user again.

Still wonder what happened that changed this file or fckd my system...
 
  • Like
Reactions: alley_u2

benjieb

Senior Member
Sep 24, 2008
305
67
Paris
Uhhh, didn't work so well. I have access to my google account again (play, gmail, youtube...)

but when I try to update an app or download a new one, I get an error: RPC:S-5:AEC-0


Can anyone help ?


thanks
 

yonymun

Member
Nov 5, 2010
17
0
Thanks problem solved

Hi I was frustrated for some time over this issue, following your instructions (ES file explorer and editor) solved the problem.
Only corrected the file without factory reset than added one of my accounts.
Thanks again.
 

ahmer47

New member
Apr 16, 2011
2
4
Thanks Alot man !!!

Thanks Alot man !!! it works

here are the steps ( your device must me rooted ) :

1. download total commandar.apk from google
2. Install it in your android mobile
3. open the total commandar from ur android mobile and goto File System root
4. search for the folder etc and open that folder
5. now search for the file name ' hosts ' and click on it .
6. select edit file and add ---> " # " <--- before 2nd line like this " #74.125.93.113 android.clients.google.com "
7. and save it
8. Reboot your device
9. turn on ur wifi and ADD GOOGLE ACCOUNT !!! Enjoy
 

rundu_awe

New member
Feb 13, 2011
1
0
Finally

I've been searching and try many method in internet for many hours. Finally found your solution. It is worked 100%

THANK YOU SO MUCH.. !!!
 

xhazukawa

New member
Feb 18, 2013
3
0
Thanks

it helped me but when i open youtube it says this app wont run without google play services, which are missing on your tablet and when i go there it says your device isnt compatible with this version.. and other thing is mine is different than yours

127.0.0.1 localhost
#127.83.240.239 android.clients.google.com mtalk.google.com

and the last problem of mine after doing that is my headset has no sound anymore i borrowed my sisters headset still wont work
help me fix it pls.....pls i regret resetting my tablet
 
Last edited:

xhazukawa

New member
Feb 18, 2013
3
0
Thanks Alot man !!! it works

here are the steps ( your device must me rooted ) :

1. download total commandar.apk from google
2. Install it in your android mobile
3. open the total commandar from ur android mobile and goto File System root
4. search for the folder etc and open that folder
5. now search for the file name ' hosts ' and click on it .
6. select edit file and add ---> " # " <--- before 2nd line like this " #74.125.93.113 android.clients.google.com "
7. and save it
8. Reboot your device
9. turn on ur wifi and ADD GOOGLE ACCOUNT !!! Enjoy

i really should've rebooted my device not factory resetting it
 

Top Liked Posts

  • There are no posts matching your filters.
  • 287
    CREDITS GOES TO: to crazzzzy (and many other users) (pandawill) for posting this solution.

    WARNING: YOU MAY LOSE ALL YOUR DATA BY DOING THIS.

    Issues:
    - Account sync OFF permanently with the message: "Sync is currently experiencing problems".
    - Signing in Google Apps fails showing message: "Can't establish a reliable connection to the server"

    Possible Cause:
    - system file named 'hosts' (/etc/hosts) points to a Google server that changed IP, thus blocking access to Apps.

    Possible Solution:
    edit 'hosts' file (/etc/hosts) deleting or commenting (adding a # at the beginning) the old line

    Please do it at your own risk.

    How to do it:

    METHOD 1

    1.- ROOT your device (of course)

    2.- Editing the file
    You will need a proper editor
    Download and Install Total Commander and open it
    OR DOWNLOAD BELOW

    3.- Browse with Total Commander to root/etc
    (hint: on the right side of the screen there's a shortcut to system folder.. look for etc/ and you will find it)
    Tap mount R/W
    Long tap on "hosts" > edit file > Totalcmd-Editor

    Open etc/hosts and edit the file. Just put # before 74.125.93.113 android.clients.google.com.

    4.- SAVED

    Edited file should look like this:

    127.0.0.1 localhost
    #74.125.93.113 android.clients.google.com

    remember: based on my own observation it should be look like this:

    127.0.0.1(just one space)localhost
    #74.125.93.113(just one space)android.clients.google.com

    5.- Turn OFF your device.
    6.(Not Necessary, Go to Next Step. But if the problem persist do Factory Reset..) Got it on Recovery Mode, Factory Data Reset, wipe data.
    7. Reboot your device.
    8. Once the phone reboots, input your google account information when the phone asks for it.
    9.- Sync to your account and contacts

    METHOD 2:

    1. Make sure you have a ROOT ACCESS on your Device.
    2. Install Root Explorer, Run App, Grant SU Access.
    3. Browse root / etc... at the top of your screen you will see mount R/O and mount R/W...
    4.Tap mount R/W
    5.Look for host file, long press it and open with text editor.
    6. just Add # (pound sign) on the first number.
    like this:

    #74.125.93.113(just one space)android.clients.google.com

    SAVE IT and Reboot.
    Now you can connect to Google Play very well.

    UPDATE: 08/22/13

    If above method fail to connect you properly or have some issue on wireless connection, revert the host file to its original state
    and install this app on playstore:
    https://play.google.com/store/apps/details?id=com.treb.hosts&hl=en

    run app and choose your prefer edit.

    Another Way Playstore not working after Installing/Uninstalling Freedom App?

    - Go to Root Explorer and Mount R/W then delete Hosts file under system/etc/
    - Reboot
    - Shutdown & Boot to Recovery
    - Wipe Cache/Dalvik Cache
    - Reboot
    - Presto! back to normal.

    Edit:
    Removed Attached Files you may download it on Google Playstore. :)

    Total Commander: https://play.google.com/store/apps/details?id=com.ghisler.android.TotalCommander

    Root Explorer: https://play.google.com/store/apps/details?id=com.speedsoftware.rootexplorer

    Note: You may use your favorite File Manager as long as it can browse up to the root of your Phone..

    Download Other File Managers:
    Root Browser: http://forum.xda-developers.com/showthread.php?t=1338582 (Credits to the Devs)
    ES Explorer: http://forum.xda-developers.com/showthread.php?t=2210417 (Credits to the Devs)

    Note: If ABOVE method doesn't work for you... reflash rom would be your final choice!

    JUST A SIMPLE CLICK ON THANKS BUTTON... WILL GLADLY APPRECIATED!
    ACTIONS SPEAK LOUDER THAN WORDS SO YOU MAY CLICK THANKS BUTTON RATHER THAN THANK ME ON REPLY...
    4
    Thanks Alot man !!!

    Thanks Alot man !!! it works

    here are the steps ( your device must me rooted ) :

    1. download total commandar.apk from google
    2. Install it in your android mobile
    3. open the total commandar from ur android mobile and goto File System root
    4. search for the folder etc and open that folder
    5. now search for the file name ' hosts ' and click on it .
    6. select edit file and add ---> " # " <--- before 2nd line like this " #74.125.93.113 android.clients.google.com "
    7. and save it
    8. Reboot your device
    9. turn on ur wifi and ADD GOOGLE ACCOUNT !!! Enjoy
    4
    Well well... after so much of experimenting, finally the HOSTS patch did the work!!!

    Edited the HOSTS using Root Explorer, rebooted the device...and VIOLA!!!!
    Tons of notifications...
    I guess all apps using GCM too were stuck!

    Thanks a ton!!!
    Cheers!

    SHOULD i expect you to click the THANKS button... :p

    It worked without factory reset

    Initially I tried to edit the "hosts" file with ES File explorer but failed to do so then I tried it with Root Explorer and result was the same, finally I downloaded Total Commander apk and edited the file and when I attempted to save changes it asked for permission which I allowed and saved it. Then I reboot my device and opted for add account and it just worked. My IP was not the same as mentioned above but I didn't change it rather I just put that # tag before second line.

    I went through these steps

    1. Downloaded and Installed Total Commandar.apk
    2. Open Total Commander and go to File System Root
    3. Allow Root permission when asked
    4. Search for the folder named "etc" and open it
    5. Now search for the file named ' hosts ' and click on it .
    6. Select edit file and add " # " before 2nd line like this #74.125.93.113 android.clients.google.com
    7. And save it.
    8. Reboot your device
    9. Turn on your data connection and ADD GOOGLE ACCOUNT !!! Enjoy

    PLEASE click thanks :p

    dear
    brother ur metho-1 works

    highly thanks to uuu
    i love you

    rajdeep

    yay! just click THANKS under my name would be great!
    2
    I read your solution but when i saw my host file there was a different ip address

    127.201.26.224 android.clients.google.com
    mtalk.google.com

    i comment both of them and did what you said but it didn't work the first time
    2nd time i did that and it worked


    Thanks
    2
    i find this works

    1/ download adaway ... http://forum.xda-developers.com/showthread.php?t=2190753&nocache=1#

    2/ then download new hosts .. reboot!

    3/ then revert to original hosts reboot

    4/ hopefully we are working again!!!