[SOLUTION:] Can't Establish a reliable connection to the server/Playstore No Connect

Search This thread

dharunsonu

New member
Aug 19, 2016
1
0
I did all this. After doing this also the problem exists I'm my phone. Can't establish a reliable connection. Plz help
 

LavaTorch101

New member
Sep 10, 2016
1
0
Thank you so much the second methodnworked for me....... Thanx a lot if anyone wants to root without a problem (one click root) then use *kingo* its the best
 

moshec88

New member
Sep 17, 2016
1
0
thank you!!!

thank you so much! work for me :)
i got this problem on my nexus 7 device because i did "factory reset" when i have root. the root stay as was - the tablet didn't reset itself completely.
 

m05c0

New member
Oct 21, 2016
1
0
Dude, I'm Loosing My Head Over this. I Have This Damn problem with A Freaking Chinese Phone. This Piece Of Trash Don't Let Me Even Enter A Google Account, So I Searched For This Solution... And The Bad Thing Is This Phone Can't Be Rooted Because Of The Model... So How The F* Am I going to It The Host File? I Think This Is My Problem BC Anything Google Related On This Phone Is Not Working... And Everything Comes In Chinese So That's Why I Need Google And Its Damn Apps.... Please Help
 

Lightracer

Senior Member
May 28, 2016
379
110
Dude, I'm Loosing My Head Over this. I Have This Damn problem with A Freaking Chinese Phone. This Piece Of Trash Don't Let Me Even Enter A Google Account, So I Searched For This Solution... And The Bad Thing Is This Phone Can't Be Rooted Because Of The Model... So How The F* Am I going to It The Host File? I Think This Is My Problem BC Anything Google Related On This Phone Is Not Working... And Everything Comes In Chinese So That's Why I Need Google And Its Damn Apps.... Please Help
Have you tried using one click root apps? (like Kingroot or Kingoroot?)
 

honeyhoneyJS

New member
Nov 15, 2016
1
0
Hello. I'm facing the same problem.

I'm trying to edit the host file. Problem is, the host file does not even have this >>> 74.125.93.113 android.clients.google.com under the
127.0.0.1 localhost.
 

Lightracer

Senior Member
May 28, 2016
379
110
If all else fails, delete the hosts file. Make sure you back it up first then after you delete it, reboot. Check if it can establish a connection now.
 

davedario77

New member
Dec 3, 2016
1
0
Hi! I have been experiencing this problem over and over with my tablet, it's android 5.0.0 lolipop, and I have been resetting my phone for almost three time just to try to get it fixed... but still .... no luck... it only started when i rooted my phone using kingroot... that's all... any suggestions?
 

Lightracer

Senior Member
May 28, 2016
379
110
Hi! I have been experiencing this problem over and over with my tablet, it's android 5.0.0 lolipop, and I have been resetting my phone for almost three time just to try to get it fixed... but still .... no luck... it only started when i rooted my phone using kingroot... that's all... any suggestions?
Gain root access and delete the "hosts" file then clear the cache of the play store.
Press thanks if I helped :)

Sent from my espresso3g using XDA Labs
 

ismail.ahmed84

Senior Member
Nov 30, 2014
69
30
thanks alot

YOU ARE A GENIUS MAN THANK YOU 2 METHOD IS WORKING FOR ME AND I REGISTER AFTER SEEING YOUR POST THANK YOU AGAIN

AND I HAVE A QUESTION THAT I DO 2 METHOD AND ALL WORKING FINE BUT CAN I DO SAME AFTER RESET THE DEVICE OR NOT :confused:
 

shabbirpatheria

New member
Jul 3, 2016
2
0
I found a solution to the same problem somewhere else and the instructions were to the delete the whole text in the hosts file and replace it with " 127.0.0.1 localhost ". it worked pretty well for me but, can it cause any problems in the future since i deleted the whole text ??
 

npmsasi

New member
Mar 2, 2017
1
1
Another Way Playstore not working after Installing/Uninstalling Freedom App

Hi,

It is working on my Sony E3 D2212. Now i'm able to login in google play store.:good::good::good:

Thanks,


Another Way Playstore not working after Installing/Uninstalling Freedom App?

- Go to Root Explorer and Mount R/W then delete Hosts file under system/etc/
- Reboot
- Shutdown & Boot to Recovery
- Wipe Cache/Dalvik Cache
- Reboot
- Presto! back to normal.
 
  • Like
Reactions: Babydoll86

sarimo1

Member
Jul 12, 2015
44
6
CREDITS GOES TO: to crazzzzy (and many other users) (pandawill) for posting this solution.

WARNING: YOU MAY LOSE ALL YOUR DATA BY DOING THIS.

Issues:
- Account sync OFF permanently with the message: "Sync is currently experiencing problems".
- Signing in Google Apps fails showing message: "Can't establish a reliable connection to the server"

Possible Cause:
- system file named 'hosts' (/etc/hosts) points to a Google server that changed IP, thus blocking access to Apps.

Possible Solution:
edit 'hosts' file (/etc/hosts) deleting or commenting (adding a # at the beginning) the old line

Please do it at your own risk.

How to do it:

METHOD 1

1.- ROOT your device (of course)

2.- Editing the file
You will need a proper editor
Download and Install Total Commander and open it
OR DOWNLOAD BELOW

3.- Browse with Total Commander to root/etc
(hint: on the right side of the screen there's a shortcut to system folder.. look for etc/ and you will find it)
Tap mount R/W
Long tap on "hosts" > edit file > Totalcmd-Editor

Open etc/hosts and edit the file. Just put # before 74.125.93.113 android.clients.google.com.

4.- SAVED

Edited file should look like this:

127.0.0.1 localhost
#74.125.93.113 android.clients.google.com

remember: based on my own observation it should be look like this:

127.0.0.1(just one space)localhost
#74.125.93.113(just one space)android.clients.google.com

5.- Turn OFF your device.
6.(Not Necessary, Go to Next Step. But if the problem persist do Factory Reset..) Got it on Recovery Mode, Factory Data Reset, wipe data.
7. Reboot your device.
8. Once the phone reboots, input your google account information when the phone asks for it.
9.- Sync to your account and contacts

METHOD 2:

1. Make sure you have a ROOT ACCESS on your Device.
2. Install Root Explorer, Run App, Grant SU Access.
3. Browse root / etc... at the top of your screen you will see mount R/O and mount R/W...
4.Tap mount R/W
5.Look for host file, long press it and open with text editor.
6. just Add # (pound sign) on the first number.
like this:

#74.125.93.113(just one space)android.clients.google.com

SAVE IT and Reboot.
Now you can connect to Google Play very well.

UPDATE: 08/22/13

If above method fail to connect you properly or have some issue on wireless connection, revert the host file to its original state
and install this app on playstore:
https://play.google.com/store/apps/details?id=com.treb.hosts&hl=en

run app and choose your prefer edit.

Another Way Playstore not working after Installing/Uninstalling Freedom App?

- Go to Root Explorer and Mount R/W then delete Hosts file under system/etc/
- Reboot
- Shutdown & Boot to Recovery
- Wipe Cache/Dalvik Cache
- Reboot
- Presto! back to normal.

Edit:
Removed Attached Files you may download it on Google Playstore. :)

Total Commander: https://play.google.com/store/apps/details?id=com.ghisler.android.TotalCommander

Root Explorer: https://play.google.com/store/apps/details?id=com.speedsoftware.rootexplorer

Note: You may use your favorite File Manager as long as it can browse up to the root of your Phone..

Download Other File Managers:
Root Browser: http://forum.xda-developers.com/showthread.php?t=1338582 (Credits to the Devs)
ES Explorer: http://forum.xda-developers.com/showthread.php?t=2210417 (Credits to the Devs)

Note: If ABOVE method doesn't work for you... reflash rom would be your final choice!

JUST A SIMPLE CLICK ON THANKS BUTTON... WILL GLADLY APPRECIATED!
ACTIONS SPEAK LOUDER THAN WORDS SO YOU MAY CLICK THANKS BUTTON RATHER THAN THANK ME ON REPLY...
but there is no ip adress below
only 127.0.0.1 local host
what to do please
 
  • Like
Reactions: Har_sh94

Ashokk8

Senior Member
Dec 30, 2016
287
74
Visakhapatnam
Guys i am very much frustrated firstly this method (1) has worked for me but when i changed Rom again, save problem arised.
My address was totally different it is 127.0.0.1 localhost
::1 ip6-localhost
Like this. Tried everything and didn't find anything helpful please help
 

Top Liked Posts

  • There are no posts matching your filters.
  • 287
    CREDITS GOES TO: to crazzzzy (and many other users) (pandawill) for posting this solution.

    WARNING: YOU MAY LOSE ALL YOUR DATA BY DOING THIS.

    Issues:
    - Account sync OFF permanently with the message: "Sync is currently experiencing problems".
    - Signing in Google Apps fails showing message: "Can't establish a reliable connection to the server"

    Possible Cause:
    - system file named 'hosts' (/etc/hosts) points to a Google server that changed IP, thus blocking access to Apps.

    Possible Solution:
    edit 'hosts' file (/etc/hosts) deleting or commenting (adding a # at the beginning) the old line

    Please do it at your own risk.

    How to do it:

    METHOD 1

    1.- ROOT your device (of course)

    2.- Editing the file
    You will need a proper editor
    Download and Install Total Commander and open it
    OR DOWNLOAD BELOW

    3.- Browse with Total Commander to root/etc
    (hint: on the right side of the screen there's a shortcut to system folder.. look for etc/ and you will find it)
    Tap mount R/W
    Long tap on "hosts" > edit file > Totalcmd-Editor

    Open etc/hosts and edit the file. Just put # before 74.125.93.113 android.clients.google.com.

    4.- SAVED

    Edited file should look like this:

    127.0.0.1 localhost
    #74.125.93.113 android.clients.google.com

    remember: based on my own observation it should be look like this:

    127.0.0.1(just one space)localhost
    #74.125.93.113(just one space)android.clients.google.com

    5.- Turn OFF your device.
    6.(Not Necessary, Go to Next Step. But if the problem persist do Factory Reset..) Got it on Recovery Mode, Factory Data Reset, wipe data.
    7. Reboot your device.
    8. Once the phone reboots, input your google account information when the phone asks for it.
    9.- Sync to your account and contacts

    METHOD 2:

    1. Make sure you have a ROOT ACCESS on your Device.
    2. Install Root Explorer, Run App, Grant SU Access.
    3. Browse root / etc... at the top of your screen you will see mount R/O and mount R/W...
    4.Tap mount R/W
    5.Look for host file, long press it and open with text editor.
    6. just Add # (pound sign) on the first number.
    like this:

    #74.125.93.113(just one space)android.clients.google.com

    SAVE IT and Reboot.
    Now you can connect to Google Play very well.

    UPDATE: 08/22/13

    If above method fail to connect you properly or have some issue on wireless connection, revert the host file to its original state
    and install this app on playstore:
    https://play.google.com/store/apps/details?id=com.treb.hosts&hl=en

    run app and choose your prefer edit.

    Another Way Playstore not working after Installing/Uninstalling Freedom App?

    - Go to Root Explorer and Mount R/W then delete Hosts file under system/etc/
    - Reboot
    - Shutdown & Boot to Recovery
    - Wipe Cache/Dalvik Cache
    - Reboot
    - Presto! back to normal.

    Edit:
    Removed Attached Files you may download it on Google Playstore. :)

    Total Commander: https://play.google.com/store/apps/details?id=com.ghisler.android.TotalCommander

    Root Explorer: https://play.google.com/store/apps/details?id=com.speedsoftware.rootexplorer

    Note: You may use your favorite File Manager as long as it can browse up to the root of your Phone..

    Download Other File Managers:
    Root Browser: http://forum.xda-developers.com/showthread.php?t=1338582 (Credits to the Devs)
    ES Explorer: http://forum.xda-developers.com/showthread.php?t=2210417 (Credits to the Devs)

    Note: If ABOVE method doesn't work for you... reflash rom would be your final choice!

    JUST A SIMPLE CLICK ON THANKS BUTTON... WILL GLADLY APPRECIATED!
    ACTIONS SPEAK LOUDER THAN WORDS SO YOU MAY CLICK THANKS BUTTON RATHER THAN THANK ME ON REPLY...
    4
    Thanks Alot man !!!

    Thanks Alot man !!! it works

    here are the steps ( your device must me rooted ) :

    1. download total commandar.apk from google
    2. Install it in your android mobile
    3. open the total commandar from ur android mobile and goto File System root
    4. search for the folder etc and open that folder
    5. now search for the file name ' hosts ' and click on it .
    6. select edit file and add ---> " # " <--- before 2nd line like this " #74.125.93.113 android.clients.google.com "
    7. and save it
    8. Reboot your device
    9. turn on ur wifi and ADD GOOGLE ACCOUNT !!! Enjoy
    4
    Well well... after so much of experimenting, finally the HOSTS patch did the work!!!

    Edited the HOSTS using Root Explorer, rebooted the device...and VIOLA!!!!
    Tons of notifications...
    I guess all apps using GCM too were stuck!

    Thanks a ton!!!
    Cheers!

    SHOULD i expect you to click the THANKS button... :p

    It worked without factory reset

    Initially I tried to edit the "hosts" file with ES File explorer but failed to do so then I tried it with Root Explorer and result was the same, finally I downloaded Total Commander apk and edited the file and when I attempted to save changes it asked for permission which I allowed and saved it. Then I reboot my device and opted for add account and it just worked. My IP was not the same as mentioned above but I didn't change it rather I just put that # tag before second line.

    I went through these steps

    1. Downloaded and Installed Total Commandar.apk
    2. Open Total Commander and go to File System Root
    3. Allow Root permission when asked
    4. Search for the folder named "etc" and open it
    5. Now search for the file named ' hosts ' and click on it .
    6. Select edit file and add " # " before 2nd line like this #74.125.93.113 android.clients.google.com
    7. And save it.
    8. Reboot your device
    9. Turn on your data connection and ADD GOOGLE ACCOUNT !!! Enjoy

    PLEASE click thanks :p

    dear
    brother ur metho-1 works

    highly thanks to uuu
    i love you

    rajdeep

    yay! just click THANKS under my name would be great!
    2
    I read your solution but when i saw my host file there was a different ip address

    127.201.26.224 android.clients.google.com
    mtalk.google.com

    i comment both of them and did what you said but it didn't work the first time
    2nd time i did that and it worked


    Thanks
    2
    i find this works

    1/ download adaway ... http://forum.xda-developers.com/showthread.php?t=2190753&nocache=1#

    2/ then download new hosts .. reboot!

    3/ then revert to original hosts reboot

    4/ hopefully we are working again!!!