[SOLUTION] Getting Wi-Fi Connectivity Issues Fixed On Samsung Galaxy I 9000...

Search This thread

ApnaDroid

Senior Member
Nov 17, 2010
62
20
0
If you are also experiencing Wi-fi connectivity issues with Samsung Galaxy I 9000 here is the solution :


Problem :


samsung-galaxy-I9000-network-issues.png

Solution (Tested Personally) :
To get Wi-Fi fixed on your Samsung Galaxy I 9000 follow the instructions detailed below :

  • Make sure Wi-Fi is ON and Navigate to Settings -> Wireless and Network -> Wi-Fi Settings, now click the left-side context-menu button on your phone to bring-up Advanced option and click it.
    i9000-wifi-fix-step-1.png
  • Now to get things working we will need to make cellphone use a static IP address for Wi-Fi, check the Use Static IP option and proceed with entering values manually.
    i9000-wifi-fix-step-3.png
  • If you are not sure what values to use take a look at your network-adapter status on computer, here are my settings (should works on most default router setups).
    i9000-wifi-fix-step-4.png
  • Enter all values and your screen should now look like the one below.
    static-edit-wifi.png
  • Now go back to your Wi-Fi settings page and click your access-point name and it should show you the manually entered IP value.
    i9000-wifi-fix-step-2.png
  • Your Wi-Fi issues should be now over.

If you need help with manual values do ask here.
 

ksh20480

Senior Member
May 28, 2008
114
7
0
Mumbai
If you are also experiencing Wi-fi connectivity issues with Samsung Galaxy I 9000 here is the solution :


Problem :


samsung-galaxy-I9000-network-issues.png

Solution (Tested Personally) :
To get Wi-Fi fixed on your Samsung Galaxy I 9000 follow the instructions detailed below :

  • Make sure Wi-Fi is ON and Navigate to Settings -> Wireless and Network -> Wi-Fi Settings, now click the left-side context-menu button on your phone to bring-up Advanced option and click it.
    i9000-wifi-fix-step-1.png
  • Now to get things working we will need to make cellphone use a static IP address for Wi-Fi, check the Use Static IP option and proceed with entering values manually.
    i9000-wifi-fix-step-3.png
  • If you are not sure what values to use take a look at your network-adapter status on computer, here are my settings (should works on most default router setups).
    i9000-wifi-fix-step-4.png
  • Enter all values and your screen should now look like the one below.
    static-edit-wifi.png
  • Now go back to your Wi-Fi settings page and click your access-point name and it should show you the manually entered IP value.
    i9000-wifi-fix-step-2.png
  • Your Wi-Fi issues should be now over.

If you need help with manual values do ask here.
is tis te lan ip or wan ip?
 

upp3rd0g

Senior Member
Sep 4, 2010
50
2
0
If you need help with manual values do ask here.

I don't mean to be offensive but your recommendations make no sense at all...

You are saying: if you have wifi troubles switch from DHCP assigned ip-addresses to static ip-addresses, using the settings which are personal to _your_ setup at _your_ house.

If for some reason static-ip-address gives you a better connectivity I suggest you start investigating your DHCP configuration in your network.
 
  • Like
Reactions: Karupan

ApnaDroid

Senior Member
Nov 17, 2010
62
20
0
I don't mean to be offensive but your recommendations make no sense at all...

You are saying: if you have wifi troubles switch from DHCP assigned ip-addresses to static ip-addresses, using the settings which are personal to _your_ setup at _your_ house.

If for some reason static-ip-address gives you a better connectivity I suggest you start investigating your DHCP configuration in your network.

No offense taken, but being a system administrator and software developer for 9 years I know what I am talking about. The "DHCP configuration" on my network/router is fine, it is working flawlessly for past few years with 8 computers on the LAN with multiple wi-fi devices connecting to it almost on daily basis - only SGS gets the Wi-Fi blues; it is the 'SGS DHCP' driver implementation which is having issues - without a static IP SGS connects and works for some time but have issues re-connecting automatically after a screen-off or long break. I personally had used my iPhone 3G on this setup for more then a yaear (and many other phones/devices occasionally) without a hiccup and problems were there on SGS from very first day until I used the STATIC IP.


Here are some forum/blog posts/user opinions confirming the SGS wifi issue and the static ip solution :


If you are having SGS Wi-fi issues, have you tried this solution ?
 
Last edited:
R

rajesh26e4u

Guest
Thanks for the tip. But I was wondering how the wifi would perform if you were at a wifi zone other than your house wifi with these settings. For example, university library or a coffee shop. Would the wifi connectivity get distorted due to these settings when we're using free wifi such as the above mentioned?
 

amwebby

Senior Member
Aug 17, 2010
405
20
0
Thorpe Bay
www.amoc.org
I haven't tried this but have the same concern about switching to other wifi networks. My data plan includes free wifi connection to the Cloud, BT Openzone and other wifi hotspots. I would be concerned at the effect of a static IP address on those.

I have only noticed an issue with wifi since upgrading to Froyo. Sometimes the phone dies not switch back from 3G or HDSPA when I return to a wifi zone. The workaround is to switch wifi off and back on again. I have an unlimited data plan so the only concern is speed but that does make it annoying.
 

ApnaDroid

Senior Member
Nov 17, 2010
62
20
0
Thanks for the tip. But I was wondering how the wifi would perform if you were at a wifi zone other than your house wifi with these settings. For example, university library or a coffee shop. Would the wifi connectivity get distorted due to these settings when we're using free wifi such as the above mentioned?

I haven't tried this but have the same concern about switching to other wifi networks. My data plan includes free wifi connection to the Cloud, BT Openzone and other wifi hotspots. I would be concerned at the effect of a static IP address on those.

I have only noticed an issue with wifi since upgrading to Froyo. Sometimes the phone dies not switch back from 3G or HDSPA when I return to a wifi zone. The workaround is to switch wifi off and back on again. I have an unlimited data plan so the only concern is speed but that does make it annoying.

"There's an app for that" ;) - http://www.appbrain.com/app/wifi-static/com.farproc.wifi.statIc
 

akshayadv

Senior Member
Nov 21, 2010
53
4
0
Now connects but no Data Transfer

Hello ApnaDroid,

Thanks for your trick.. Now I can get "connected" but cannot have any data transfer.. when I connect to my wifi router (my modem and wifi router are seperate units) which is on 10.1.1.10, I dont see it connected and having data transfer. Strangely, when I see under WiFi routers wireless statistics, I cann see the MAC address of the Galaxy S showing this in front "STA-ASSOC".

That means, that I am getting connecetd to the wifi alright.... but no data transfer... MIND YOU, WITH NO CHANGES TO THE SAME WIFI, WHEN I FACTORY RESET, EVERYTHING WORKS FINE.

Please guide. Is there any way to patch this in Froyo Build DDJP6.

Regards

PS ; Is there any way I can reset the Wifi to factory settings without Hard Formatting (Factory Formatting) my Galaxy S ???
 
Last edited:

akshayadv

Senior Member
Nov 21, 2010
53
4
0
This solved it..

Hello ApnaDroid,

Thanks for your trick.. Now I can get "connected" but cannot have any data transfer.. when I connect to my wifi router (my modem and wifi router are seperate units) which is on 10.1.1.10, I dont see it connected and having data transfer. Strangely, when I see under WiFi routers wireless statistics, I cann see the MAC address of the Galaxy S showing this in front "STA-ASSOC".

That means, that I am getting connecetd to the wifi alright.... but no data transfer... MIND YOU, WITH NO CHANGES TO THE SAME WIFI, WHEN I FACTORY RESET, EVERYTHING WORKS FINE.

Please guide. Is there any way to patch this in Froyo Build DDJP6.

Regards

PS ; Is there any way I can reset the Wifi to factory settings without Hard Formatting (Factory Formatting) my Galaxy S ???

After doig all the above, I again switched back and unchecked the "Static IP". Then voila... I tried this...i open allshare app which go to wifi settings and connect to the wifi then just close allshare and you have wifi

Went to allshare ad enables wifi... IT WORKS...
 

idimintu

New member
Nov 23, 2010
3
0
0
As soon as I updated to Froyo I had the same issue with regards to wifi refusing to reconnect to my Netgear WNR2000 at home after a short while, it was fine with Eclair and worked fine with a Draytek 2600 at work after update.

My solution was to change the Netgear router to use WPA2 encryption and not mixed WPA/WPA2, have not had a problem since. I have not tried other methods yet.
 

spilurus

New member
Dec 2, 2010
1
0
0
Woah, the AllShare method really worked for me. I went out one day and tried to connect unsuccessfully to a hotspot. When I came back, the Wifi didn't work and was stuck at "Obtaining an IP address". Nothing else worked, but accessing the wifi settings through Allshare, gave it an external ip address, (169.152.647.201 or something or other) and from there, refreshed to obtain a local IP within the proper subnet.

Thanks akshayadv!
 

VeenK

Senior Member
Oct 22, 2008
67
0
0
Woah, the AllShare method really worked for me. I went out one day and tried to connect unsuccessfully to a hotspot. When I came back, the Wifi didn't work and was stuck at "Obtaining an IP address". Nothing else worked, but accessing the wifi settings through Allshare, gave it an external ip address, (169.152.647.201 or something or other) and from there, refreshed to obtain a local IP within the proper subnet.

Thanks akshayadv!

Hi,

My Stock 2.1 did not have any wifi problems. Now updating to stock 2.2 it does. Found a little app on market, Wifi Fixer from Zanshin which did not do anything to improve. Uninstalled it again. Restarting my Bogpond Netgear cable modem router (CG814WGv3) did do the trick for about 2 minutes before dropping again. Another time the wifi stays on but no connection to internet. Which is not correct as other wifi phone does connect as well as my wifi laptop and this computer. Phone reboot will fix wifi for a little while. So I do think this is a Froyo 2.2 issue and dont want to change the router settings as it did work before without a problem. I dont want to go the static IP route for now.

I am wondering if it has anything to do with maybe my Aura gps program. Not so much because of the gps, but because the program wants a data connection at times. Similar with google maps I hear... I see some people suggesting this may create a conflict when only on wifi even though it initially works, something with re-associating the wifi. I am not that technical, so I leave it for your consideration...

???
I would like to find out more about the Allshare method. Could not find an app on market with this name, what is it, where to find, and how to go about it?

Any other solutions or fixes? (I find so many posts/threads, which so little on possible fixes.)

Phone details in signature.

Thanks
 
Last edited:

akshayadv

Senior Member
Nov 21, 2010
53
4
0
Dear VeenK,
All Samsung Galaxy S Froyo ROMs have an app called allshared which comes pre-installed. (Mine is DDJP6 with OCLF installed). I have been using this to connect to the internet. I havent changed any settings like Static IP or the like.. Its just factory settings which are left untouched in my phone.

Method : Just start your Allshare app and when it askes to connect to WiFi, click OK. When the WiFi is connected in allshared, simply close the app and you have the working WiFi. (downside is that the WiFi will have to be connected again using allshare after power off and power on)

Try the allshare app and let us know your feedback... (It has worked for me everythime.. A bit frustrating though that you have to do it off anf on. But its a workaround discovered by me almost by accident. much better than doing a factory reset everytime).

Regards
 
  • Like
Reactions: PauCore

sn3rge

New member
Feb 13, 2011
1
0
0
Allshare

Thanks, this workaround worked for me ! Still hate Samsung but at least I can connect to my home wifi again ....

Dear VeenK,
All Samsung Galaxy S Froyo ROMs have an app called allshared which comes pre-installed. (Mine is DDJP6 with OCLF installed). I have been using this to connect to the internet. I havent changed any settings like Static IP or the like.. Its just factory settings which are left untouched in my phone.

Method : Just start your Allshare app and when it askes to connect to WiFi, click OK. When the WiFi is connected in allshared, simply close the app and you have the working WiFi. (downside is that the WiFi will have to be connected again using allshare after power off and power on)

Try the allshare app and let us know your feedback... (It has worked for me everythime.. A bit frustrating though that you have to do it off anf on. But its a workaround discovered by me almost by accident. much better than doing a factory reset everytime).

Regards
 

yani2000

Senior Member
Jul 23, 2010
453
92
48
...
Method : Just start your Allshare app and when it askes to connect to WiFi, click OK. When the WiFi is connected in allshared, simply close the app and you have the working WiFi. (downside is that the WiFi will have to be connected again using allshare after power off and power on)
...
I had to start the AllShare app only ONCE and never more, even after phone reboot.
I am currently using "Static IP" solution since I had v2.2 installed and it works everywhere (DHCP/public cafes(nobody must have the same IP number as the IP number I assigned for my phone), Static/home).

@ApnaDroid (OP):
Great tutorial with pics!
But for DNS1 and DNS2 I think you need to input "192.168.1.1" (router's IP number) in both fields, because "192.168.1.2" is the first device connected to your router.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Problem:
    Obtaining IP Address
    Also Known As
    01:35:42.634 Error dhcpcd 1082 /system/etc/dhcpcd/dhcpcd-run-hooks: Permission denied

    Solution:
    Flash with CWM this file -> DOWNLOAD
    works on both CWM's - tested on JVB but should work on other FW's...
    2
    If you are also experiencing Wi-fi connectivity issues with Samsung Galaxy I 9000 here is the solution :


    Problem :


    samsung-galaxy-I9000-network-issues.png

    Solution (Tested Personally) :
    To get Wi-Fi fixed on your Samsung Galaxy I 9000 follow the instructions detailed below :

    • Make sure Wi-Fi is ON and Navigate to Settings -> Wireless and Network -> Wi-Fi Settings, now click the left-side context-menu button on your phone to bring-up Advanced option and click it.
      i9000-wifi-fix-step-1.png
    • Now to get things working we will need to make cellphone use a static IP address for Wi-Fi, check the Use Static IP option and proceed with entering values manually.
      i9000-wifi-fix-step-3.png
    • If you are not sure what values to use take a look at your network-adapter status on computer, here are my settings (should works on most default router setups).
      i9000-wifi-fix-step-4.png
    • Enter all values and your screen should now look like the one below.
      static-edit-wifi.png
    • Now go back to your Wi-Fi settings page and click your access-point name and it should show you the manually entered IP value.
      i9000-wifi-fix-step-2.png
    • Your Wi-Fi issues should be now over.

    If you need help with manual values do ask here.
    1
    If you need help with manual values do ask here.

    I don't mean to be offensive but your recommendations make no sense at all...

    You are saying: if you have wifi troubles switch from DHCP assigned ip-addresses to static ip-addresses, using the settings which are personal to _your_ setup at _your_ house.

    If for some reason static-ip-address gives you a better connectivity I suggest you start investigating your DHCP configuration in your network.
    1
    Dear VeenK,
    All Samsung Galaxy S Froyo ROMs have an app called allshared which comes pre-installed. (Mine is DDJP6 with OCLF installed). I have been using this to connect to the internet. I havent changed any settings like Static IP or the like.. Its just factory settings which are left untouched in my phone.

    Method : Just start your Allshare app and when it askes to connect to WiFi, click OK. When the WiFi is connected in allshared, simply close the app and you have the working WiFi. (downside is that the WiFi will have to be connected again using allshare after power off and power on)

    Try the allshare app and let us know your feedback... (It has worked for me everythime.. A bit frustrating though that you have to do it off anf on. But its a workaround discovered by me almost by accident. much better than doing a factory reset everytime).

    Regards
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone