Question [SOLVED] Android Pay not working on OOS 13 C.20? [NE2213]

Search This thread

NHNXDA

Senior Member
Jan 26, 2008
366
61
C21 hasn't fixed it as I'm on C21 after backdating from C22 that's got networking issues, low & behold wallet keeps failing intermittently at stores.

As someone else stated, intermittently the card machines ask to insert a card, but then another store it works, never had these issues before.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    So, I'm among the ones with no work profile and experiencing the issue.
    Looks like I managed to FIX IT!!!
    • Disabled multiple users
    • Disabled (and deleted) system cloner profile
    Not sure which one made the trick, suspect it was the system cloner which I'd expect to work in way closer to the work profiles, will try a the next payment 😁 but at least Wallet is back working!!!
    3
    Found a workaround solution that may work for some of you, tested and it works!

    1 Disable Google pay/wallet as your default NFC app - choose any other option like Amex pay or others

    2 Toggle NFC off and on just to be sure

    3 Open your GPay app manually, you should see the card you want to pay with, then tap on the terminal as normal

    Hope this helps. My set is NE2215 , c20 with active work profile. No. Factory reset and other solutions didn't work.
    2
    For all who aren´t able to add a credit card to Google Wallet with rooted devices on C.20. It works with Magisk if you:

    1. install modules safetynet-fix and hide-props-config (latest versions)
    2. set magisk hide and enable zygisk
    3. force deny list check Google Play, Google Play Services, Google Wallet
    4. open a terminal app (I used termux with command "su") and type in "props"
    5. be patient until props shows its alternatives, then choose fingerprint of "Google 6 Pro" and set this as the default one
    6. delete complete data of above mentioned Google apps
    7. reboot and check in Google Playstore if device is shown as "certified" or latest Google Play Update is shown
    8. optional check safetynet status with Yasnac etc.

    But you should be good from this on. You can use Google Wallet as expected. I did a factory reset before the process, but I´m not sure if this is necessary.
    2
    LOL! Got the update like 1h after finding the fix myself! Thank you OnePlus! :ROFLMAO:
    I still couldn't get any fix to work but C21 has fixed it for me (thankfully).
    2
    Well, C21, which is rolling out also fixed it :p