• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question [SOLVED] Anyone with rooted 10s (with or without TWRP) and Google Pay working?

Search This thread

woody4165

Senior Member
Nov 30, 2011
243
36
Rome
Hi

I succeded in rooting this phone without TWRP following this guide and applied the SafetyNet Fix without success.
I have also a rooted Poco X3 NFC with stock MIUI 12.5 where SafetynetFix is working fine. I have not flashed TWRP on the POCO, but I just use TWRP to boot into recovery, when needed.

Anyone succeded in having the RN 10s rooted with GPay working?

Thanks
 
Last edited:
Feb 2, 2015
12
1
Yup google pay is working for me. Make sure safetynet passes. I followed this: Root then install magisk as an app with different name, enabled magisk hide, enable safetynet fix, reboot and then install google pay
 
  • Like
Reactions: woody4165

woody4165

Senior Member
Nov 30, 2011
243
36
Rome
Yup google pay is working for me. Make sure safetynet passes. I followed this: Root then install magisk as an app with different name, enabled magisk hide, enable safetynet fix, reboot and then install google pay
Safetynet unfortunately does not pass.
Which version of SafetyNet Fix did you use?

I will check again.

Thanks
 

woody4165

Senior Member
Nov 30, 2011
243
36
Rome
Yup google pay is working for me. Make sure safetynet passes. I followed this: Root then install magisk as an app with different name, enabled magisk hide, enable safetynet fix, reboot and then install google pay
When you say "install magisk as an app with different name" you mean that I have to install Magisk normally, then from the Magisk settings, reinstall with different name to hide it from other app.
Is it correct?
Thanks
 

woody4165

Senior Member
Nov 30, 2011
243
36
Rome
THANKS @abhinavprateek

Finally it's working!!!

Probably the issue was the correct version of SafetyNet Fix that has to be the Riru one, version 2.1.2 actually (and Riru has to be installed in Magisk previously, as you wrote).
After installing Safetynet fix I cleared all data in those apps:
Google Pay
Play Store
Play Services

and rebooted

Then the safetynet check in Magisk was working ad also Google Pay
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Yup google pay is working for me. Make sure safetynet passes. I followed this: Root then install magisk as an app with different name, enabled magisk hide, enable safetynet fix, reboot and then install google pay