[solved]Bootloader and Baseband versions are blank

Search This thread

dushan90

Senior Member
Dec 22, 2008
142
26
Seeduwa
So my phone booted into the stock recovery (no TWRP installed) when I accidentally selected the wrong update method in magisk. It kept on rebooting to the recovery even after selecting reboot device and tried clearing cache. Even after that it booted back to the recovery. Then I turned off the phone. And now when the phone turns on it goes to bootloader even after selecting recovery mode. And in the bootloader "Bootloader Version" and "Baseband Version" are blank. This is what it shows;

Fastboot Mode
PRODUNT_NAME - sdm845
VARIANT - SDM UFS
BOOTLOADER VERSION -
BASEBAND VERSION -
SERIAL NUMBER - "Serial number available"
SECURE BOOT - yes
DEVICE STATE - unlocked

PC doesn't recognize it either.
Under device manager it says "Unknown USB Device (Device Descriptor Request Failed)
I'm having 6T 6GB RAM (International)
Bootloader unlocked


Any idea as to why this happens and how to solve it?

Thanks
 
Last edited:

dushan90

Senior Member
Dec 22, 2008
142
26
Seeduwa
PC recognized the phone after trying a different USB port. And even detects fastboot.

What should I do to get this booted into the system?

fastboot boot twrp-3.2.3-2-fajita.img gave below error.
FAILED (remote: Failed to load/authenticate boot image: Load Error)

Still selecting "Recovery Mode" reboots to Bootloader
 
Last edited:

indian84

Senior Member
Mar 30, 2012
4,117
2,873
Doha
PC recognized the phone after trying a different USB port. And even detects fastboot.

What should I do to get this booted into the system?

fastboot boot twrp-3.2.3-2-fajita.img gave below error.
FAILED (remote: Failed to load/authenticate boot image: Load Error)

Still selecting "Recovery Mode" reboots to Bootloader
Use MSM Tool to recover the device. That's the easiest option.
 
  • Like
Reactions: dushan90

dushan90

Senior Member
Dec 22, 2008
142
26
Seeduwa
Alright. So this is how I solved my problem.

First entered
Code:
fastboot --set-active=b

And that solved FAILED (remote: Failed to load/authenticate boot image: Load Error) error.

After that I managed to boot to twrp by
Code:
fastboot boot twrp-3.2.3-0-fajita.img

At first, the phone got stuck at Oneplus logo.
Pressing Vol Up + Power for about 10 seconds turned off the phone. Pressing Power button for a few more seconds turned it back on to bootloader. Enterd the previous code once again booted it to TWRP.

Sideloaded 9.0.13 downloaded from Oneplus site and rebooted.

Problem solved. Everything was saved.
 
  • Like
Reactions: i7vSa7vi7y

i7vSa7vi7y

Senior Member
Feb 4, 2012
340
27
Alright. So this is how I solved my problem.

First entered
Code:
fastboot --set-active=b

And that solved FAILED (remote: Failed to load/authenticate boot image: Load Error) error.

After that I managed to boot to twrp by
Code:
fastboot boot twrp-3.2.3-0-fajita.img

At first, the phone got stuck at Oneplus logo.
Pressing Vol Up + Power for about 10 seconds turned off the phone. Pressing Power button for a few more seconds turned it back on to bootloader. Enterd the previous code once again booted it to TWRP.

Sideloaded 9.0.13 downloaded from Oneplus site and rebooted.

Problem solved. Everything was saved.
Beast mode nice job and thanks for sharing your fix

Sent from my [device_name] using XDA-Developers Legacy app
 

raj1994patel

Member
Nov 10, 2013
15
4
I have the same issue..
Is it possible to restore the baseband version by entering this commands?

In my situation, I already wiped and boot into the system.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    PC recognized the phone after trying a different USB port. And even detects fastboot.

    What should I do to get this booted into the system?

    fastboot boot twrp-3.2.3-2-fajita.img gave below error.
    FAILED (remote: Failed to load/authenticate boot image: Load Error)

    Still selecting "Recovery Mode" reboots to Bootloader
    Use MSM Tool to recover the device. That's the easiest option.
    1
    Alright. So this is how I solved my problem.

    First entered
    Code:
    fastboot --set-active=b

    And that solved FAILED (remote: Failed to load/authenticate boot image: Load Error) error.

    After that I managed to boot to twrp by
    Code:
    fastboot boot twrp-3.2.3-0-fajita.img

    At first, the phone got stuck at Oneplus logo.
    Pressing Vol Up + Power for about 10 seconds turned off the phone. Pressing Power button for a few more seconds turned it back on to bootloader. Enterd the previous code once again booted it to TWRP.

    Sideloaded 9.0.13 downloaded from Oneplus site and rebooted.

    Problem solved. Everything was saved.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone