Question [Solved] BOOTLOOPED phone after A12 update. NANDroid restore caused Camera/Fingerprint to become completely disabled

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Update 4: All issues fixed! I'll briefly explain all my issues, what I think caused them, and how i resolved them incase it helps others.

    (You can find 3 posts of my original issues by scrolling down, but TL;DR)

    4th post (at the top) : Brief summary of all solutions for my 3 big issues.

    3rd post: nandroid backup applied, fingerprint+camera stopped working. Fix: reflash Persist partition manually, using the "" file from the TWRP backup folder

    2nd post: Bootloop due to... miscelaneous user errors. Fixed by using TWRP reformat then restoring to nandroid backup.

    1st post: Bootloop due to wrong boot.img. Fix: reflashed boot.img downloaded from post#8 of this thread

    context: I'm using a DN2103 (international Nord 2) phone variant, which received the .A12 operating system update in the past couple days. Meanwhile, Indian users received the .A13 update.

    In my process to unroot and update to the new OTA operating system, I used the stock boot.img provided by an indian user, which was the boot.img for the .A13 update which was incompatible with the european .A12 OTA operating system.

    Basically I had the wrong boot.img

    BOOTLOOP FIX: (this assumes you have the appropriate MTK drivers and ADB drivers, if not, lookup how to get those installed or you can't run ADB or fastboot commands)

    1. Download the correct stock boot.img for your version: I got mine from
    2. Transfer the new boot.img and a copy of vbmeta.img (optional) into the folder where your adb.exe is located (usually platform tools folder). I use the stock vbmeta from the OTA updates from from:
    3. Reflash your downloaded stock boot image using commands "fastboot devices" to see if you device responds, if it does, then send "fastboot flash boot boot.img".
    4. Reboot phone. If it's still stuck in a bootloop, try flashing vbmeta with command "fastboot flash vbmeta vbmeta.img" similar to the boot image flash.
    If you don't have ADB and Mediatek drivers installed, but have TWRP installed, you can do the same from Step 2: Transfer files onto phones internal storage, and step 3) Use the install button in TWRP to flash boot.img to the "Boot" partition. You can also do the same for vbmeta.img to the vbmeta partition if you phone doesn't boot after that.

    Hopefully it works. If not, I'm afraid you'll need to boot into TWRP, (if you ahve it installed) and press Wipe, and wipe data/dalvik/cache, then press Wipe again, and reformat the whole phone. If you can get into stock recovery, then you can also use that to format all data. That should get your phone completely wiped to fresh and should boot into a welcome screen, for first time setup.

    (note: If you used TWRP to restore or wipe all partitions, PERSIST partition will not be functional leading to camera/fingerprint issues, solution below)

    To get into TWRP whilst your phone is bootlooping, you can hold volume up + power to force your phone to reboot, as soon as logos fade, you can press volume down + power to get your phone into fastboot mode. Connect PC, open powershell terminal, phone should respond to "fastboot devices" command. You can then send "fastboot reboot recovery" comand to get it into TWRP.

    Fix for Fingerprint scanner and Camera not working:

    Apparently when you restore to a TWRP backup, TWRP does not correctly flash the PERSIST partition, so you simply need to do it manually. The persist partition contains sensor calibration data for the fingerprint and camera.

    Steps I took for this fix
    1) Went to my nandroid/TWRP backup which I had saved to my PC
    2) Located file ""
    3) On PC, open ADB terminal in the same folder containing the "" file (on windows shift+right click to open powershell)
    4) Connected phone to PC, sent command "adb devices" to check if device responds, if listed, sent command "adb reboot bootloader" to get device into fastboot mode
    5) Sent command "fastboot devices" to see if device responds, if listed, sent command "fastboot flash persist"
    6) Took 1.5 seconds to send 54000 ish KB. Shoud see OKAY's on powershell screen
    7) sent command "fastboot reboot" to boot phone up.

    Big thanks to @HofaTheRipper for providing the stock A12 boot.img and the persist partition fix!

    Post 3 (you can find original post and 2nd post below too)

    Phone no longer bootloops, but fingerprint scanner +camera no longer work.

    Solution in post #24 of this thread by @HofaTheRipper

    Basically caused by TWRP not flashing the Persist partition correctly, so it's solved by finding the "" file from a Nandroid backup, and flashing that manually.

    So phone no longer bootloops which is great, but the camera and fingerprint sensor currently don't work or respond at all

    Fingerprint scanner: Trying to register a fingerprint results in the phone vibrating nonstop saying "TRY AGAIN" in big letters, with small letters "unable to complete finger print settings please retry". It continues to vibrate until the settings app is closed or minimised, and won't register a new finger at all. In fact, the fingerprint sensor doesn't even light up, and hte vibrates are the kind of vibrate the phone does to let you know theres an "error" or "not accepted try again" kind of vibration.

    Camera issues: Using the option to register facial recognition in the settings app can't open camera due to error message; "camera being used by another app. Please retry later." Even just opening the stock camera app itself instantly crashes. All other apps that use a camera say they do not have permissions to access the camera, despite very clearly having been granted permission.

    What I've tried so far:
    -Rolling back to A11 OS
    -OTA updating afresh back to A12 (again)
    -using TWRP wipe darvik/cache/data
    -using TWRP to reformat all data
    -using settings app, android's wipe data and factory reset option
    -googling and searching xda a tonne to find any possible leftover remnants of fingerprints left behind from my previous OS install

    One of the thread i found suggest there could be fingerprints i could delete; but I can't find the relevant files on my device.

    My 2nd bootloop did indeed force me to do a TWRP wipe+reformat whilst the device was encrypted/ had a pincode, so perhaps theres some kind of security feature that's getting tripped here.

    I tried the backup to Nandroid on A11, then used the OTA update to update to A12, so something tells me that perhaps a stock os reflash wouldn't help in my case.

    It would be nice to have to full stock OS's for A11, A12, and A13 just to try them out and help troubleshoot.

    Any help finding a solution to the camera/fingerprint issue is appreciated, or any help hunting down where I can download the full OS versions. (even for older OS's for the nord2)

    My new working theory is perhaps android's innate permission system is messed up, or there's some data stored in the security module that isn't being wiped that's withholding these features relating to the fingerprint/facial unlock security features.

    Every single app that tries to access camera is giving back a "please grant permissions" error, despite very clearly have permissions to use the camera.

    Any ideas on how to resolve this would be great!

    EDITTED: Part 2, BOOT LOOPING AGAIN. Flashing boot.img doesn't resolve bootloop this time around and the phone has a pincode that I forgot to remove.

    This is most likely caused due to magisk trying to modify the boot.img for the wrong stock A13 boot image, which no longer existed as I had flashed in the boot image for stock A12 as part of my first bootloop fix; But the phone still had its old data and magisk installation running.

    Solved it by using TWRP Wipe option to factory reset and format data. After that, I was able to get the device to boot - current issue is just that the camera and fingerprint sensor don't work


    After flashing boot.img for A12, I managed to boot the phone, solving the initial bootloop. However, it didn't take me long to notice issues, and walk straight into another bootloop.

    Series of events;
    -Phone asked for initial setup including forcing me to apply pincode (can't skip that step)
    -Part of pin setup, noticed fingerprint reader not working (vibrates and error message "unable to complete finger print settings please retry")
    -Part of pin setup, noticed comera not working during facial recognition step (error message "camera app used by another app")
    -Noticed camera app crashes instantly.
    -forgot to remove passcode as was in the app drawer and was exploring what was going on, got distracted.
    -I checked settings page -> About phone -> Phone is running A12
    -checked for latest update to see if A13 is available for OTA update in my region; Nope. "You are up to date!"

    Then I made the big mistake. As I was in the app drawer and just checking the state of the phone, and concerned about the fingerprint scanner and camera app not working, I found the magisk app still in the app drawer. Curious as to magisk's state; I clicked on the app and launched it.

    -Note; my initial boot loop (orignial post below) was caused when I clicked magisk for the first time after rooting phone, let it the magisk app do it's first time setup thing about "installing full version"; As soon as i hit reboot it bootlooped phone. Now that i resolved that bootloop, I figured magisk might be fine now? Was curious to see what happened to magisk hence my temptation to click it and see. Didn't think to remove pincode first.

    -This time, as soon as I clicked magisk, the screen IMMEDIATELY went black, popped up a message saying "restarting", and the phone immediately rebooted.

    Phone is now stuck in bootloop again. And to make matters worse, phone has a pincode, which i didn't have time to remove, so stuff is encrypted.

    Obviously I tried what worked before; Booted to TWRP, this time, TWRP had to ask for my pincode to decrypt device, but accepted my pincode and decrypted User0 successfully.

    -Flashed boot.img for A12 device again, rebooted.

    Still stuck in bootloop. Same symptoms as before; Stuck on 2 rotating white dots around the big red dot; If i wait long enough it reboots and shows 1+ symbo land orange state warning message, after a few reboots it boots to TWRP.

    So now I have a pincode, and same problem as before, aka bootlooping, TWRP is still installed and working, but also probable issue with fingerprint scanner and camera (remnant from last bootloop perhaps?)

    Most likely because magisk is still set to reboot when launched and to modify the boot.img, as thats the step where my first bootloop happened.

    initial bootloop was fixed by flashing boot.img for A12 provided in the comments below
    Supposedly the boot.img I originally used was for A13; Supposedly these boot images are similar enough that they seem to mostly work for each other, until magisk touches it - issues with magisk in my 2nd bootloop post above.

    My Nord 2 is stuck in a bootloop

    I was running a rooted .A11 update just fine, updated to .A12 following a guide, lost root access, so re rooted phone just like i originally did. Got to the point where i used TWRP to flash, that part worked fine, phone booted just fine, launched the magisk app from the app drawer, let magisk install full version, it automatically rebooted, then immediately got stuck in a bootloop.

    Full story for troubleshooting context: (in case you can see where I goofed)
    - I updated from .A11 to .A12 successfully which meant the phone was unrooted; Followed @pankspoo 's guide except using my own OTA after clicking download in my settings app (I'm EU region); (following the comment to find the folder at /data/OTA-package/
    - Verified my phone was fine running the .A12 update properly; opened settings app, checked about phone page, .A12 listed and "newest version installed". Launched the root checker app and confirmed phone was "not rooted" anymore so proceeded to follow @pankspoo root guide again , the same guide I originally used successfully back on .A11 (worked great!)
    - Got to the point in the guide where I flashed and installed TWRP, it worked just fine. Nothing unusual so far.
    - Used TWRP to flash, also worked fine. Still nothing unusual.
    - Used TWRP to make a full backup (ticked all boxes) here, but this backup file seems to be GONE (did not transfer it to PC)
    - Rebooted to system, phone booted just fine, found magisk icon in the app drawer, launched the magisk app and let it do its first time setup thingy, where it "installs full magisk" and so on. I let it do it's thing, eventually it rebooted the phone;
    - Phone now immediately stuck in bootloop. Don't know if Magisk even installed itself properly; Waited out the first bootloop long enough that the phone ended up rebooting multiple times and ended up automatically booting into TWRP so its not a "just wait longer" issue.

    Its a standard bootloop aka stuck on 2 rotating white dots around the larger red dot. If i wait longer enough, phone reboots, initially shows the 1+ icon and the "orange state not trusted boot in 5" message that we're probably all used to seeing. After a few reboots it eventually ends up booting into TWRP.

    Holding Volume up+power forces the phone to reboot, but obviously, still gets stuck in the same bootloop.
    Holding Volume down+power when the phone reboots places the phone into fastboot mode, which lets me connect my computer, open the powershell window, and use the "fastboot reboot recovery" command to get into TWRP instantly.

    TWRP is working fine! I can still flash things and do all the normal stuff in TWRP... But not idea what to do right now.

    Stuff I've already tried: (against my better judgement)
    -Clicked "restore" button on TWRP; I made a TWRP backup whilst on A11, and the device does not seem to want to boot with that A11 boot image and old nandroid restored.
    -renamed file to and used TWRP to flash it; Nothing seems to have happened. Error code: "magisk will not be uninstalled please uninstall manually"
    -Tried reflashing normally.
    -Tried to manually reflash my old file form TWRP backup on the phone (this is most likely my old A11 boot image)

    How do I proceed from here? All help appreciated. Edit: Turns out, i was flashing the A13 boot image from indian devices whereas I have a phone running A12. Bootloop issues were instantly resolved when the A12 boot image was flashed again;

    However, magisk was still set to reboot the phone and patch the boot.img so I ended up having to wipe all data to get rid of magisk and stop magisk from corrupting the boot image.
    A12 Stock EU boot img:

    Fingerprint error fix:

    Twrp doesnt restore the persist partition correctly!

    rename the from the twrp backup to persist.img and flash it in bootloader via "fastboot flash persist persist.img"
    The a12 boot image worked a charm! Thanks guys!