[Solved] Bricked XT910, help needed

Search This thread

doub01

New member
Jul 19, 2012
4
4
0
I recently bought a Motorola Droid Razr on ebay. It's an XT910. It came with a branded T-Mobile ICS 4.0.4, which I suspect has been installed by a previous owner from a leak because I got it before the beginning of the OTA ICS release.

I wanted to install an unbranded retail ICS. I used the Droid Razr Utility by mattlgroff. However it failed during the flashing. I later discovered that the utility is not for the XT910/GSM Razr but for the XT912/CDMA Razr.

So now I have a phone that won't boot. When I start the phone while holding vol+/vol-, I get the following boot menu:

Code:
[SIZE="1"]Boot Mod Selection Menu (0A.6C)
  Vol Up Selects, Vol Down Scrolls

  Available Boot Modes:
    Normal Powerup
    Recovery
    AP Fastboot
    BP SBF Flash
    BP Only
    BP HW Diag & Boot AP
    BP Tools[/SIZE]

If I select "Normal Powerup" or "Recovery" or "BP Tools", I get the "Dual Core" Motorola logo for a while, and then the following screen:

Code:
[SIZE="1"]Invalid Flash Mode (S) (Boot Failure)
0A.6C
To return to normal mode - first press power key to poser down

Device is LOCKED. Status Code: 0

Battery Low
Cannot Program
Connect USB
Data Cable


Invalid CG OTV (CG: webtop): Invalid SP Data
Invalid CG HAB (CG: webtop, status: 0X0056)
Invalid CG OTV (CG: webtop)[/SIZE]

If I select "AP Fastboot", I get the following screen:

Code:
[SIZE="1"]AP Fastboot Flash Mode (S)
0A.6C
To return to normal mode - first press power key to poser down

Device is LOCKED. Status Code: 0

Battery Low
Cannot Program
Connect USB
Data Cable[/SIZE]

If I select "BP SBF Flash", I get the following screen:


Code:
[SIZE="1"]BP SF Flash Mode (S)
0A.6C




Battery Low
Cannot Program
Connect USB
Data Cable[/SIZE]

If I select "BP Only", I get the "Dual Core" Motorola logo forever.

If I select "BP HW Diag & Boot AP", I get the "Dual Core" Motorola logo for a while, and then the following screen:

Code:
[SIZE="1"]AP SBF Flash Mode (S) (Boot Failure)
0A.6C
To return to normal mode - first press power key to poser down

Device is LOCKED. Status Code: 0

Battery Low
Cannot Program
Connect USB
Data Cable


Invalid CG OTV (CG: webtop): Invalid SP Data
Invalid CG HAB (CG: webtop, status: 0X0056)
Invalid CG OTV (CG: webtop)[/SIZE]

I made a factory cable. When I plug it, all these screen keep being the same, except the middle four lines, which read:

Code:
[SIZE="1"]Battery OK
OK to Program
Transfer Mode:
USB Connected[/SIZE]

I tried using RSD Lite, when the phone in in "AP Fastboot" mode. I tried running it with several images that I found on sbf.droid-developers.org umts_spyder list.php. Here are the result:

  • SPDREM_U_01.6.5.1-73_SPU-11-M1-2_SIGNEuropeAustraliaEMEA_USASPDRRTGB_HWp2b_Service1FF_fastboot.xml.zip
    • Failed flashing process. 1/11 flash cdt.bin "cdt.bin_signed" -> Phone returned FAIL.
  • SPDREM_U_01.6.5.1-73_SPU-11-M1-2-DE_SIGNEuropeAustraliaEMEA_USASPDRTMDE_HWp2b_Service1FF_fastboot.xml.zip
    • Failed flashing process. 1/11 flash cdt.bin "cdt.bin_signed" -> Phone returned FAIL.
  • SPDREM_U_01.6.5.1-167_SPU-15-M2-1-DE_1C.91P_0A.6C_TMDE_CFC_HWp2b_SIGNED.xml.zip
    • Failed flashing process. 6/20 flash cdt.bin "cdt.bin_signed" -> Phone returned FAIL.
  • SPDREM_U_01.6.5.1-167_SPU-15-M2-3_SIGNEuropeAustraliaEMEA_USASPDRRTGB_HWp2b_Service1FF_fastboot.xml.zip
    • Failed flashing process. 1/11 flash cdt.bin "cdt.bin_signed" -> Phone returned FAIL.
  • SPDREM_U_01.6.7.2-180_SPU-19-TA-11.2_SIGNEuropeAustraliaEMEA_USASPDRICSRTGB_HWp2b_Service1FF_fastboot.xml.zip
    • The 10 steps run properly, the phone reboots, I get a "Dual Core" Motorola logo for a while, and then the error screen below


Code:
[SIZE="1"]Invalid Flash Mode (S) (Boot Failure)
0A.6C
To return to normal mode - first press power key to poser down

Device is LOCKED. Status Code: 0

Battery Low
Cannot Program
Connect USB
Data Cable


Invalid CG OTV (CG: cdrom): Invalid SP Data
Invalid CG OTV (CG: system): Invalid SP Data
Invalid CG OTV (CG: webtop): Invalid SP Data
Invalid CG HAB (CG: webtop, status: 0X0056)
Invalid CG OTV (CG: webtop)[/SIZE]

Can anyone tell me what fastboot file I should download for my phone? Is there any other method to unbrick it?
 
Last edited:

BakaPhoenix

Senior Member
Jul 16, 2010
617
110
73
Roma
Flash only the webtop from the gb sbf (you can do it using rds lite and deleting all the other lines that arent the one with webtop, or using eternity project fastboot method and modifing the .bat file for flash only the webtop)
and then flash the ics sbf that you can find in the dev forum (the last one you have posted in your post)
 
  • Like
Reactions: doub01

doub01

New member
Jul 19, 2012
4
4
0
Flash only the webtop from the gb sbf (you can do it using rds lite and deleting all the other lines that arent the one with webtop, or using eternity project fastboot method and modifing the .bat file for flash only the webtop)
and then flash the ics sbf that you can find in the dev forum (the last one you have posted in your post)

Your message was a bit cryptic for the newbie that I am, but it put me on the right track.

I thought the fastboot .xml.zip files were monolithic things, but I had a look at the extracted content, and at the XML file. It appears the "steps" displayed by RSD Lite are in fact described in that XML, and all that application is doing is taking some binaries and writing them to corresponding (named) partitions on the phone (there is a fastboot_image.sh script in the latest ROM I mentionned above that helped a lot confirming that).

And it appears that the 1.6.7.2-180 fastboot file contains no image for the webtop partition, contrary to earlier ROMs. So what happens (I think) is that I corrupted that partition (and maybe others), but successfully flashing the latest fastboot ROM wouldn't fix it because there is no new webtop image in these ROM.

So I did what you suggested. I manually flashed the various partitions (using moto-fastboot.exe), using the webtop image from 1.6.5.1-73, and the rest from 1.6.7.2-180.

I still don't understand why flashing the whole 1.6.5.1-73 from RSD Lite failed. My guess is that the signing keys have been updated, and the phone no longer accepts the signed binaries from 1.6.5.1-73. However it still accepted the old webtop signed image (when I skipped the other ones manually), so maybe there is a different signing key per partition.
 

BakaPhoenix

Senior Member
Jul 16, 2010
617
110
73
Roma
Sorry if i was hard to undestand ^^''
But i was to lazy to write a good guide o.o
So in the end do you fixed?

P.s. The fact that it doesn't accepted the whole old gb is because the ics update signed some partiton, so the older sbf couln't be used since they didn't have the sign, the webtop(and some others) partition can be flashed becase its partition is not signed with the update
 
Last edited:

doub01

New member
Jul 19, 2012
4
4
0
So in the end do you fixed?

Yes, sorry if I wasn't clear. I now have a clean unrooted unbranded retail ICS 4.0.4 :D And a better knowledge of the platform, so I can start customizing it a bit in the future (I especially don't like the booting logo, although I think you rarely have to reboot the system).

P.s. The fact that it doesn't accepted the whole old gb is because the ics update signed some partiton, so the older sbf couln't be used since they didn't have the sign, the webtop(and some others) partition can be flashed becase its partition is not signed with the update

Do you know where these signatures are stored, or if it's possible to update them? Or maybe can you point me at some documentation explaining all that in details?
 

BakaPhoenix

Senior Member
Jul 16, 2010
617
110
73
Roma
Sorry but i don't really know about them :D
BTW to change the boot animation is really easy, you need root and an app like es file manager. In the folder /system/media, there is a zip file called bootanimation.
Downlaod the bootanimation that you like and replace it with the stock one and you are done
 

hammily

Member
Jun 28, 2012
13
0
0
Your message was a bit cryptic for the newbie that I am, but it put me on the right track.

I thought the fastboot .xml.zip files were monolithic things, but I had a look at the extracted content, and at the XML file. It appears the "steps" displayed by RSD Lite are in fact described in that XML, and all that application is doing is taking some binaries and writing them to corresponding (named) partitions on the phone (there is a fastboot_image.sh script in the latest ROM I mentionned above that helped a lot confirming that).

And it appears that the 1.6.7.2-180 fastboot file contains no image for the webtop partition, contrary to earlier ROMs. So what happens (I think) is that I corrupted that partition (and maybe others), but successfully flashing the latest fastboot ROM wouldn't fix it because there is no new webtop image in these ROM.

So I did what you suggested. I manually flashed the various partitions (using moto-fastboot.exe), using the webtop image from 1.6.5.1-73, and the rest from 1.6.7.2-180.

I still don't understand why flashing the whole 1.6.5.1-73 from RSD Lite failed. My guess is that the signing keys have been updated, and the phone no longer accepts the signed binaries from 1.6.5.1-73. However it still accepted the old webtop signed image (when I skipped the other ones manually), so maybe there is a different signing key per partition./QUOTE]

I am rooted really bad as well. Could you describe in detail how you manually flashed. I don't know how to do that.
 

Ph3arr3t

Member
Apr 17, 2012
32
0
0
Hey all; I think I just Bricked mt XT910.
I used App2SD to set & move Contract Killer from one sdcard => sdcard-ext. phone booted without incident except everytime I had to tell the game to load from sd not delete & reinstall... no big deal.
then I read that App2ROM was supposed to make the game load faster if I moved it with this app... since then I can't find the game with App2SD, App2ROM, easy uninstaller, App Quarantine, auto run manager, nothing.. and I kept getting the popup that the game had crashed suppenly before I even get to "desktop".
So I used RazrBootstrap to get into recovery mode to try and delete the CK popup.
It succeeded in restoring the phone to stock; BUT I still have the CK popup. and I think something Identified it as a system app now.
how do I delete / move the CK loader so I can get uninterupted access to the phone to correct the CK issue without the popups.
and as a footnote my system is ubuntu 12.04 can't seem to get the pc to see it either to help with the reloading, as I have all my apps on my pc.
 

pedrotorresfilho

Senior Member
Jan 4, 2012
1,596
1,098
0
decantodepoetas.blogspot.com
Hey all; I think I just Bricked mt XT910.
I used App2SD to set & move Contract Killer from one sdcard => sdcard-ext. phone booted without incident except everytime I had to tell the game to load from sd not delete & reinstall... no big deal.
then I read that App2ROM was supposed to make the game load faster if I moved it with this app... since then I can't find the game with App2SD, App2ROM, easy uninstaller, App Quarantine, auto run manager, nothing.. and I kept getting the popup that the game had crashed suppenly before I even get to "desktop".
So I used RazrBootstrap to get into recovery mode to try and delete the CK popup.
It succeeded in restoring the phone to stock; BUT I still have the CK popup. and I think something Identified it as a system app now.
how do I delete / move the CK loader so I can get uninterupted access to the phone to correct the CK issue without the popups.
and as a footnote my system is ubuntu 12.04 can't seem to get the pc to see it either to help with the reloading, as I have all my apps on my pc.

fastboot erase userdata to delete ur data. If this do not fix you'll have to rsd lite flash the system over.

Cheers

Sent from my XT910 using xda premium
 

doub01

New member
Jul 19, 2012
4
4
0
well I tried looking around for the fastboot files, call me a n00b, I couldn't get them. can you provide links?
might be here: sbf.droid-developers.org

Click the "Motorola Razr (XT910)" link, and then download the one numbered 1.6.7.2-180 (which is the latest one at the moment).
 
  • Like
Reactions: Ph3arr3t

erkmatz

New member
Sep 28, 2010
1
0
0
Yes, sorry if I wasn't clear. I now have a clean unrooted unbranded retail ICS 4.0.4 :D And a better knowledge of the platform, so I can start customizing it a bit in the future (I especially don't like the booting logo, although I think you rarely have to reboot the system).


Hi. I'm Erick, I have the same problem. I've tried many Fastboots and always fail. Now my battery is dead. So I'm on my way to buy a factory cable, the 1st step to get back to work, but, once I´ll have. Could you share us, how did you get it? Step by step if you have the time, please. I has been two days locked into my room looking for the solution. :eek:

Thanks.
 

mikevipsr

Senior Member
Mar 27, 2009
87
42
48
Shreveport, LA
The one i use is VRZ_XT912_6.7.2-180_DHD-16_M4-31_1FF.xml
and havent had a problem in the last three times. to fix that low battery issue i posted the information on another forum. I'm uploading a video on youtube right now.
 

Attachments

  • 2012-08-02_00-45-39_598.jpg
    2012-08-02_00-45-39_598.jpg
    255.3 KB · Views: 814
  • 2012-08-02_00-45-19_715.jpg
    2012-08-02_00-45-19_715.jpg
    234.6 KB · Views: 684
  • 2012-08-02_00-52-35_969.jpg
    2012-08-02_00-52-35_969.jpg
    261.2 KB · Views: 672
  • Like
Reactions: Cristiandando

mikevipsr

Senior Member
Mar 27, 2009
87
42
48
Shreveport, LA
How to fix a Motorola razr stuck in ap fastboot with a low battery

Alternative Low battery in Ap fastboot fix

If this fix doesn't work for you then I have a known working solution. I used a 600ma charger cut the end off and then cut the wire coating back exposing 3/16 of wire. With charger unplugged I attached the red to the + and the black wire to the - terminal being extremely careful not to touch anything else in there causing it to arc and possibly causing damage. I recommend that you download the ifixit app in the market to a tablet or use their website so you can get the help on the removal of the back plate without breaking or cracking it. once removed you can use the torx screwdriver to remove the negative screw. It has a washer too I just placed the wire under there and re-tightened it and then done the same to the positive side.

Now that you have done this you should very carefully flip it over taking extreme care as to not have the wire break or fall out. I placed mine over the edge of the table so I could inspect it before plugging it up. If all is good plug it up the hit vol-+ and power choose fastboot or you can just hit power cause it'll go straight there cause it's bricked and in bootfailure. The RAZR will now say BATTERY OK. Run RSD Lite and install your

VRZ_XT912_6.7.2-180_DHD-16_M4-31_1FF.xml

After it fully installs turn device off and carefully remove everything and snap the back cover on and then power back on. Worked twice for me since it keeps soft bricking every time I use touch clockwork recovery to restore a back up. I NEED HELP WITH Clockworkmod...

O Yeah, If you find this helpful give me thanks my 1 is lonely.. lol
 

Attachments

  • 2012-08-02_00-45-39_598.jpg
    2012-08-02_00-45-39_598.jpg
    255.3 KB · Views: 418
  • 2012-08-02_00-45-31_846.jpg
    2012-08-02_00-45-31_846.jpg
    248.2 KB · Views: 362
  • 2012-08-02_00-45-19_715.jpg
    2012-08-02_00-45-19_715.jpg
    234.6 KB · Views: 334
  • 2012-08-02_00-52-35_969.jpg
    2012-08-02_00-52-35_969.jpg
    261.2 KB · Views: 272
Last edited:

danygarss

Senior Member
Mar 4, 2011
53
16
0
Madrid
Alternative Low battery in Ap fastboot fix

If this fix doesn't work for you then I have a known working solution. I used a 600ma charger cut the end off and then cut the wire coating back exposing 3/16 of wire. With charger unplugged I attached the red to the + and the black wire to the - terminal being extremely careful not to touch anything else in there causing it to arc and possibly causing damage. I recommend that you download the ifixit app in the market to a tablet or use their website so you can get the help on the removal of the back plate without breaking or cracking it. once removed you can use the torx screwdriver to remove the negative screw. It has a washer too I just placed the wire under there and re-tightened it and then done the same to the positive side.

Now that you have done this you should very carefully flip it over taking extreme care as to not have the wire break or fall out. I placed mine over the edge of the table so I could inspect it before plugging it up. If all is good plug it up the hit vol-+ and power choose fastboot or you can just hit power cause it'll go straight there cause it's bricked and in bootfailure. The RAZR will now say BATTERY OK. Run RSD Lite and install your

VRZ_XT912_6.7.2-180_DHD-16_M4-31_1FF.xml

After it fully installs turn device off and carefully remove everything and snap the back cover on and then power back on. Worked twice for me since it keeps soft bricking every time I use touch clockwork recovery to restore a back up. I NEED HELP WITH Clockworkmod...

O Yeah, If you find this helpful give me thanks my 1 is lonely.. lol


MAN YOU JUST HAVE SAVED ME!!! I thought my phone was dead, because it failed while installing a ROM and it could not charge or boot up. I used an USB charger (850 mA) from other mobile, and it worked!!!!! man you're amazing, huge thanks!!
 

williemeiser

Senior Member
Mar 15, 2011
274
25
28
I have exactly the same problem as the original OP. Can anyone please guide me how to fix this, in more easy-to-understand words? Coz im really noob in Motorola devices. Please..

But Except I got :
"Invalid CG OTV (CG:system):Invalid SP data
Invalid CG version (CG: system)
Invalid CG OTV (CG:system)
 
Last edited:

duig

Member
Nov 29, 2012
18
0
0
help please

Hello....just bought a Motorola xt910 on eBay....but it had a rom Korean that has only English and Korean as languages so y try to put a European retail rom.....but it stop flashing with error CbT.bin....now the phone is in fastboot mode.. .i still have battery ....can any one please post a rom that dosent get this error ? Thanks in advance....
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    How to fix a Motorola razr stuck in ap fastboot with a low battery

    Alternative Low battery in Ap fastboot fix

    If this fix doesn't work for you then I have a known working solution. I used a 600ma charger cut the end off and then cut the wire coating back exposing 3/16 of wire. With charger unplugged I attached the red to the + and the black wire to the - terminal being extremely careful not to touch anything else in there causing it to arc and possibly causing damage. I recommend that you download the ifixit app in the market to a tablet or use their website so you can get the help on the removal of the back plate without breaking or cracking it. once removed you can use the torx screwdriver to remove the negative screw. It has a washer too I just placed the wire under there and re-tightened it and then done the same to the positive side.

    Now that you have done this you should very carefully flip it over taking extreme care as to not have the wire break or fall out. I placed mine over the edge of the table so I could inspect it before plugging it up. If all is good plug it up the hit vol-+ and power choose fastboot or you can just hit power cause it'll go straight there cause it's bricked and in bootfailure. The RAZR will now say BATTERY OK. Run RSD Lite and install your

    VRZ_XT912_6.7.2-180_DHD-16_M4-31_1FF.xml

    After it fully installs turn device off and carefully remove everything and snap the back cover on and then power back on. Worked twice for me since it keeps soft bricking every time I use touch clockwork recovery to restore a back up. I NEED HELP WITH Clockworkmod...

    O Yeah, If you find this helpful give me thanks my 1 is lonely.. lol
    3
    I recently bought a Motorola Droid Razr on ebay. It's an XT910. It came with a branded T-Mobile ICS 4.0.4, which I suspect has been installed by a previous owner from a leak because I got it before the beginning of the OTA ICS release.

    I wanted to install an unbranded retail ICS. I used the Droid Razr Utility by mattlgroff. However it failed during the flashing. I later discovered that the utility is not for the XT910/GSM Razr but for the XT912/CDMA Razr.

    So now I have a phone that won't boot. When I start the phone while holding vol+/vol-, I get the following boot menu:

    Code:
    [SIZE="1"]Boot Mod Selection Menu (0A.6C)
      Vol Up Selects, Vol Down Scrolls
    
      Available Boot Modes:
        Normal Powerup
        Recovery
        AP Fastboot
        BP SBF Flash
        BP Only
        BP HW Diag & Boot AP
        BP Tools[/SIZE]

    If I select "Normal Powerup" or "Recovery" or "BP Tools", I get the "Dual Core" Motorola logo for a while, and then the following screen:

    Code:
    [SIZE="1"]Invalid Flash Mode (S) (Boot Failure)
    0A.6C
    To return to normal mode - first press power key to poser down
    
    Device is LOCKED. Status Code: 0
    
    Battery Low
    Cannot Program
    Connect USB
    Data Cable
    
    
    Invalid CG OTV (CG: webtop): Invalid SP Data
    Invalid CG HAB (CG: webtop, status: 0X0056)
    Invalid CG OTV (CG: webtop)[/SIZE]

    If I select "AP Fastboot", I get the following screen:

    Code:
    [SIZE="1"]AP Fastboot Flash Mode (S)
    0A.6C
    To return to normal mode - first press power key to poser down
    
    Device is LOCKED. Status Code: 0
    
    Battery Low
    Cannot Program
    Connect USB
    Data Cable[/SIZE]

    If I select "BP SBF Flash", I get the following screen:


    Code:
    [SIZE="1"]BP SF Flash Mode (S)
    0A.6C
    
    
    
    
    Battery Low
    Cannot Program
    Connect USB
    Data Cable[/SIZE]

    If I select "BP Only", I get the "Dual Core" Motorola logo forever.

    If I select "BP HW Diag & Boot AP", I get the "Dual Core" Motorola logo for a while, and then the following screen:

    Code:
    [SIZE="1"]AP SBF Flash Mode (S) (Boot Failure)
    0A.6C
    To return to normal mode - first press power key to poser down
    
    Device is LOCKED. Status Code: 0
    
    Battery Low
    Cannot Program
    Connect USB
    Data Cable
    
    
    Invalid CG OTV (CG: webtop): Invalid SP Data
    Invalid CG HAB (CG: webtop, status: 0X0056)
    Invalid CG OTV (CG: webtop)[/SIZE]

    I made a factory cable. When I plug it, all these screen keep being the same, except the middle four lines, which read:

    Code:
    [SIZE="1"]Battery OK
    OK to Program
    Transfer Mode:
    USB Connected[/SIZE]

    I tried using RSD Lite, when the phone in in "AP Fastboot" mode. I tried running it with several images that I found on sbf.droid-developers.org umts_spyder list.php. Here are the result:

    • SPDREM_U_01.6.5.1-73_SPU-11-M1-2_SIGNEuropeAustraliaEMEA_USASPDRRTGB_HWp2b_Service1FF_fastboot.xml.zip
      • Failed flashing process. 1/11 flash cdt.bin "cdt.bin_signed" -> Phone returned FAIL.
    • SPDREM_U_01.6.5.1-73_SPU-11-M1-2-DE_SIGNEuropeAustraliaEMEA_USASPDRTMDE_HWp2b_Service1FF_fastboot.xml.zip
      • Failed flashing process. 1/11 flash cdt.bin "cdt.bin_signed" -> Phone returned FAIL.
    • SPDREM_U_01.6.5.1-167_SPU-15-M2-1-DE_1C.91P_0A.6C_TMDE_CFC_HWp2b_SIGNED.xml.zip
      • Failed flashing process. 6/20 flash cdt.bin "cdt.bin_signed" -> Phone returned FAIL.
    • SPDREM_U_01.6.5.1-167_SPU-15-M2-3_SIGNEuropeAustraliaEMEA_USASPDRRTGB_HWp2b_Service1FF_fastboot.xml.zip
      • Failed flashing process. 1/11 flash cdt.bin "cdt.bin_signed" -> Phone returned FAIL.
    • SPDREM_U_01.6.7.2-180_SPU-19-TA-11.2_SIGNEuropeAustraliaEMEA_USASPDRICSRTGB_HWp2b_Service1FF_fastboot.xml.zip
      • The 10 steps run properly, the phone reboots, I get a "Dual Core" Motorola logo for a while, and then the error screen below


    Code:
    [SIZE="1"]Invalid Flash Mode (S) (Boot Failure)
    0A.6C
    To return to normal mode - first press power key to poser down
    
    Device is LOCKED. Status Code: 0
    
    Battery Low
    Cannot Program
    Connect USB
    Data Cable
    
    
    Invalid CG OTV (CG: cdrom): Invalid SP Data
    Invalid CG OTV (CG: system): Invalid SP Data
    Invalid CG OTV (CG: webtop): Invalid SP Data
    Invalid CG HAB (CG: webtop, status: 0X0056)
    Invalid CG OTV (CG: webtop)[/SIZE]

    Can anyone tell me what fastboot file I should download for my phone? Is there any other method to unbrick it?
    1
    Flash only the webtop from the gb sbf (you can do it using rds lite and deleting all the other lines that arent the one with webtop, or using eternity project fastboot method and modifing the .bat file for flash only the webtop)
    and then flash the ics sbf that you can find in the dev forum (the last one you have posted in your post)
    1
    well I tried looking around for the fastboot files, call me a n00b, I couldn't get them. can you provide links?
    might be here: sbf.droid-developers.org

    Click the "Motorola Razr (XT910)" link, and then download the one numbered 1.6.7.2-180 (which is the latest one at the moment).
    1
    The one i use is VRZ_XT912_6.7.2-180_DHD-16_M4-31_1FF.xml
    and havent had a problem in the last three times. to fix that low battery issue i posted the information on another forum. I'm uploading a video on youtube right now.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone