• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Solved] E: Can't mount /dev/block/stl11 - Issues with Recovery

Search This thread

bdemartino

Senior Member
Jan 18, 2011
873
191
Midwest
Since I personally have dealt with this issue quite a few times recently in my testing and flashing of new ROM's, I figured I'd post it up in case anyone else also had the issue.

Basically this error occurs when your phone has lagfix enabled (file system converted to EXT4) and something (possibly a flash, restore, or factory reset) brings files into the system in the stock RFS format. I.E. If you were to use odin to restore your phone to stock before converting things back to RFS.

Here is a screenshot of what this may look like if you manage to get into CWM, keep in mind sometimes you will actually revert to the stock(blue) recovery but you will see these same errors there if you're having this issue. If you bugger it up as bad as I did, you may not even get passed either recovery - you won't see the samsung logo at all as it'll go right to recovery.


NOTE: Disregard the first two errors, those errors are a result of using an older version of CWM and are normal for that version - you must have the "E: Can't mount..." errors for this to be the issue you're experiencing.


ouch.png


Here is the easiest fix. [This is for the Mesmerize.]
1. If you don't have a copy; download the full stock 2.2 odin package (NOT the one with custom recovery, you will need to flash that one AFTER flashing the full stock version as it won't fix the issue by itself) and of course, odin if you don't have it.
2. Load up the .pit in the .pit slot and the .tar.md5 in the PDA slot and get your phone into download mode. (I usually pull the battery, plug it in and hold volume down, there are other methods) Also check the "repartition" box.
3. Once odin see's your phone (look for a yellow COM: box) hit start and it will flash the stock files to your phone.
4. Put the battery back in and boot the phone up, we need to get the file structure converted back to RFS and you won't be able to do so through normal means.
5. Create an empty file (In windows just erase the extension) and name it "disable lagfix" no extension
6. Download QT ADB from here (or just use ADB), and move the file from your PC to the Voodoo folder on your SD card. Reboot your phone, you should hear the lagfix being disabled (robot chick voice)
7. After that is complete, all your stuff will be converted properly - but if you don't flash a clean full OS again (like you did in the first few steps) you will revert to these errors once lagfix is re-enabled. So, repeat steps 1-4, and don't forget if you want the custom recovery you can odin flash that package AFTER you use the full stock package, this is just to ensure all your files are clean and installed properly.
8. You now have a clean phone with everything in the proper format and working properly, so you know what to do from here ;).
 
Last edited:

notsurewhatidid

New member
May 22, 2011
1
0
help please

i flubbed...flashed before i read with odin...my phone is giving me the cant mount and i'm not sure i'm doing your directions right...tried several times and nothing...the disable lagfix and adb part has me comfused
 

bdemartino

Senior Member
Jan 18, 2011
873
191
Midwest
I think when I wrote this I missed a step, right before step #5 you may need to flash a voodoo kernel so that lagfix can get disabled through the instructions in step 5 and on.
 

droidzach

Senior Member
Dec 23, 2010
177
21
Monroe, WI
When I had this happen to me I just odined the stock 2.1 files and checked the repartition box. Fixed me right up. Going to stock 2.2 didn't fix my problem tho.My dumbass tried to odin ec10 stock with root and recovery from cm7 with ext4 (voodoo) enabled. I wanted to reset my phone you know...haha yeah thought I done ****ed myself

Sent from my SCH-I500 using XDA Premium App
 
  • Like
Reactions: m92680

bdemartino

Senior Member
Jan 18, 2011
873
191
Midwest
The custom root and recovery one didnt work for me either, used the other. I've never gone to 2.1 but whatever works :)

Sent from my SCH-I500 using XDA Premium App
 

King Mustard

Senior Member
Nov 14, 2010
537
25
Samsung Galaxy Tab S5e
When I had this happen to me I just odined the stock 2.1 files and checked the repartition box. Fixed me right up. Going to stock 2.2 didn't fix my problem tho.My dumbass tried to odin ec10 stock with root and recovery from cm7 with ext4 (voodoo) enabled. I wanted to reset my phone you know...haha yeah thought I done ****ed myself

Sent from my SCH-I500 using XDA Premium App
Oooh, flashing 2.1 fixed all my RFS/EXT4 issues! Thank you! :)
 

PimpFinger

Member
Mar 18, 2009
32
2
Wiggins, MS
First of all let me thank you for sharing this.

I've got the same error that you listed minus the "missing bitmap" part.

My trouble started when trying to Odin back to EB11 froyo from phidelt82. (I had a copy saved) I believe I'm having this issue because I used a different version of odin than the one I usually use, and the Re-Partion box was checked. I didn't notice it was checked until it started.

Since then I haven't been able to get past the recovery.

I can however flash recoveries, kernels, and most roms,(via odin or zip) but I never even see the samsung logo on reboot. It just goes straight to the recovery.

I've created the file disable-lagfix and dropped it in voodoo folder.

At this point I can enable/disable voodoo all day long, but after disabling and flashing eb11 or ee25 stock immediately after I still get the Can't mount errors.

(they look a little different in stock recovery, but I'm pretty sure it's the same error)

I've done this several times both with Re-Partitiion checked and unchecked to no avail.

Right now the error I'm getting is "E:Can't mount /cache/recovery/command" log, log, last_log, last_log.

I've been working on this since Sunday and I'm nearly at my wits end. :confused:

If anyone out there can tell me if I'm just missing something or if there's another procedure. I would very greatly appreciate it.
 

bdemartino

Senior Member
Jan 18, 2011
873
191
Midwest
First of all let me thank you for sharing this.

I've got the same error that you listed minus the "missing bitmap" part.

My trouble started when trying to Odin back to EB11 froyo from phidelt82. (I had a copy saved) I believe I'm having this issue because I used a different version of odin than the one I usually use, and the Re-Partion box was checked. I didn't notice it was checked until it started.

Since then I haven't been able to get past the recovery.

I can however flash recoveries, kernels, and most roms,(via odin or zip) but I never even see the samsung logo on reboot. It just goes straight to the recovery.

I've created the file disable-lagfix and dropped it in voodoo folder.

At this point I can enable/disable voodoo all day long, but after disabling and flashing eb11 or ee25 stock immediately after I still get the Can't mount errors.

(they look a little different in stock recovery, but I'm pretty sure it's the same error)

I've done this several times both with Re-Partitiion checked and unchecked to no avail.

Right now the error I'm getting is "E:Can't mount /cache/recovery/command" log, log, last_log, last_log.

I've been working on this since Sunday and I'm nearly at my wits end. :confused:

If anyone out there can tell me if I'm just missing something or if there's another procedure. I would very greatly appreciate it.

Ok, the can't mount "log" and such errors might be a little different - were you on or are you on an MTD rom? (miui or CM7) because those errors will show if you're using the 3 button method to get into recovery while one either of those two roms. If you can, jump on IRC and get some help, we're around and more than willing to walk you through.

http://webchat.freenode.net/
channel: #samsung-mesmerize
 
Last edited:
  • Like
Reactions: PimpFinger

PimpFinger

Member
Mar 18, 2009
32
2
Wiggins, MS
Just wanted to say I got my problem fixed following the advice of bdemartino to flash EE23 via odin.

The other builds I was trying to flash were not full builds.

Thanks again! I was ecstatic after my phone finally rebooted!:D
 
Jun 27, 2010
23
1
Is it safe to say that anyone who has odined back to stock has lost all data?

I think there has to be a way to push an rom that uses the lagfix and won't go into an endless boot cycle.

Anyone else?
 

m92680

Member
Feb 1, 2011
7
0
When I had this happen to me I just odined the stock 2.1 files and checked the repartition box. Fixed me right up. Going to stock 2.2 didn't fix my problem tho.My dumbass tried to odin ec10 stock with root and recovery from cm7 with ext4 (voodoo) enabled. I wanted to reset my phone you know...haha yeah thought I done ****ed myself

Sent from my SCH-I500 using XDA Premium App
going back to 2.1 was the only thing that worked for me too
 

dandan86

New member
Jul 10, 2011
2
1
Hattiesburg
I'm trying to make a clean reinstall to come back to as well
I've been running cm7. For a while now and tried to do something and caused the e can't Mont problem
I'm on a showcase from cellsouth
I can still use this adb reformatted fix right
If not I read that I can flash a full build pit and tar check repartition boot then Odin a cwm and flash an rfs reformatter zip to fix my problems
Is that true too
 
Last edited:
  • Like
Reactions: ted3ma1

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Since I personally have dealt with this issue quite a few times recently in my testing and flashing of new ROM's, I figured I'd post it up in case anyone else also had the issue.

    Basically this error occurs when your phone has lagfix enabled (file system converted to EXT4) and something (possibly a flash, restore, or factory reset) brings files into the system in the stock RFS format. I.E. If you were to use odin to restore your phone to stock before converting things back to RFS.

    Here is a screenshot of what this may look like if you manage to get into CWM, keep in mind sometimes you will actually revert to the stock(blue) recovery but you will see these same errors there if you're having this issue. If you bugger it up as bad as I did, you may not even get passed either recovery - you won't see the samsung logo at all as it'll go right to recovery.


    NOTE: Disregard the first two errors, those errors are a result of using an older version of CWM and are normal for that version - you must have the "E: Can't mount..." errors for this to be the issue you're experiencing.


    ouch.png


    Here is the easiest fix. [This is for the Mesmerize.]
    1. If you don't have a copy; download the full stock 2.2 odin package (NOT the one with custom recovery, you will need to flash that one AFTER flashing the full stock version as it won't fix the issue by itself) and of course, odin if you don't have it.
    2. Load up the .pit in the .pit slot and the .tar.md5 in the PDA slot and get your phone into download mode. (I usually pull the battery, plug it in and hold volume down, there are other methods) Also check the "repartition" box.
    3. Once odin see's your phone (look for a yellow COM: box) hit start and it will flash the stock files to your phone.
    4. Put the battery back in and boot the phone up, we need to get the file structure converted back to RFS and you won't be able to do so through normal means.
    5. Create an empty file (In windows just erase the extension) and name it "disable lagfix" no extension
    6. Download QT ADB from here (or just use ADB), and move the file from your PC to the Voodoo folder on your SD card. Reboot your phone, you should hear the lagfix being disabled (robot chick voice)
    7. After that is complete, all your stuff will be converted properly - but if you don't flash a clean full OS again (like you did in the first few steps) you will revert to these errors once lagfix is re-enabled. So, repeat steps 1-4, and don't forget if you want the custom recovery you can odin flash that package AFTER you use the full stock package, this is just to ensure all your files are clean and installed properly.
    8. You now have a clean phone with everything in the proper format and working properly, so you know what to do from here ;).
    1
    When I had this happen to me I just odined the stock 2.1 files and checked the repartition box. Fixed me right up. Going to stock 2.2 didn't fix my problem tho.My dumbass tried to odin ec10 stock with root and recovery from cm7 with ext4 (voodoo) enabled. I wanted to reset my phone you know...haha yeah thought I done ****ed myself

    Sent from my SCH-I500 using XDA Premium App
    1
    First of all let me thank you for sharing this.

    I've got the same error that you listed minus the "missing bitmap" part.

    My trouble started when trying to Odin back to EB11 froyo from phidelt82. (I had a copy saved) I believe I'm having this issue because I used a different version of odin than the one I usually use, and the Re-Partion box was checked. I didn't notice it was checked until it started.

    Since then I haven't been able to get past the recovery.

    I can however flash recoveries, kernels, and most roms,(via odin or zip) but I never even see the samsung logo on reboot. It just goes straight to the recovery.

    I've created the file disable-lagfix and dropped it in voodoo folder.

    At this point I can enable/disable voodoo all day long, but after disabling and flashing eb11 or ee25 stock immediately after I still get the Can't mount errors.

    (they look a little different in stock recovery, but I'm pretty sure it's the same error)

    I've done this several times both with Re-Partitiion checked and unchecked to no avail.

    Right now the error I'm getting is "E:Can't mount /cache/recovery/command" log, log, last_log, last_log.

    I've been working on this since Sunday and I'm nearly at my wits end. :confused:

    If anyone out there can tell me if I'm just missing something or if there's another procedure. I would very greatly appreciate it.

    Ok, the can't mount "log" and such errors might be a little different - were you on or are you on an MTD rom? (miui or CM7) because those errors will show if you're using the 3 button method to get into recovery while one either of those two roms. If you can, jump on IRC and get some help, we're around and more than willing to walk you through.

    http://webchat.freenode.net/
    channel: #samsung-mesmerize
    1
    I'm trying to make a clean reinstall to come back to as well
    I've been running cm7. For a while now and tried to do something and caused the e can't Mont problem
    I'm on a showcase from cellsouth
    I can still use this adb reformatted fix right
    If not I read that I can flash a full build pit and tar check repartition boot then Odin a cwm and flash an rfs reformatter zip to fix my problems
    Is that true too