*SOLVED* Galaxy S10 rotate sensor issues after update to One UI 3.0

Search This thread

fado5ster

Senior Member
Feb 27, 2013
66
5
*SOLVED*

Hi all,

Have my Galaxy S10 SM-G9730 Dual Sim (unrooted) for about 18months now and has never skipped a beat.... until the new One UI 3.0 update that I got a few days ago.

After a restart everything works fine then after 15min-2hrs I will lose auto rotate, screen brightness is also less responsive (proximity sensor seems to be ok). Toggling auto rotate/adaptive brightness on/off does nothing.
Same issue across all apps (Youtube, Camera, Messaging etc.)

Going to the *#0*# - SENSOR menu shows me that:
Accelerometer Sensor is responsive (x, y, z axis all change to reflect movement) but the "IMAGE TEST" doesn't rotate the image of the dog. Should it?
Gyroscope Sensor doesn't move at all, is it supposed to? "GYRO SELFTEST" shows a PASS.

I downloaded the app "Sensor Test" and most of the sensors give me the error:
"This sensor doesn't report any readings, seems you have error with sensor service in device firmware"

I have tried the following:
- Toggle auto rotate on/off.
- Restart phone (using power button - restart & using power & Vol down combo)
- Cleared cache from Bootloader menu.
- Settings - Apps - Reset app preferences.
- Factory reset (using both settings - Factory reset & using bootloader factory reset)

I have a feeling it is an app that isn't updated to run on One UI 3.0 but I have no way of finding the guilty app.

Called Samsung who were no help (try restart, try factory reset, send it to us but we will charge you as Samsung don't have international warranty :rolleyes: , even though yes we agree that it was our update that probably caused it)

Seemed to be good for about 10 hours after the factory reset but came came again,
Anyone come across this and found a way out?

*edit* just checked after restart and Gyroscope Sensor shows values after restart (while auto rotate is working), This leads me to believe it is 100% the gyroscope at first which in time leads to the accelerometer also not working.

*edit x2* well I've just restarted my phone then went through every single app 1 by 1 (downloaded and bloatware) and checking for rotation after each app launch, that is: launch app, test rotation, close app, test rotation and do that 172 times!! :sleep: I task killed maybe 5 times during the process..
after opening every app I still have auto rotation which leads me to believe its some system background process and not a 3rd party app issue. Damn..
Is there any way for me to monitor these? or monitor sensors stopping functioning?

*SOLVED* See post #6 below
 
Last edited:

dspss

New member
Feb 19, 2021
2
0
I have same problem. After updating to one ui 3, the rotate sensor stops working after a while and only a reboot helps. Galaxy Note 10+ N9750 (snapdragon). Can't find fix yet
 
Last edited:

fado5ster

Senior Member
Feb 27, 2013
66
5
*SOLVED*

Ok then, finally seem to have this sorted.
What I ended up doing was:

Downloading the latest firmware (the firmware that caused the problem) using frija.

I took a complete backup onto my laptop using Smart Switch.

I then flashed the firmware using Odin but again after a few hours sensors started to drop off again.

I then flashed the firmware again using Odin but this time I performed a nand erase while flashing.

Pushed my backup back onto my phone from my laptop using Smart Switch.
And hey presto!

This seems to have sorted it, I'm now well into day 2 and still working 100% which is the best it has been since the OTA firmware update.

Hopefully that will help others
 

tkwesa

Member
Nov 27, 2011
8
1
My phone is doing this as well, I've got a US unlocked phone overseas as well. I followed your instructions and did the nand erase but after 2 days the sensors started messing up again.
 

Alphaman10

Senior Member
Jul 23, 2015
896
292
My phone is doing this as well, I've got a US unlocked phone overseas as well. I followed your instructions and did the nand erase but after 2 days the sensors started messing up again.
It's the firmware..samsung is releasing buggy firmware..received 3.1 update yesterday... seems to have solved proximity and autorotate issue..smartview and NFC still not working for me.
 

tkwesa

Member
Nov 27, 2011
8
1
So they force us into an update that breaks the phone and don't let us go back to the previous version of the software? That doesn't sound right.

Another marketing scam to get us on to the S21.