[Solved] Google Sync Error

Search This thread

bgumble

Senior Member
Dec 27, 2008
556
97
oneplus.net
Out of nothing my contact and calendar from google account didn't sync.

  • (I reconfigured some time ago my google talk / hangouts, but I'm not sure that this was the reason for this google sync error)

In the sync settings of my google account an error appeared, something like


Sync is currently experiencing problems, it will be back shortly​


first: it took me some hours to figure it out
  • nothing in this forum mentioned before helped like deleting account and google apps, wiping cache, rebooting etc.



finally ...



this is the solution / workaround that fixed it for me:​

  1. open google calendar

  2. click in menu settings

    (here are only screenshots from my german android 4.1.2, but you should be able to follow the steps)

    e287.jpg


  3. in setting click on your existing gmail account

    bpvb.jpg


  4. in the settings of your existing account tab on add account

    vfuc.jpg


  5. on the following screen select google

    6b07.jpg


  6. enter now your login and password of your (existing) google account

    qxwy.jpg


  7. Open your account in settings, hit menu and sync now

  8. enjoy and hit THANKS (or even better click on link in my signature to join dropbox) if it helped and looks like this (in settings / google):

    4i0q.jpg



good to hear it worked :good:

I'd like to ask you to hit the 'thanks' button, as just a 'thanks' is the only honor I get. You'd be the 2nd person after >21.000 views of this thread. Thank you.
 
Last edited:

IMadeYouReadThiso.o

New member
Mar 22, 2014
1
11
Sync is currently experiencing problems, it will be back shortly ~FIX~

~For Root Users ~​
-First clear Google Play cache and data
-Open Root Explorer or a another similar file explorer
-Find the file named "ect" and open
-For Root Explorer change Mount R/W to Mount R/O
-Long press on the "hosts" file and tap "open in text editor"
-See the IP address xxx.x.x.x Localhost
-Add a "#" before the IP address, e.g - #xxx.x.x.x localhost
-Save and reboot your device
-tested on a Nexus 7 2013 running stock 4.4.2 build KOT49H with ElementalX kernel
-I may have no responsibility if you device becomes bricked, do this at your own risk x.x

I hope this helped ^-^
 
Last edited:

amirsh77

Senior Member
Apr 20, 2011
405
172
Kerman
Out of nothing my contact and calendar from google account didn't sync.

  • (I reconfigured some time ago my google talk / hangouts, but I'm not sure that this was the reason for this google sync error)

In the sync settings of my google account an error appeared, something like


Sync is currently experiencing problems, it will be back shortly​


first: it took me some hours to figure it out
  • nothing in this forum mentioned before helped like deleting account and google apps, wiping cache, rebooting etc.



finally ...



this is the solution / workaround that fixed it for me:​

  1. open google calendar

  2. click in menu settings

    (here are only screenshots from my german android 4.1.2, but you should be able to follow the steps)

    e287.jpg


  3. in setting click on your existing gmail account

    bpvb.jpg


  4. in the settings of your existing account tab on add account

    vfuc.jpg


  5. on the following screen select google

    6b07.jpg


  6. enter now your login and password of your (existing) google account

    qxwy.jpg


  7. Open your account in settings, hit menu and sync now

  8. enjoy and hit THANKS (or even better click on link in my signature to join dropbox) if it helped and looks like this (in settings / google):

    4i0q.jpg



~For Root Users ~​
-First clear Google Play cache and data
-Open Root Explorer or a another similar file explorer
-Find the file named "ect" and open
-For Root Explorer change Mount R/W to Mount R/O
-Long press on the "hosts" file and tap "open in text editor"
-See the IP address xxx.x.x.x Localhost
-Add a "#" before the IP address, e.g - #xxx.x.x.x localhost
-Save and reboot your device
-tested on a Nexus 7 2013 running stock 4.4.2 build KOT49H with ElementalX kernel
-I may have no responsibility if you device becomes bricked, do this at your own risk x.x

I hope this helped ^-^

NOT Helped ... :(:rolleyes:
 

amirsh77

Senior Member
Apr 20, 2011
405
172
Kerman
Can you specify? Like your android version, your error, what you did ...

I'm on 4.4.3 Nexus 5, I got error "Sync is currently experiencing problems. It will be back shortly! " when I want to sync just google contacts, other google options like calendar and keep are synching fine.
 

bgumble

Senior Member
Dec 27, 2008
556
97
oneplus.net
I'm on 4.4.3 Nexus 5, I got error "Sync is currently experiencing problems. It will be back shortly! " when I want to sync just google contacts, other google options like calendar and keep are synching fine.

If I were you I would remove the whole google account from the phone and delete all contacts. Boot into recovery, wipe cache, reboot and add google account.

But first of all I would make a nandroid backup!

Good luck :good:
 

avraum

Member
Feb 14, 2011
9
1
thanx mannnnnn!!! your solution workd for me.

Out of nothing my contact and calendar from google account didn't sync.

  • (I reconfigured some time ago my google talk / hangouts, but I'm not sure that this was the reason for this google sync error)

In the sync settings of my google account an error appeared, something like


Sync is currently experiencing problems, it will be back shortly​


first: it took me some hours to figure it out
  • nothing in this forum mentioned before helped like deleting account and google apps, wiping cache, rebooting etc.



finally ...



this is the solution / workaround that fixed it for me:​

  1. open google calendar

  2. click in menu settings

    (here are only screenshots from my german android 4.1.2, but you should be able to follow the steps)

    e287.jpg


  3. in setting click on your existing gmail account

    bpvb.jpg


  4. in the settings of your existing account tab on add account

    vfuc.jpg


  5. on the following screen select google

    6b07.jpg


  6. enter now your login and password of your (existing) google account

    qxwy.jpg


  7. Open your account in settings, hit menu and sync now

  8. enjoy and hit THANKS (or even better click on link in my signature to join dropbox) if it helped and looks like this (in settings / google):

    4i0q.jpg


 

CoNsPiRiSiZe

Senior Member
Jul 14, 2010
1,975
343
Roseville
Finally someone has posted a solution to this problem. I just tried this on my stock non rooted AT&T S4 and although I went through the steps when I go to login to my account it says
"couldn't sign in
There was a problem connecting to the Google servers.
Please try again later"

But - it no longer gives the sync errors instead looks to be syncing on my Google contacts. It says "cancel sync" where it is usually says sync now. Hopefully it does sync. If not.... what other options do I have?!

---------- Post added at 06:24 PM ---------- Previous post was at 05:30 PM ----------

Correction to my previous post - the fix does not work on my phone running ATT Touchwiz 4.4.2


Anyone know how to fix that wont wipe the contacts not synced yet? @bgumble
 

bgumble

Senior Member
Dec 27, 2008
556
97
oneplus.net
If I were you I would remove the whole google account from the phone and delete all contacts. Boot into recovery, wipe cache, reboot and add google account.

But first of all I would make a nandroid backup!

Good luck :good:

Finally someone has posted a solution to this problem. I just tried this on my stock non rooted AT&T S4 and although I went through the steps when I go to login to my account it says
"couldn't sign in
There was a problem connecting to the Google servers.
Please try again later"

But - it no longer gives the sync errors instead looks to be syncing on my Google contacts. It says "cancel sync" where it is usually says sync now. Hopefully it does sync. If not.... what other options do I have?!

---------- Post added at 06:24 PM ---------- Previous post was at 05:30 PM ----------

Correction to my previous post - the fix does not work on my phone running ATT Touchwiz 4.4.2


Anyone know how to fix that wont wipe the contacts not synced yet? @bgumble

you can export the contacts on your phone, try my 2nd solution, and with a working sync you can try to import the contacts again ...:fingers-crossed:
 

CoNsPiRiSiZe

Senior Member
Jul 14, 2010
1,975
343
Roseville
you can export the contacts on your phone, try my 2nd solution, and with a working sync you can try to import the contacts again ...:fingers-crossed:

So i ended up calling Samsung - because i rely on my contacts for work/professional use, and basically got them to direct me to disconnect my google account from my phone then re connect and sync it - just to be on the safe side so if it wiped my contacts which it did not and i knew would not... id have someone to blame ;)

disconnecting my google account and reconnecting is the solution that worked for me. Thanks for the post! Hope my post can help the next person in my shoes as this seems to be a common error.
 

bgumble

Senior Member
Dec 27, 2008
556
97
oneplus.net
So i ended up calling Samsung - because i rely on my contacts for work/professional use, and basically got them to direct me to disconnect my google account from my phone then re connect and sync it - just to be on the safe side so if it wiped my contacts which it did not and i knew would not... id have someone to blame ;)

disconnecting my google account and reconnecting is the solution that worked for me. Thanks for the post! Hope my post can help the next person in my shoes as this seems to be a common error.

good to hear it worked :good:

I'd like to ask you to hit the 'thanks' button, as just a 'thanks' is the only honor I get. You'd be the sixth person after >21.000 views of this thread. Thank you.
 
  • Like
Reactions: CoNsPiRiSiZe

Araib93

Senior Member
Jan 7, 2013
423
210
Rawalpindi
~For Root Users ~​
-First clear Google Play cache and data
-Open Root Explorer or a another similar file explorer
-Find the file named "ect" and open
-For Root Explorer change Mount R/W to Mount R/O
-Long press on the "hosts" file and tap "open in text editor"
-See the IP address xxx.x.x.x Localhost
-Add a "#" before the IP address, e.g - #xxx.x.x.x localhost
-Save and reboot your device
-tested on a Nexus 7 2013 running stock 4.4.2 build KOT49H with ElementalX kernel
-I may have no responsibility if you device becomes bricked, do this at your own risk x.x

I hope this helped ^-^

Worked like a charm ! :) Thanks mate. (Tested on HTC Pico CM 11 - 4.4.4 build KUT84P)
 

CoNsPiRiSiZe

Senior Member
Jul 14, 2010
1,975
343
Roseville
good to hear it worked :good:

I'd like to ask you to hit the 'thanks' button, as just a 'thanks' is the only honor I get. You'd be the sixth person after >21.000 views of this thread. Thank you.

Yes, unfortunate. This was the first thread i have seen with a real answer to this issue that i know a lot of people have; i have been searching the forums for 6 weeks - so thank you!
 

fallofredmond

Member
Oct 26, 2013
10
0
Hopatcong, NJ
Still Not Fixed

I had absolutely zero issues with sync on either of my accounts when I was using 4.3 ROMs. After switching to a custom Touchwiz KitKat ROM, the problems began. After the switch and restore of data with TB, acore was chronically crashing. So I wiped and reloaded the ROM from scratch and did not restore any system data that time. At this point, I went to add my Google accounts and calendars was not an available option. aCalendar+ Tasks was. However, even after repeatedly reauthorizing that option to have access, sync kept failing on aCalendar+ and Google Calendar was not an option still.

I have dropped both calendar programs, tried the contact fixer app, tried suggestions on other sites, and tried all suggestions in this thread with one exception. I am not manually editing my hosts file because, in my experience, doing so almost always breaks something else as a side effect.

So, short of wiping my ROM again, which I really don't have the time to do right now-what is there left to try. As it is, there is no option under my Google accounts settings to sync calendars at all and Picasa sync is now chronically failing on both accounts as a bonus. Google calendar is currently the only calendar app that I have installed and it endlessly churns when attempting to load the list of available calendars.
 

bgumble

Senior Member
Dec 27, 2008
556
97
oneplus.net
I had absolutely zero issues with sync on either of my accounts when I was using 4.3 ROMs. After switching to a custom Touchwiz KitKat ROM, the problems began. After the switch and restore of data with TB, acore was chronically crashing. So I wiped and reloaded the ROM from scratch and did not restore any system data that time. At this point, I went to add my Google accounts and calendars was not an available option. aCalendar+ Tasks was. However, even after repeatedly reauthorizing that option to have access, sync kept failing on aCalendar+ and Google Calendar was not an option still.

I have dropped both calendar programs, tried the contact fixer app, tried suggestions on other sites, and tried all suggestions in this thread with one exception. I am not manually editing my hosts file because, in my experience, doing so almost always breaks something else as a side effect.

So, short of wiping my ROM again, which I really don't have the time to do right now-what is there left to try. As it is, there is no option under my Google accounts settings to sync calendars at all and Picasa sync is now chronically failing on both accounts as a bonus. Google calendar is currently the only calendar app that I have installed and it endlessly churns when attempting to load the list of available calendars.

sorry for being late.

Did you solve the problem, or do you still have problems with google sync?
 

fallofredmond

Member
Oct 26, 2013
10
0
Hopatcong, NJ
sorry for being late.

Did you solve the problem, or do you still have problems with google sync?

I did not solve the problem with Google Calendar itself-I went around it instead. I switched from gCal and aCalendar+ to Calengoo and gTasks and those sync with Google Cloud data just fine. The only issue is that I still get a chronic sync error on Picasa sync so I had to go around that as well using Google+ sync instead. Very strange and frustrating problem this is.
 

bgumble

Senior Member
Dec 27, 2008
556
97
oneplus.net
I did not solve the problem with Google Calendar itself-I went around it instead. I switched from gCal and aCalendar+ to Calengoo and gTasks and those sync with Google Cloud data just fine. The only issue is that I still get a chronic sync error on Picasa sync so I had to go around that as well using Google+ sync instead. Very strange and frustrating problem this is.

Weird, I never dicovered issues in the software. I thought these errors were database errors. But it's defenetly a good workaround to change the software.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 23
    Out of nothing my contact and calendar from google account didn't sync.

    • (I reconfigured some time ago my google talk / hangouts, but I'm not sure that this was the reason for this google sync error)

    In the sync settings of my google account an error appeared, something like


    Sync is currently experiencing problems, it will be back shortly​


    first: it took me some hours to figure it out
    • nothing in this forum mentioned before helped like deleting account and google apps, wiping cache, rebooting etc.



    finally ...



    this is the solution / workaround that fixed it for me:​

    1. open google calendar

    2. click in menu settings

      (here are only screenshots from my german android 4.1.2, but you should be able to follow the steps)

      e287.jpg


    3. in setting click on your existing gmail account

      bpvb.jpg


    4. in the settings of your existing account tab on add account

      vfuc.jpg


    5. on the following screen select google

      6b07.jpg


    6. enter now your login and password of your (existing) google account

      qxwy.jpg


    7. Open your account in settings, hit menu and sync now

    8. enjoy and hit THANKS (or even better click on link in my signature to join dropbox) if it helped and looks like this (in settings / google):

      4i0q.jpg



    good to hear it worked :good:

    I'd like to ask you to hit the 'thanks' button, as just a 'thanks' is the only honor I get. You'd be the 2nd person after >21.000 views of this thread. Thank you.
    11
    Sync is currently experiencing problems, it will be back shortly ~FIX~

    ~For Root Users ~​
    -First clear Google Play cache and data
    -Open Root Explorer or a another similar file explorer
    -Find the file named "ect" and open
    -For Root Explorer change Mount R/W to Mount R/O
    -Long press on the "hosts" file and tap "open in text editor"
    -See the IP address xxx.x.x.x Localhost
    -Add a "#" before the IP address, e.g - #xxx.x.x.x localhost
    -Save and reboot your device
    -tested on a Nexus 7 2013 running stock 4.4.2 build KOT49H with ElementalX kernel
    -I may have no responsibility if you device becomes bricked, do this at your own risk x.x

    I hope this helped ^-^
    4
    I'm on 4.4.3 Nexus 5, I got error "Sync is currently experiencing problems. It will be back shortly! " when I want to sync just google contacts, other google options like calendar and keep are synching fine.

    If I were you I would remove the whole google account from the phone and delete all contacts. Boot into recovery, wipe cache, reboot and add google account.

    But first of all I would make a nandroid backup!

    Good luck :good:
    3
    Out of nothing my contact and calendar from google account didn't sync.

    • (I reconfigured some time ago my google talk / hangouts, but I'm not sure that this was the reason for this google sync error)

    In the sync settings of my google account an error appeared, something like


    Sync is currently experiencing problems, it will be back shortly​


    first: it took me some hours to figure it out
    • nothing in this forum mentioned before helped like deleting account and google apps, wiping cache, rebooting etc.



    finally ...



    this is the solution / workaround that fixed it for me:​

    1. open google calendar

    2. click in menu settings

      (here are only screenshots from my german android 4.1.2, but you should be able to follow the steps)

      e287.jpg


    3. in setting click on your existing gmail account

      bpvb.jpg


    4. in the settings of your existing account tab on add account

      vfuc.jpg


    5. on the following screen select google

      6b07.jpg


    6. enter now your login and password of your (existing) google account

      qxwy.jpg


    7. Open your account in settings, hit menu and sync now

    8. enjoy and hit THANKS (or even better click on link in my signature to join dropbox) if it helped and looks like this (in settings / google):

      4i0q.jpg



    ~For Root Users ~​
    -First clear Google Play cache and data
    -Open Root Explorer or a another similar file explorer
    -Find the file named "ect" and open
    -For Root Explorer change Mount R/W to Mount R/O
    -Long press on the "hosts" file and tap "open in text editor"
    -See the IP address xxx.x.x.x Localhost
    -Add a "#" before the IP address, e.g - #xxx.x.x.x localhost
    -Save and reboot your device
    -tested on a Nexus 7 2013 running stock 4.4.2 build KOT49H with ElementalX kernel
    -I may have no responsibility if you device becomes bricked, do this at your own risk x.x

    I hope this helped ^-^

    NOT Helped ... :(:rolleyes:
    3
    NOT Helped ... :(:rolleyes:

    Can you specify? Like your android version, your error, what you did ...
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone