• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[solved] help!!!

Search This thread

FranGAMER321

Member
Mar 23, 2019
29
2
Funny, i had the same problem yesterday, was told i should wipe the decryption on the phone in twrp, i lost my IMEI and can't flash roms anymore, be carefull.
In TWRP to skip the password requirement I touched cancel and touched wipe (without a custom wipe), and after doing so I made an error, but after trying a couple of hours later the same thing came out, until I tried 3 more times in a row and he left me, after that I could finally use LineageOS 17.1
 

TheFixItMan

Senior Member
Jul 8, 2012
7,816
4,009
London
Funny, i had the same problem yesterday, was told i should wipe the decryption on the phone in twrp, i lost my IMEI and can't flash roms anymore, be carefull.

Your loss of imei had nothing to do with formatting data and more to do with flashing rom

Make sure you're on oero firmware & reflash that firmware fully via fastboot
Flash a custom rom that gives you imei (you will have to try them - try the oero twrp flashable stock rom too) and then back up efs so you can restore it if problem happens again

---------- Post added at 02:05 PM ---------- Previous post was at 02:03 PM ----------

I installed Lineage OS 17.1 and when I turn on my phone he asks me for a password but I've never had :(

You need to format data

TWRP - wipe - format data (option on the right)
Reboot to recovery & flash rom again

Or in fastboot do
fastboot erase userdata

Either way backup anything on internal storage (pics docs music etc) first as this will be deleted
 
  • Like
Reactions: maserati2011

maserati2011

Senior Member
Aug 10, 2014
91
1
Your loss of imei had nothing to do with formatting data and more to do with flashing rom

Make sure you're on oero firmware & reflash that firmware fully via fastboot
Flash a custom rom that gives you imei (you will have to try them - try the oero twrp flashable stock rom too) and then back up efs so you can restore it if problem happens again

would you be kind enough to help me through it on messenger?
 

maserati2011

Senior Member
Aug 10, 2014
91
1
Your loss of imei had nothing to do with formatting data and more to do with flashing rom

Make sure you're on oero firmware & reflash that firmware fully via fastboot
Flash a custom rom that gives you imei (you will have to try them - try the oero twrp flashable stock rom too) and then back up efs so you can restore it if problem happens again

I managed to re flash the stock Oreo 8.1 firmware through Lenovo Moto Smart Assistant hoping to get the IMEI back and automatically re-lock the boot-loader but neither happened, still no IMEI and Boot-loader is still unlocked, what to do now?
 

TheFixItMan

Senior Member
Jul 8, 2012
7,816
4,009
London
I managed to re flash the stock Oreo 8.1 firmware through Lenovo Moto Smart Assistant hoping to get the IMEI back and automatically re-lock the boot-loader but neither happened, still no IMEI and Boot-loader is still unlocked, what to do now?

If running
fastboot erase modemst1
fastboot erase modemst2

Doesn't bring your imei back like I said - try different custom roms (especially the last where imei worked)

Else you will need a motherboard replacement if you can't work out a way to restore it

And never re-lock the bootloader 'if you hard brick your device again due to ota update because the firmware you flashed was wrong you will never be able to re-flash the device
 
  • Like
Reactions: maserati2011

maserati2011

Senior Member
Aug 10, 2014
91
1
If running
fastboot erase modemst1
fastboot erase modemst2

Doesn't bring your imei back like I said - try different custom roms (especially the last where imei worked)

Else you will need a motherboard replacement if you can't work out a way to restore it

And never re-lock the bootloader 'if you hard brick your device again due to ota update because the firmware you flashed was wrong you will never be able to re-flash the device

So basically your advice is to find a stable custom rom where the IMEI shows and just stick with it correct?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Funny, i had the same problem yesterday, was told i should wipe the decryption on the phone in twrp, i lost my IMEI and can't flash roms anymore, be carefull.

    Your loss of imei had nothing to do with formatting data and more to do with flashing rom

    Make sure you're on oero firmware & reflash that firmware fully via fastboot
    Flash a custom rom that gives you imei (you will have to try them - try the oero twrp flashable stock rom too) and then back up efs so you can restore it if problem happens again

    ---------- Post added at 02:05 PM ---------- Previous post was at 02:03 PM ----------

    I installed Lineage OS 17.1 and when I turn on my phone he asks me for a password but I've never had :(

    You need to format data

    TWRP - wipe - format data (option on the right)
    Reboot to recovery & flash rom again

    Or in fastboot do
    fastboot erase userdata

    Either way backup anything on internal storage (pics docs music etc) first as this will be deleted
    1
    I managed to re flash the stock Oreo 8.1 firmware through Lenovo Moto Smart Assistant hoping to get the IMEI back and automatically re-lock the boot-loader but neither happened, still no IMEI and Boot-loader is still unlocked, what to do now?

    If running
    fastboot erase modemst1
    fastboot erase modemst2

    Doesn't bring your imei back like I said - try different custom roms (especially the last where imei worked)

    Else you will need a motherboard replacement if you can't work out a way to restore it

    And never re-lock the bootloader 'if you hard brick your device again due to ota update because the firmware you flashed was wrong you will never be able to re-flash the device