[SOLVED] - Manually enable adb debugging from recovery

Search This thread

workdowg

Senior Member
Apr 17, 2011
1,556
691
Seneca Falls
First off, this may seem a noob question, but I am definitely not. :)

I have an Iconia A200 that now has a broken lcd screen. No display, no touch. I am able to get into the tablet from TWRP via adb, but not from Android (Jelly Bean). It seems I never enabled usb debugging when I installed the custom rooted rom.... I can access the file system and modify anything... Which files need to be modified to enable debugging in Android? Here is what I tried:

Added to default.prop and /system/build.prop
Code:
persist.service.adb.enable=1                                                    
persist.service.debuggable=1
persist.sys.usb.config=mtp,adb

Edit: Must have had typos... It now works.
 
Last edited:

Curt5654

New member
Feb 13, 2015
2
0
First, find the folder that contains the adb.exe file.
Then, right click the folder and choose "copy as path".

Then,

You can open system properties,
Click on environment variables,
On the System Variables window, click on the path variable, then click Edit,
On the menu that opens, click new,
And paste the clipboard and click "Ok".
Close all the variable windows.

You should now be able to open a cmd window anywhere and ADB and Fast Boot should work.

I hope that I explained this well enough.
Enjoy,
 

Top Liked Posts

  • There are no posts matching your filters.
  • 19
    First off, this may seem a noob question, but I am definitely not. :)

    I have an Iconia A200 that now has a broken lcd screen. No display, no touch. I am able to get into the tablet from TWRP via adb, but not from Android (Jelly Bean). It seems I never enabled usb debugging when I installed the custom rooted rom.... I can access the file system and modify anything... Which files need to be modified to enable debugging in Android? Here is what I tried:

    Added to default.prop and /system/build.prop
    Code:
    persist.service.adb.enable=1                                                    
    persist.service.debuggable=1
    persist.sys.usb.config=mtp,adb

    Edit: Must have had typos... It now works.
    19
    How would i do this with my skyrocket? same problem, broken screen, adb disabled. Some instructions would be sweet, cause im not really clear with what you did here.

    How would i do this with my skyrocket? same problem, broken screen, adb disabled. Some instructions would be sweet, cause im not really clear with what you did here.
    I'm going to stay general and assume that a skyrochet is a phone, you have a linux or windows pc with ADB installed (and the drivers to connect to your phone) and have TWRP or CWM Recovery installed already...
    1) Start the phone in recovery mode - mine is power down and vol
    2) Connect you cable to the pc and start a console terminal or cmd prompt
    3) Run the following
    Code:
    adb shell
    su
    mount -o remount,rw /system
    cd /
    echo "persist.service.adb.enable=1" >> default.prop 
    echo "persist.service.debuggable=1" >> default.prop
    echo "persist.sys.usb.config=mtp,adb" >> default.prop
    echo "persist.service.adb.enable=1" >> /system/build.prop 
    echo "persist.service.debuggable=1" >> /system/build.prop
    echo "persist.sys.usb.config=mtp,adb" >> /system/build.prop
    Once you reboot into Android you should be able to connect via adb.
    If you google vnc over adb you can get a usable but very slow vnc connection then install Andriod VNC server for a little better performance.
    That's the best I can do from memory ...
    3
    First off, this may seem a noob question, but I am definitely not. :)

    I have an Iconia A200 that now has a broken lcd screen. No display, no touch. I am able to get into the tablet from TWRP via adb, but not from Android (Jelly Bean). It seems I never enabled usb debugging when I installed the custom rooted rom.... I can access the file system and modify anything... Which files need to be modified to enable debugging in Android? Here is what I tried:

    Added to default.prop and /system/build.prop
    Code:
    persist.service.adb.enable=1                                                    
    persist.service.debuggable=1
    persist.sys.usb.config=mtp,adb

    Edit: Must have had typos... It now works.

    Ok Sounds good for you. Can you changed the title of your thread by [SOLVED]
    Thanks in advance ;)
    3
    Hi workdowg! I appreciate your replies.

    Immediately after I boot into CWM recovery and connect via adb, I'm already root. There is no need for me to su.

    Also, there's already a directory called /system. If I "cd" to this directory and run "ls -la", I get the following:

    Code:
    # cd /system
    
    /system # ls -la
    __bionic_open_tzdata: couldn't find any tzdata when looking for localtime!
    __bionic_open_tzdata: couldn't find any tzdata when looking for GMT!
    __bionic_open_tzdata: couldn't find any tzdata when looking for posixrules!
    drwxr-xr-x    3 root     root             0 Jan  1  1970 .
    drwxr-xr-x   22 root     root             0 Jan  1 17:07 ..
    drwxr-xr-x    2 root     root             0 Jan  1  1970 bin


    So immediately after I boot, /system is a directory which already exists, but doesn't contain a "build.prop"


    When you are in adb shell what do you get with just the mount command?

    The output of the mount command is:

    Code:
    # mount
    rootfs on / type rootfs (rw)
    tmpfs on /dev type tmpfs (rw,seclabel,nosuid,relatime,mode=755)
    devpts on /dev/pts type devpts (rw,seclabel,relatime,mode=600)
    proc on /proc type proc (rw,relatime)
    sysfs on /sys type sysfs (rw,seclabel,relatime)
    selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
    tmpfs on /storage type tmpfs (rw,seclabel,relatime,mode=050,gid=1028)
    tmpfs on /mnt/secure type tmpfs (rw,seclabel,relatime,mode=700)
    tmpfs on /mnt/fuse type tmpfs (rw,seclabel,relatime,mode=775,gid=1000)
    /dev/block/mmcblk0p12 on /cache type ext4 (rw,seclabel,relatime,user_xattr,barrier=1,journal_async_commit,data=ordered)



    Try this:
    Code:
    su
    mount -o rw,remount /dev/block/by-name/system /system

    Four mount commands which I tried but didn't work:

    Code:
    # mount -o rw,remount /dev/block/by-name/system /system
    mount: mounting /dev/block/by-name/system on /system failed: Invalid argument
    
    # mount -o rw,remount /dev/block/by-name/system /system2
    mount: mounting /dev/block/by-name/system on /system2 failed: No such file or directory
    
    /dev/block # mount -o rw,remount /dev/block/mmcblk0p13 /system2
    mount: mounting /dev/block/mmcblk0p13 on /system2 failed: No such file or directory
    
    /dev/block # mount -o rw,remount /dev/block/mmcblk0p13 /system
    mount: mounting /dev/block/mmcblk0p13 on /system failed: Invalid argument


    Btw I'm guessing that mmcblk0p13 is my system partition, but I'm not 100% sure.

    *********************

    Edit:

    Oh no, I wasn't thinking straight earlier...

    Sorry, I've just realized how noob I was. Anyway, after running the following commands...

    Code:
    cd /
    mkdir /system2
    mount -o rw /dev/block/mmcblk0p13 /system2
    echo "persist.service.adb.enable=1" >> default.prop 
    echo "persist.service.debuggable=1" >> default.prop
    echo "persist.sys.usb.config=mtp,adb" >> default.prop
    echo "persist.service.adb.enable=1" >> /system2/build.prop 
    echo "persist.service.debuggable=1" >> /system2/build.prop
    echo "persist.sys.usb.config=mtp,adb" >> /system2/build.prop

    ...and then rebooting, I now have adb access to Android! (Finally!) And I've managed to run Android Screencast together with my phone, so my phone is fully functional once more.

    Thank you so much workdowg!
    3
    You should've stopped at " 'adb' is not..."

    Microsoft Windows [Version 6.3.9600]
    (c) 2013 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>adb shell
    'adb' is not recognized as an internal or external command,
    operable program or batch file.
    . . .
    Getting this on S$..any1 here to help me!

    You need to first install ADB, the installer can be found via Google.
    Once installed (Press 'Y' > 'ENTER' for each option during install, this should install it to the default location, i.e. "C:").
    Run "cmd" and enter the command "dir" . . . you should see "adb" as the first or second <DIR> listed; if you do not, find where 'adb' is installed and navigate to its folder via the commands 'cd' and 'dir'. Once in the 'adb' dir...
    Begin typing "adb shell" and you'll see something other than..
    "'adb' is not recognized as an internal or external command,
    operable program or batch file."