[SOLVED] Mi unlock not working

Search This thread

noraj1137

Member
Jan 10, 2019
16
1

Description​


I have downloaded the latest Mi Unlock version miflash_unlock-en-6.5.406.31.

I have two authentication option :


When I log in with my email + password it's asking for a SMS code but I'm never receiving any SMS from Xiaomi. It's not an issue on my side since am receiving SMS from other peoples and it's the right number since it's already associated to my Mi account and was verified. With other Xiaomi services I'm receiving SMS, I'm not just for the Unlock tool.

With the QR code authentication using my phone, it's says authentication successful but that I have to re-login ( ) and when I click on the login button there is a login wheel on a white screen loading indefinitely ( ).

I tried clicking on the "bug & feedback" button, it redirects to https://en.miui.com/forum.php but the page returns a 502 HTTP error.

I downloaded MI Unlock from https://en.miui.com/unlock/download_en.html (miflash_unlock-en-6.5.224.28). When launching it, it offered me to download a newer version at miuirom.xiaomi.com/rom/u1106245679/6.5.406.31/miflash_unlock-en-6.5.406.31.zip (miflash_unlock-en-6.5.406.31). Both have the same behavior.

I tried running the software on various Windows 10 machines without success. So If I understand correctly as I'm not even able to log in properly I can't start the ultra-long unlock timer.

My opinion:



Why there is even the account linking, the PC tool required, the very long timer, etc. while on other vendor phones there is just one button to press or a key to retrieve on your account.

[email protected] is not answering, it's just an empty mailbox. [email protected] answered me but asked me to rewrite my mail in French because I wrote it in English and no answer since. My post in Xiaomi sub-reddit has been pending for approval for weeks "Post is awaiting moderator approval.". Xiaomi community forum is buggy as hell and my post there was removed.

All this look like a giga scam from Xiaomi so people can't unlock their phones and stay with unrooted MIUI. I bought the POCO F3 just because I was supposed to be able to root and flash it but now I can't even unlock it.



QR code auth logs​


cef.log

Code:
[0508/132947:ERROR:renderer_main.cc(227)] Running without renderer sandbox

miflash_unlock.log

Code:
2022-5-8 Version:6.5.406.31 Process<000000AC> >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Begin List Enviroment Variables.
=::=::\
[CROPPED]
End List Enviroment Variables.
Process list:
[CROPPED]
DEBUG  <13:29:47.241,T:14900> : miflash_unlock start
DEBUG  <13:29:47.640,T:11000> : auto refresh device list
INFO   <13:29:47.650,T:11000> : fastboot devices
INFO   <13:29:48.828,T:14892> : new app version:6.5.406.31 url:http://miuirom.xiaomi.com/rom/u1106245679/6.5.406.31/miflash_unlock-en-6.5.406.31.zip
DEBUG  <13:29:49.968,T:14900> : [200]End: https://account.xiaomi.com/pass/serviceLogin?sid=unlockApi&json=false&passive=true&hidden=false&_snsDefault=facebook&_locale=en_US&checkSafePhone=true
DEBUG  <13:29:51.230,T:14900> : [200]End: https://account.xiaomi.com/pass/lp?deviceType=PC&dataCenter=eu&dataCenterZone=Europe&locale=en_US&region=US&callback=https%3A%2F%2Funlock.update.miui.com%2Fsts&sid=unlockApi&qs=%253Fsid%253DunlockApi%2526json%253Dfalse%2526passive%253Dtrue%2526hidden%253Dfalse%2526_snsDefault%253Dfacebook%2526_locale%253Den_US%2526checkSafePhone%253Dtrue&_sign=EDITED&serviceParam=%7B%22checkSafePhone%22%3Atrue%2C%22checkSafeAddress%22%3Afalse%2C%22lsrp_score%22%3A0.0%7D&privacyLink=%2Fabout%2Fprotocol%2Fprivacy&agreeLink=%2Fabout%2Fprotocol%2Fagreement&loginMethods=PWD&useManMachine=false&areaConfig=%5Bobject%20Object%5D&fromTw=false&_qrsize=270
DEBUG  <13:29:52.267,T:14900> : [200]End: https://eu.lp.account.xiaomi.com/static/res/EDITED/account-static/html/login/dist/qrlogin/passlp-en.html?deviceType=PC&dataCenter=eu&dataCenterZone=Europe&locale=en_US&region=US&callback=https%3A%2F%2Funlock.update.miui.com%2Fsts&sid=unlockApi&qs=%253Fsid%253DunlockApi%2526json%253Dfalse%2526passive%253Dtrue%2526hidden%253Dfalse%2526_snsDefault%253Dfacebook%2526_locale%253Den_US%2526checkSafePhone%253Dtrue&_sign=EDITED&serviceParam=%7B%22checkSafePhone%22%3Atrue%2C%22checkSafeAddress%22%3Afalse%2C%22lsrp_score%22%3A0.0%7D&privacyLink=%2Fabout%2Fprotocol%2Fprivacy&agreeLink=%2Fabout%2Fprotocol%2Fagreement&loginMethods=PWD&useManMachine=false&areaConfig=%5Bobject%20Object%5D&fromTw=false&_qrsize=270&_=EDITED
DEBUG  <13:30:11.412,T:14900> : [401]End: https://unlock.update.miui.com/sts?d=EDITED&ticket=0&pwd=0&p_ts=EDITED&fid=1&p_lm=7&auth=EDITED&m=9&tsl=0&nonce=EDITED&_ssign=EDITED
DEBUG  <13:30:11.412,T:14900> : WA_ReLogin
DEBUG  <13:30:17.216,T:14900> : call logout
 

noraj1137

Member
Jan 10, 2019
16
1
After 24 days I retried the credentials authentication with SMS OTP and I was able to log in, install the driver for my phone and launch the unlock process.

But now I'm having this issue
1653852024827.png

Update: I had to unplug and plug my phone again and click "unlock again" for it to work.