• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[SOLVED] No Signal after update with "Wipe All Data"

Search This thread


Sep 3, 2013
Guys a question, if i have an gionee elife e7, can i install the modem of a blu life pure xl to have 3g in my phone?, o maybe flash the rom stock of the blu into the gionee?


Dec 13, 2012
I followed all the tutorial but always without success.
I need a working QCN or EFS backup from TWRP recovery
Or a video tutorial.

help me pleaaaaaaaaaaaase


New member
Nov 2, 2015
Can you please give steps on how to connect the phone and put it in diag mode? Flashed firmware twice and qpst sees com 10 but says no phone.
Last edited:

vishu sharma

May 19, 2014
sri ganganagar
In Software Download - Restore when the software is trying to "reset device", reboot it from adb or from the device it self.
Please feedback, my 3G is working now... I believe there was a problem with the SIM card i was using before...
This might be the solution all together.....
1 - Restore the qcn
2 - Restore your IMEI

it should be fine!!
I tested again adn now i got 2G and 3G...
Man, how i'm happy!!!!!


Oct 1, 2015
Help imei 0 null

Fellow okay?
I am having the same problem that you guys had.
after trying to flash in a custom by TWRP in my
LIFE PURE XL containing the same hardware that Gionee E7 32GB lost my Imei signal has been corrupted.
but wondered how they managed to retrieve the IMEI which in my case is IMEI 0 ..
I am here in Brazil and not understanding very well what to do .. excuse the bad English!
can you help me ? :( :bem:


New member
Dec 11, 2015
Thank you very much!
I fixed it!
I restored my old files modem1st and modem st2. After i'm restored QCN backup (with the help of your file). And, before reboot, was loaded QCN file from firmware (WBW8901GI_0301).
I'm used QPST 2.7 build 402. Only this version, 402, has helped me!
I'm happy!!! Yeeeah!!! Thank you for help!!!

I am a bit new to this and i have tried every step from clean install with complete wipe, loading both the qnc from this page and the kitkat qnc file after, to successfully loading my imei and it still doesnt work. My question is when you refer to your modem st1 and st2 what do you mean? where did you get that?

another thing is does it matter that im doing it on windows 10?
Last edited:


New member
Dec 11, 2015
I got a BLU Pure XL qcn and now i have GSM, but no 3G/WCDMA.
We need the original Gionee E7 qcn to get all working

If you want download the BLU qcn if you want to get GSM/EDGE working for now...

As i said before: "Wipe full data" really wipes... :(

Hey man, can you upload this original blu xl qcn please, id like to have atleast any signal since ive done all your steps atleast 5 times per version qspt and still no luck. Im hoping that its not working due to a compatibillity issue on windows 10 and qspt. I will try do the same steps on windows 7 and will get back to you guys, thanks! suffering here watching my phone :(

okay so windows 7 had no luck as well on qpst 402 either... :(
Last edited:


New member
Dec 11, 2015
So my procedure has been as follows:
1) GN_Qcom_Download_Tools_V2.1.0.1 i used to flash the stock rom Gionee_E7_32G_0301_T8143 with wipe all data.
2) I then open QPST config-add my diag comport- go to software download and then the restore tab.
3)i restore the E7.QCN.OK_IMEI-0.qcn (then get a error, which is apparently normal), before i reboot i install WBW8901GI_0301.qcn, the i reboot on the phone itself when it says resting device on qpst like the forum said.
4) I then launch the RVManager, add my comport, tick hex, go to item 550, enter my converted imei, reboot phone, i then go to settings-status and my imei is now there in the correct format.
5) i then put in the sim card while the phone is on, the signal comes on for about 5 seconds before it completely dissapears again = no signal.

Either ive missed a step or the forum has missed a step or the qcn is not a working one.

I have the Gionee E7 32GB, which is basically just a wifi device only now :(

Im sure its because the qcn doesnt stick, must i reboot after the error message? as well as the reset error i also get a message saying that the model number isnt the same and if i wish to continue.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Solved the bad issue of no network and no imei

    @ashu rajput and @MD.RABBY

    For all those who have been struggling using qcn provided here in this forum and failing please just flash this fresh qcn by courtesy of 4pda. It auto repair your no network and the imei (illegal use is not my responsibility).
    just while restoring from qpst select this file and restore, dont check any other tick options and you may need to manually restart upon error. after reboot everthing works:good:
    What about me - i have a bootloop after restore on 4.2.2 firmware, and "unknown" IMEI, network and other on 4.4.2 firmware... I can restore IMEI, but i have not gsm/umts network signal.
    If you get a working phone - can you make a backup memory of your phone (without userdata, system and other your private files) with "Partitions Backup&Restore" (from market) ?
    I think my problem - the consequences of my "experiments" with memory...

    Try this:
    1 - Remove the SIM from the phone
    2 - Install kitKat with GNQC using Wipe All Data
    3 - Load QCN file and reboot [if your using the first file i shared, delete it and download the new one]
    4 - Restore your IMEI using QPST and reboot [i could be necessary repeat this step || the IMEI usually don't stay at the 1st and 2nd attemps]
    5 - When on boot you have your IMEI back, insert the SIM card

    Sorry bout the file, the first one i shared is from a Blu Pure XL. To work properly on a Gionee its necessary to flash the Blu Modem also...
    If you are flashing the phone with GNQC tools, you can check that there's a QCN file on the Firmware folder.
    If you load first "Working-QCN-copia.qcn", dont reboot and load next the "WBW8901GI_0301.qcn", now reboot you will fix the boot loop.
    The file "E7-GSM.OK_WCDMA.NOK_IMEI-0.qcn" is the BLU file modded to Gionee, so if you load this one you dont need to load anymore qcn files.

    Keep feedback me.. We'll solve this
    i have flash again my phone with wipe all data but it dosen't work qpst. it dosen't apear nothing just com 1.
    in developers menu you activated "write diag interface" and debug via usb?
    Now look.
    1. Look into device manager, and remember number com port
    2. Add new port in QPST configuration
    3. Write number COM port by hands, if number of COM port not detected automatically.
    4. Now we have your phone in QPST
    5. Now you open "Start client - Software download" and restore QCN backup
    I might share that with you, but i just dont see how that will help you....
    You still need to set your IMEI on the device...
    Making a backup file now... this might take a few minutes..
    Meanwhile, have you tried to set your imei with EFS Prof? Has i said before, it might take a few times for the IMEI to stick.
    You can also try to set your IMEI with DFS CDMA Tool, that also works!
    Please, don't stress up! It wont help! Take a deep and long breath and try to set your IMEI while i backup the NV Items with EFS
    @stallionrider21 @RSGI_PT @RSGI @d_mesg or anyone else with more knowledge on this --
    I've tried almost each and every step mentioned here on all pages. Was not able to restore QCN files posted on page 2/3 and 8 directly, but EFS restore via TWRP method worked successfully which is posted on page 7. But I'm still unable to inject my IMEI via QPST or EFS Professional tool as it gives me some bad response error while writing IMEI. Is someone here willing to hex edit their EFS backup of TWRP with my IMEI (I can provide it via PM to the helping person) or can provide a proper QCN backup of their E7 32 GB model with my IMEI hex edited into their QCN backup file so that I can finally flash it properly to restore my phone back to normal. Any help on this would be greatly appreciated. I'm willing to provide error screenshots for exact information if needed. Thanks in advance.

    Issues : IMEI shows as Unknown, nor Bluetooth is switching on and shows as unavailable in Settings>>About Phone>>Status.

    Edit : Just for more information, my phone suffered a water damage and had to give it to local service technician for repair, somehow he changed something which messed my IMEI/baseband info on phone. That guy has no clue how to restore it via software as he can only fix hardware issues. Please help!

    Edit2: Thanks for all the instructions here. Problem resolved after flashing back to original JB firmware, that allowed me to restore stallionrider21's QCN file, and then changed my IMEI back to my own using previous instructions from OP. Later upgraded to KK (8143 version and 8180 version eventually) without wiping data and it's all fine now. Any other latest versions of KK, when flashed, restores same issue of unknown baseband and invalid IMEI. No idea, what's wrong, anyways, I'm happy at least to restore my Wife's phone to normal. Thanks xda and everyone here.