Question [SOLVED] Nothing Phone (1) Keeps Rebooting After Persist Partition is Erased

Search This thread

arinc9

Member
Sep 25, 2017
7
2
Nothing Phone 1
I see the splash screen with NOTHING logo and "Powered by Android" at the bottom. After 15 seconds or so, the phone reboots.

This started happening after I erased the persist partition using fastboot.

A few things I tried which didn't work:
Sideloading a full 1.1.4 hotfix zip file using adb.
Factory resetting from the recovery and fastboot.
Format persist partition as ext4, "fastboot format:ext4 persist".

I don't see persist.img included in the firmware release. Can anyone extract the persist partition from their Nothing Phone (1)? I can flash persist.img and hopefully get the phone to boot properly.

Or if it's possible to enable diag mode from the recovery image. I don't know if it's possible to set sys.usb.config to diag,adb on recovery. I took a qcn backup beforehand. I can just restore that.

Thanks to @ayed78 providing persist.img from their device, I was able to boot into Android. I restored the qcn backup to restore the IMEIs and therefore restore cellular network connectivity.
 
Last edited:

AntoXik72

Senior Member
Feb 27, 2013
100
50
I see the splash screen with NOTHING logo and "Powered by Android" at the bottom. After 15 seconds or so, the phone reboots.

This started happening after I erased the persist partition using fastboot.

A few things I tried which didn't work:
Sideloading a full 1.1.4 hotfix zip file using adb.
Factory resetting from the recovery and fastboot.
Format persist partition as ext4, "fastboot format:ext4 persist".

I don't see persist.img included in the firmware release. Can anyone extract the persist partition from their Nothing Phone (1)? I can flash persist.img and hopefully get the phone to boot properly.

Or if it's possible to enable diag mode from the recovery image. I don't know if it's possible to set sys.usb.config to diag,adb on recovery. I took a qcn backup beforehand. I can just restore that.
I will make a tutorial about brick fix tonight wich worked for me. Hope it'll work for yours
 

arinc9

Member
Sep 25, 2017
7
2
Nothing Phone 1
Posting a short version of my reply here, from https://forum.xda-developers.com/t/how-to-unbrick-nothing-phone-1-fastboot-bootloop.4501439/

I've tried this on my Nothing Phone (1) EEA version which bootloops. It doesn't work. Whilst booting from the A slot, there's the 15 seconds of splash screen, then it reboots, same as before.

Flashing to A slot was completed without any errors. I don't think this super image includes the persist partition. My phone started bootlooping after I erased the persist partition. Can anyone upload their persist partition for the global or EEA version?
 

Top Liked Posts