• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[SOLVED] Phone phone in bootloop, power button also not responding

Search This thread
Hi,

I installed an unoffical havoc android 11 build along with opengapps with the help of TWRP, and now my phone is stuck showing me a loop that goes round and round, and the power button isn't working either.

What to do? I feel like in time the battery will die but I am not sure it will go in recovery either.
 
I was able to fix this myself. Here is what I did:

1. Wait until phone goes out of battery.
2. Open cmd and enter following command:
Bash:
fastboot boot twrp.img
. Since the device is still not connected, it will get stuck on "waiting for device".
3. Now connect the discharged phone to your pc using a good USB cable and power it on. The phone will start charging, but will restart several times before it is sufficiently charged. Once it is sufficiently charged, it will proceed to boot wherein fastboot will detect it and boot twrp.
4. Now you are in twrp. You can go ahead with flash. I used havoc (android 10) image for Nokia 6.1 plus from https://nokia-sdm660.github.io

Why it happened:
I am not sure but it could be one of these:
1. I forgot to clean dalvik cache
2. I used unofficial havoc (android 11) image

Thanks for this community for giving us exceptional amount of information, I was able to resolve this issue by myself.