[SOLVED] Rooting android 9 A600FN ?

Search This thread

Sebo1002

Member
Aug 19, 2019
5
0
Very good explanation. Now, the circumstances are more understandable.
I note, that I have no idea how to help you and what the problem is, but the problem you described is so interesting that I can't refrain from speculation.
Here they are:
  1. First: your points from 1 to 6 are correct, you don't have to change them, just maybe download the necessary files again from the web sources. for sure...
  2. Second: if you catch bootloop again (you described it), then you do not have to repeat the procedure from 1 to 6 points.
    All you have to do is start the phone directly to TWRP recovery (press and hold about 5s. Vol + plus power button until you see the logo and feel the shake).
    Wipe everything (data/dlavik/cache), but not the system. Do not format Data - it is unnecessary anymore. Data can already be read.
    I think you don't need to flash Magisk because the modified boot is already there.
    I'm not sure about RMM-Bypas 3.0 and no verity opt, but to be sure you can flash both (points 4 and 5) one by one, restart recovery - not needed I think.
    Now you're fresh! you can start all over again, your bootloop will disappear, and you will see the configuration wizard again.

  1. need magisk...
    [*]third: do it different now, because don't do anything!!!
    This means no network data, no wifi, no google and samsung accounts, just see your main desktop. Then restart.
    What will happen? Probably nothing, just the phone will start normally.
    the same - problems with PIN typing - still says wrong pin, the one i put one step earlier
    I think the issue is related to your google account and restore data from google copy.
    Unfortunately, even without logging in to the google account, the phone updates itself as soon as it feels the network - this may also be the source of the problem.
    Let us know about the test results
    no, it's not related with google/sams account - my rom isn't "rootable" with described methods.

    want stock rom, don't want coocked rom.

    Pice of sh#&* this phone is.
    I'm done with rooting this, will get another, "normal" phone.
 
G

GuestX01058

Guest
need magisk...

the same - problems with PIN typing - still says wrong pin, the one i put one step earlier

no, it's not related with google/sams account - my rom isn't "rootable" with described methods.


want stock rom, don't want coocked rom.

Pice of sh#&* this phone is.
I'm done with rooting this, will get another, "normal" phone.
I have rooted A600FN, TWRP and GSI rom. When i wasn't have GSI rom, only things what don't work are Lock Screen and Knox required apps. But GSI rom doesn't fix lock screen :(
 

orlproi

Member
Oct 5, 2011
8
0
With the solution to the first post everything works then? (Fingerprints, MyBank, ecc.)
thank you
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hello Guyz any solution for rooting our beloved A600FN with Pie ?
    Thx in advance

    SOLVED :

    Verify first if KG state from your download mode is removed
    after that install TWRP TWRP-3.2.3-TwrpBuilder-a6ltexx-2018-11-26_20-43.tar from odin don't forget to tick off auto reboot
    restart on twrp (important don't let it boot to system)
    Wipe => format data and restart to Recovery
    Now install RMM_Bypass_v3_corsicanu.zip (do a search) and Magisk 19.3
    Reboot Sytem and its done !!!

    BIG thx to @corsicanu for bypass and @heni87 for giving us the solution !!! Dont forget to follow their work on https://t.me/A600X !!!
    1
    If anyone haven't still figured it out here's the solution, you need to remove KG state from your download mode by following some tedious steps. Once then you need to flash full stock pie followed by RMM bypass v3. Then everything works including fingerprint/pins/face unlock/samsung account.
    1
    Hello
    Before, I had root/TWRP, (Stock Oreo/Pie and others.., GSI everything…, many times!) for testing…
    So, I flash with odin official firmware:
    PDA A600FNXXS4BSF1
    CSC A600FNOGC4BSF1
    From: https://www.sammobile.com/samsung/galaxy-a6/firmware/SM-A600FN/OPV/download/A600FNXXS4BSF1/282141/
    The new android Pie starts up perfectly, everything works as it should!
    In Settings, in Developer options the OEM unlocking switch is set to "ON" (Bootloader already unlocked). Ok
    After starting the phone in bootloader mode, I have this message (among others):
    CURRENT BINARY: Samsung Official
    KG STATE: Prenormal
    FAP LOCK: OFF
    OEM LOCK: OFF
    Secure Download: Enable
    CARRIER_ID:
    WARRANTY VIOD: 1 (0x030c)
    AP SWREV: B:4 K:3 S:3
    0ID = 05b5ce4a5e34

    When I try flesh TWRP in Odin, I get red FAIL! Info, and a message on the phone:
    only official binaries are allowed to be flashed (recovery)
    Is there any chance to flash TWRP and root again?
    How to do it?
    Sorry to say this but you're already on U4 bootloader so it's too late now. Maybe you should wait till KG state prenormal vanish and then get root that's the best you could get right now.
    1
    Thank you for your response.
    It looks like I'm experiencing a new experience with a non-root device, at least for a while...
    I have no doubt that earlier, several times successfully fleshd TWRP via U4 bootloader. For example; for several days I had PA6 ROM for A6 installed on my current booatloader! It's a fact and somehow it was possible.
    I hope that the wait will change my KG status to normal after 7 days.
    Does anyone know how to check this from running android without restarting the phone? I'm asking, but it's probably not possible...
    For now, my Up Time is about 92h, so I have about 76h to wait (just over 3 days).
    After this period, I will try to restart the phone in bootloader mode. Then I will let you know if the KG status will become to normal and if whether TWRP flashing is possible.
    greetings
    You can't tell if KG state is vanished without entering download mode also afaik uptime doesn't matter unlike RMM. To get rid of KG state what you have to do is sign into your Samsung account then once it entered checking state you'll need to wait for to go away on it's own I DON'T KNOW FOR HOW LONG tho. In any case come at our telegram we can help you out more effectively there.