Question {Solved} Stuck on fastboot

Search This thread

Lycox

Senior Member
Oct 28, 2005
872
78
Redmi Note 10 Pro
Hey guys.

Yesterday, something weird happend.
I wanted to flash an update (kernel) so I powered off my phone and started it as usual to get into recovery. But the only thing it does, was to start up into fastboot mode.

I'm being able to boot the ROM with
"fastboot continue" when connected to th PC.


First, I thought the recovery was broken so I reflashed it. Nothing happend. Only fastboot mode.
Then reflashed magisk, in the hope it will solve my issue. Nothing. 😕

So what could it be? A broken boot.img? How could it be fixed? Still annoying 😒
 
yes. that did it. After that, I was being able to power on as usual but not being able to start recovery. not via TRWP or via Vol+Up + Power or even Advanced Reboot -> Recovery.
Ugh... Sorry I'm a but confused :(
So you flashed the recovery, booted into recovery via fastboot, and you could move around in the TWRP. Is my understanding correct?

Well if you don't have any data, nothing hurts to reinstall the ROM I guess😅
 

Lycox

Senior Member
Oct 28, 2005
872
78
Redmi Note 10 Pro
Ugh... Sorry I'm a but confused :(
So you flashed the recovery, booted into recovery via fastboot, and you could move around in the TWRP. Is my understanding correct?
I'm only able to boot into recovery via fastboot boot recovery.img as you mentioned (I guess it's loaded directly from my HD to the phone but doesn't stay there 🤔). Booting into recovery via Vol-Up+Power doesn't work anymore...
 
I'm only able to boot into recovery via fastboot boot recovery.img as you mentioned (I guess it's loaded directly from my HD to the phone but doesn't stay there 🤔). Booting into recovery via Vol-Up+Power doesn't work anymore...
Weird. Haven't encountered this in rn10pro. But something similar happened on my previous phone I remember and that time flashing recovery, booting into it, then restarting to recover had worked. You can give it a shot.
If not wait for a better answer or flash the ROM🙂
 

Lycox

Senior Member
Oct 28, 2005
872
78
Redmi Note 10 Pro
Weird. Haven't encountered this in rn10pro. But something similar happened on my previous phone I remember and that time flashing recovery, booting into it, then restarting to recover had worked. You can give it a shot.
If not wait for a better answer or flash the ROM🙂
Thx. Will test that tomorrow and will report back
 

Lycox

Senior Member
Oct 28, 2005
872
78
Redmi Note 10 Pro
Weird. Haven't encountered this in rn10pro. But something similar happened on my previous phone I remember and that time flashing recovery, booting into it, then restarting to recover had worked. You can give it a shot.
If not wait for a better answer or flash the ROM🙂
Didn't work. Always starts in fastboot. Already tried to flash twrp via twrp but didn't helped.

So I tried to flash my ROM again and that did the trick 🙂.
Phone boots normally and I'm able to boot into recovery via advanced restart and Vol-Up+Power.

Thank you guys, for trying to solve the issue.