[SOLVED] Unable to access with ADB/No RSA Fingerprint Key Window

Search This thread

postal302

Senior Member
Nov 21, 2013
110
70
Seattle
--Edit--
This is finally solved. There was a problem with my computer's ADB RSA key, so I simply had to delete the key file and rerun ADB and I Received the RSA Key Fingerprint window instantly on my G3.

For the full description of the problem look here:
I'm having issues trying to root my phone. I'm using the ioroot method mentioned here.

I get to "* daemon started successfully *" then nothing. After a lot of troubleshooting I know it's because my phone won't allow access by my computer. I never receive the RSA Fingerprint window allowing my computer access to my phone. Here's what all I've tried:

-Put phone into Internet>Ethernet mode (and I've also tried Internet>Modem, MTP and Camera modes as well just to say I did).
-Enable Developer Options and enable USB Debugging.
-Installed the drivers linked in the ioroot page (I've also downloaded the drivers directly from LG - believe it or not ... it's the same file).
-Installed the Verizon Software Assistant from the phone after connecting to the computer.
-Updated my ADB version with the SDK Manager.
-Used different USB ports on my computer as well as two different USB cables (one of which came with the G3).
-Checked Device Manager, all is as it should be and no unrecognized devices.

When I ran the adb server without the ioroot batch file, typing "adb devices" would return my phone's serial followed by "offline." It did this until I updated ADB; then when typing "adb devices" it would return the serial followed by "unauthorized." I've tried all various methods and combinations of switching adb debugging on and off, switching developer options on and off, installing and uninstalling and reinstalling the LG drivers, unplugging and replugging the USB cable, power-cycling all devices including myself at night, doing these methods with long pauses in between (10 minutes to ensure I wasn't being impatient), scratching my head, drinking more coffee, switching to rum and swearing at all devices but nothing seems to make a difference.

What am I missing?

I've got the Verizon LG G3 in White (LG-VS985W)
Software version VS98510B
Windows laptop running Vista 32 bit (I know I know, "eeew Vista")

I was able to obtain root using a different computer, here's what I tried with my laptop after gaining root to get it and my G3 on speaking terms:
-Deleted the ADB_Keys file on the G3 (/data/misc/adb/adb_key): no change.
-Compared running Windows services between Vista and 8.1 and started services which were running on 8.1 but not vista: no change.


Here was the resolution:
There turned out to be a problem with my laptop's ADB RSA key. I'm assuming my G3 was rejecting a bad key and disallowing my laptop to connect to it via ADB.

ADB saves a key file in one of multiple places on a Windows computer, the first is in the location where adb.exe is (C:\android), the second is in the user's profile (C:\Users\*username*\.android), the third place is in the Windows system files (C:\Windows\System32\config\systemprofile\.android), the file is simply named "adbkey" with no extension. If there is no key file when ADB runs, it will generate one automatically.

Mine was located in my user folder (C:\Users\*username*\.android\). All I had to do was delete the adbkey file (there was also a file named "adbkey.pub" which I deleted as well), restart the adb server in command prompt (adb start-server) and plug my phone in. I instantly received the RSA Fingerprint Key window on my G3 allowing connection between the two devices. Then typing "adb devices" returned my phone's serial number followed by "device" showing it was available. I went back to the C:\Users\*username*\.android\ folder and sure enought there were new "adbkey" and "adbkey.pub" files.

Problem finally fixed!

Here are some VERY useful links which helped me come to this fix:
How ADB enables a secure connection
Reconstructing ADB's RSA key file
 
Last edited:

markfm

Senior Member
Mar 27, 2013
466
159
Try using this set of Vertizon g3 drivers: https://mega.co.nz/#!58YHAZaQ!yNlgZG1m7toHBZp_0HF1jSQ66gMoZmmiDrNq9W5aJIc

Open the .zip, run the .msi file on Windows.

I do not run the G3's auto-install software when I plug it into the PC.

I do set the G3 to "PTP" USB before initially connecting to the PC.

The adb file in the ioroot "bts" subfolder should be okay to run on Windows.

When the phone is attached to the PC, change its USB connection type to Internet, with submenu type Ethernet. At least on my phone, right when I change the phone connection to Internet/Ethernet is when I get the phone popup to accept the PC's RSA fingerprint.

If I then run "adb devices" on my PC, I'll see the random ID followed by "attached", which means I have a good connection. If this doesn't happen, unplug, then replug, the USB connection at the PC side.

Then I can "cd .." and run ioroot.bat.

Good luck!
 
Last edited:

postal302

Senior Member
Nov 21, 2013
110
70
Seattle
Try using this set of Vertizon g3 drivers: https://mega.co.nz/#!58YHAZaQ!yNlgZG1m7toHBZp_0HF1jSQ66gMoZmmiDrNq9W5aJIc

Open the .zip, run the .msi file on Windows.

I do not run the G3's auto-install software when I plug it into the PC.

I do set the G3 to "PTP" USB before initially connecting to the PC.

The adb file in the ioroot "bts" subfolder should be okay to run on Windows.

When the phone is attached to the PC, change its USB connection type to Internet, with submenu type Ethernet. At least on my phone, right when I change the phone connection to Internet/Ethernet is when I get the phone popup to accept the PC's RSA fingerprint.

If I then run "adb devices" on my PC, I'll see the random ID followed by "attached", which means I have a good connection. If this doesn't happen, unplug, then replug, the USB connection at the PC side.

Then I can "cd .." and run ioroot.bat.

Good luck!

... no dice.

Ok, I'm switching to my Windows 8.1 machine (my laptop is my server and android-dirty-work machine).
 

postal302

Senior Member
Nov 21, 2013
110
70
Seattle
So it worked without hesitation on my 8.1 machine. I used the drivers listed in the ioroot thread (same as the drivers from LG) and the process went off without a hitch. I have no idea why my Vista machine and G3 don't get along but I'll need to figure it out when I do further adb work because I use my laptop for that.

Thank you markfm for the extra drivers.

I'll call this solved for now but if I find out further reasons why it didn't work I'll post it here for others who have similar struggles.
 

postal302

Senior Member
Nov 21, 2013
110
70
Seattle
Ok I finally solved this. It turned out there was something wrong with my laptop's ADB RSA key. All I had to do was delete the key file, run the ADB Server and connect the phone. ADB will automatically generate an RSA key if none exists. The RSA key was located in C:\Users\*username*\.android and was simply named "adbkey" with no extension. There was also a file named adbkey.pub (Microsoft Publisher) which I'm assuming is a viewable version of the key. I deleted both of these, re-ran the ADB server and voila I instantly received the RSA Key Fingerprint confirmation window on my G3.

Done and done!
 
  • Like
Reactions: WhiteEVO

scooterd

Member
Dec 2, 2012
20
2
Palos Park, IL
unable to generate RSA key on my MCB

I've read and re-read all the entries addressing this issue. I have a black G3 and am using a 2013 Mac Book Pro. I've followed the instructions to the letter many times but with no success. I'm at a loss. Any ideas would be greatly appreciated.
 

postal302

Senior Member
Nov 21, 2013
110
70
Seattle
I've read and re-read all the entries addressing this issue. I have a black G3 and am using a 2013 Mac Book Pro. I've followed the instructions to the letter many times but with no success. I'm at a loss. Any ideas would be greatly appreciated.

You'll have to bear with me because I'm not familiar with Mac file structure.

I would start from scratch. Do all these before trying to run adb again.
On your computer:
-Delete adbkey & adbkey.pub from the .android folder (I'm not sure where that is on a Mac, Home\.android?).
-I'm not sure if Macs have a device manager, but check that your phone is correctly recognized and the drivers are installed properly.
On your phone:
-Ensure you've got developer features unlocked
-Double check that you've got usb debugging enabled.
-Tap the "Revoke USB Debugging Authorizations" button below USB debugging in developer options.
-When you're plugged in be sure to set your connection to Internet >>Ethernet (you'll see the debugging icon in the notification bar if it's connected right).

I know a lot of that is basic and redundant but if it's all done correctly then it should work. If it doesn't work it gives us a good starting point to troubleshoot.

If you want to test it open terminal, change directory to the bts folder in the ioroot folder and start adb (adb start-server), with everything done right you should get the rsa window on your phone right now. Type "adb devices" and see what comes back.
 

scooterd

Member
Dec 2, 2012
20
2
Palos Park, IL
Thanks for the assistance. I never could get anywhere with my MBP so I used Windows. I downloaded the drivers and got the RSA key after revoking all prior authorizations. However, but my computer still won't see my G3 in internet/usb debugging mode. It reads it in MTP, PTP and USB charge mode. But that's it. I've rooted numerous phones before, mostly Samsung, but this one has me stumped. Any ideas?
 

postal302

Senior Member
Nov 21, 2013
110
70
Seattle
Thanks for the assistance. I never could get anywhere with my MBP so I used Windows. I downloaded the drivers and got the RSA key after revoking all prior authorizations. However, but my computer still won't see my G3 in internet/usb debugging mode. It reads it in MTP, PTP and USB charge mode. But that's it. I've rooted numerous phones before, mostly Samsung, but this one has me stumped. Any ideas?

Use whatever mode will enable USB Debugging. If Internet>>Ethernet doesn't work then use any other mode that will. It's not necessarily important what mode your phone is in, but what mode will allow USB Debugging. If you have it in MTP, PTP, Camera or any other, and you have the USB Debugging icon in the notification bar, try the "adb devices" command and if it returns "*serial* device" then you should be good to go to root.

Once your phone has enabled USB Debugging and accepted the RSA key from your computer then the connection is made and your phone will accept the ioroot commands.
 

postal302

Senior Member
Nov 21, 2013
110
70
Seattle
Thanks for the assistance. I never could get anywhere with my MBP so I used Windows. I downloaded the drivers and got the RSA key after revoking all prior authorizations. However, but my computer still won't see my G3 in internet/usb debugging mode. It reads it in MTP, PTP and USB charge mode. But that's it. I've rooted numerous phones before, mostly Samsung, but this one has me stumped. Any ideas?

Is your phone a Verizon Model (VS985)? I'm assuming not because I don't have PTP mode on my G3. If it's not Verizon, the ioroot method suggests using PTP mode.
 
  • Like
Reactions: SkilesAwaRz

scooterd

Member
Dec 2, 2012
20
2
Palos Park, IL
Yes it is a Verizon VS985. I bought it last week. I have four options, charge, MTP, internet and PTP when I connect my phone to the PC. I get usb debugging under either ethernet or modem. Device Manegr sees my phone and I get the RSA key. I never get a terminal which let's me know something isn't right. This is truly weird but I won't give up. I'll start over and see what happens. Again, thanks for your patience.
 

postal302

Senior Member
Nov 21, 2013
110
70
Seattle
Yes it is a Verizon VS985. I bought it last week. I have four options, charge, MTP, internet and PTP when I connect my phone to the PC. I get usb debugging under either ethernet or modem. Device Manegr sees my phone and I get the RSA key. I never get a terminal which let's me know something isn't right. This is truly weird but I won't give up. I'll start over and see what happens. Again, thanks for your patience.

No problem at all, happy to help! It sounds like you have everything set up properly, however the terminal doesn't open automatically (you need to do it manually). But you shouldn't need to open the terminal to get ioroot to work, after you've unzipped the ioroot.zip file, simply navigate to the ioroot folder, right-click on ioroot.bat and choose Run as Administrator. That should run through the entire process for you.

If you want to test your adb connection (testing not required for ioroot to work) you'll need to open the command prompt manually. Press Windows Key+R, in the run window, type cmd and press enter, this will open the command prompt. When you're in the command prompt, you'll need to change directory to the location of adb.exe in the bts folder inside the ioroot folder. Mine was in a folder named android on my C drive so the address looked something like this: C:\android\ioroot\bts the command you'll type in command prompt would be: cd C:\android\ioroot\bts then press enter. Then you can type adb devices and see if you're connected properly.
 

scooterd

Member
Dec 2, 2012
20
2
Palos Park, IL
Okay. Here's where we are. I did everything you suggested. I got the RSA key and the G3 went into recovery mode. I toggeld down to the appropriate command and hit the power button. The little green guy fell over with the dreaded red triange and I got the message "This version of ioroot does not support your device/firmware combo. Please downgrade to previously supported software version. My G3 is running VS98510B. I can't post in the devlopment section but wonder if a software update prevents root the the version being used. Just a question but at least I know I'm not going crazy.

---------- Post added at 04:33 PM ---------- Previous post was at 03:46 PM ----------

Okay. Here's where we are. I did everything you suggested. I got the RSA key and the G3 went into recovery mode. I toggeld down to the appropriate command and hit the power button. The little green guy fell over with the dreaded red triange and I got the message "This version of ioroot does not support your device/firmware combo. Please downgrade to previously supported software version. My G3 is running VS98510B. I can't post in the devlopment section but wonder if a software update prevents root the the version being used. Just a question but at least I know I'm not going crazy.

You sir are a genious. After changing my USB cord, I'm rooted and all is well in the world. It's always the little things that matter
 

jerdos

New member
Jan 5, 2015
1
0
Is your phone a Verizon Model (VS985)? I'm assuming not because I don't have PTP mode on my G3. If it's not Verizon, the ioroot method suggests using PTP mode.


Hi, hope this thread is somewhat still alive. sorry for the late add on... please help.

Sorry I'm a complete moron when it comes to rooting and ADB / RSA stuff and have no idea what exactly i am doing but for some reason my macbook won't allow me to authorize my oneplus. the authorize computer dialog box never pops up however i get a notification when my phone is plugged in that debugging is active. developer options have been reset, multiple usb cables have been used, and authorization has been revoked multiple times as well.

Im not sure how to access my adb settings on mac and when i attempt to go into terminal and try kill-server / start-server commands i get error messages as commands are not recognized.

Any help is appreciated as i can no longer use stock rom on OPO and i can't go about rooting my device
 

Jesusmaryqueen

New member
Mar 26, 2015
2
0
Same here! WITH NEXUS 7

Tried all the methods and spent almost 20hrs experimenting to retrieve rsa fingerprint, but in vain:confused:
Can you please suggest any remedy?
I cant install any os and unfortunately, my status bar and softkeys disappeared after using softkeyz apk...Dont tell to delete dalvaik data and cache[ it didnt work]
Please...
 

neoarcher7

New member
Nov 24, 2014
1
0
Tried all the methods and spent almost 20hrs experimenting to retrieve rsa fingerprint, but in vain:confused:
Can you please suggest any remedy?
I cant install any os and unfortunately, my status bar and softkeys disappeared after using softkeyz apk...Dont tell to delete dalvaik data and cache[ it didnt work]
Please...

It is also possible to overcome the situation, by installing Mobilego software on your PC and follow the instructions accordingly (connecting your android using usb & debugging etc,.). You will get a RSA fingerprint request.. Easy :) Once it's done, u can close the mobilego software in the PC and open someother software for example Bacon root toolkit for oneplus one etc etc..:) Hope this helps
 

AliffanI

Member
Sep 21, 2016
9
2
adbkey doesn't exist

I don't know what i did wrong before, but my computer just DOES NOT have adbkey and adbkey.pub anywhere! First, i thought it was my phone's fault. Then, i tested in a different pc, and it worked. How do i generate those keys? There are no helpful answers in the internet yet... :(
 

Top Liked Posts

  • There are no posts matching your filters.
  • 18
    --Edit--
    This is finally solved. There was a problem with my computer's ADB RSA key, so I simply had to delete the key file and rerun ADB and I Received the RSA Key Fingerprint window instantly on my G3.

    For the full description of the problem look here:
    I'm having issues trying to root my phone. I'm using the ioroot method mentioned here.

    I get to "* daemon started successfully *" then nothing. After a lot of troubleshooting I know it's because my phone won't allow access by my computer. I never receive the RSA Fingerprint window allowing my computer access to my phone. Here's what all I've tried:

    -Put phone into Internet>Ethernet mode (and I've also tried Internet>Modem, MTP and Camera modes as well just to say I did).
    -Enable Developer Options and enable USB Debugging.
    -Installed the drivers linked in the ioroot page (I've also downloaded the drivers directly from LG - believe it or not ... it's the same file).
    -Installed the Verizon Software Assistant from the phone after connecting to the computer.
    -Updated my ADB version with the SDK Manager.
    -Used different USB ports on my computer as well as two different USB cables (one of which came with the G3).
    -Checked Device Manager, all is as it should be and no unrecognized devices.

    When I ran the adb server without the ioroot batch file, typing "adb devices" would return my phone's serial followed by "offline." It did this until I updated ADB; then when typing "adb devices" it would return the serial followed by "unauthorized." I've tried all various methods and combinations of switching adb debugging on and off, switching developer options on and off, installing and uninstalling and reinstalling the LG drivers, unplugging and replugging the USB cable, power-cycling all devices including myself at night, doing these methods with long pauses in between (10 minutes to ensure I wasn't being impatient), scratching my head, drinking more coffee, switching to rum and swearing at all devices but nothing seems to make a difference.

    What am I missing?

    I've got the Verizon LG G3 in White (LG-VS985W)
    Software version VS98510B
    Windows laptop running Vista 32 bit (I know I know, "eeew Vista")

    I was able to obtain root using a different computer, here's what I tried with my laptop after gaining root to get it and my G3 on speaking terms:
    -Deleted the ADB_Keys file on the G3 (/data/misc/adb/adb_key): no change.
    -Compared running Windows services between Vista and 8.1 and started services which were running on 8.1 but not vista: no change.


    Here was the resolution:
    There turned out to be a problem with my laptop's ADB RSA key. I'm assuming my G3 was rejecting a bad key and disallowing my laptop to connect to it via ADB.

    ADB saves a key file in one of multiple places on a Windows computer, the first is in the location where adb.exe is (C:\android), the second is in the user's profile (C:\Users\*username*\.android), the third place is in the Windows system files (C:\Windows\System32\config\systemprofile\.android), the file is simply named "adbkey" with no extension. If there is no key file when ADB runs, it will generate one automatically.

    Mine was located in my user folder (C:\Users\*username*\.android\). All I had to do was delete the adbkey file (there was also a file named "adbkey.pub" which I deleted as well), restart the adb server in command prompt (adb start-server) and plug my phone in. I instantly received the RSA Fingerprint Key window on my G3 allowing connection between the two devices. Then typing "adb devices" returned my phone's serial number followed by "device" showing it was available. I went back to the C:\Users\*username*\.android\ folder and sure enought there were new "adbkey" and "adbkey.pub" files.

    Problem finally fixed!

    Here are some VERY useful links which helped me come to this fix:
    How ADB enables a secure connection
    Reconstructing ADB's RSA key file
    3
    Try using this set of Vertizon g3 drivers: https://mega.co.nz/#!58YHAZaQ!yNlgZG1m7toHBZp_0HF1jSQ66gMoZmmiDrNq9W5aJIc

    Open the .zip, run the .msi file on Windows.

    I do not run the G3's auto-install software when I plug it into the PC.

    I do set the G3 to "PTP" USB before initially connecting to the PC.

    The adb file in the ioroot "bts" subfolder should be okay to run on Windows.

    When the phone is attached to the PC, change its USB connection type to Internet, with submenu type Ethernet. At least on my phone, right when I change the phone connection to Internet/Ethernet is when I get the phone popup to accept the PC's RSA fingerprint.

    If I then run "adb devices" on my PC, I'll see the random ID followed by "attached", which means I have a good connection. If this doesn't happen, unplug, then replug, the USB connection at the PC side.

    Then I can "cd .." and run ioroot.bat.

    Good luck!
    3
    I don't know what i did wrong before, but my computer just DOES NOT have adbkey and adbkey.pub anywhere! First, i thought it was my phone's fault. Then, i tested in a different pc, and it worked. How do i generate those keys? There are no helpful answers in the internet yet... :(

    Having same problem.
    Managego software isnt causing the RSA request to pop up either.
    I am unable to get an RSA popup request on my S4 or my Google Pixel, but I am able to get it on my S7. What gives?
    All 3 devices work on another computer I have with no issues. Therefore, this issue is computer specific. This is the best help I can offer to help us narrow down the root cause.
    There are no files on my computer to delete (adbkey and adbkey.pub) my android folder is empty. what gives?

    Anyone able to answer this question? there are still many folks searching the forums with this exact problem with RSA key and finding no success.

    SOLVED!!!

    Surprised I got this working so quickly after posting, especially after trying to get this fixed for months.

    I removed a user variable in windows environment:
    click START -> right click COMPUTER -> click ADVANCED SYSTEM SETTINGS in the left margin -> click ENVIRONMENT VARIABLES
    In the user variables section, delete the user variable with the value pointing to your android folder (for me it was C:\ Android). I had this location created when i first tried installing an older version of ADB. I later read that you could delete the RSA key (which was save in this directory) in order to get your phone to re-request RSA authorization (which is exactly what people here are trying to do). I deleted the adbkey and adbkey.pub files, but still could not get my phone to re-request RSA authorization. I then deleted the android folder itself (C:\Android). This did not solve the issue either. THEN, I DELETED THE USER VARIABLE WITH THE VALUE C:\ANDROID AS DESCRIBED. I restarted my computer and my S4 requested the RSA authorization and I am able to perform ADB communications.

    You can also reinstall your phone drivers if this doesn't quite help. I did both.
    You can do this through device manager, or by clicking start -> devices and printers -> right click your device -> click the hardware tab -> go through each function in the device function box and click properties -> driver -> uninstall. Reboot your computer. If windows does not auto-install your drivers, download the latest manufacture drivers and install them.

    Between these two steps, i was FINALLY able to get my s4 to display the pop up for RSA authorization

    If this helped you please hit thanks so I know I was able to help! Good luck guys and gals!! I know how painful this is, it took me trying on and off for months!!! :eek:
    1
    Ok I finally solved this. It turned out there was something wrong with my laptop's ADB RSA key. All I had to do was delete the key file, run the ADB Server and connect the phone. ADB will automatically generate an RSA key if none exists. The RSA key was located in C:\Users\*username*\.android and was simply named "adbkey" with no extension. There was also a file named adbkey.pub (Microsoft Publisher) which I'm assuming is a viewable version of the key. I deleted both of these, re-ran the ADB server and voila I instantly received the RSA Key Fingerprint confirmation window on my G3.

    Done and done!
    1
    Thanks for the assistance. I never could get anywhere with my MBP so I used Windows. I downloaded the drivers and got the RSA key after revoking all prior authorizations. However, but my computer still won't see my G3 in internet/usb debugging mode. It reads it in MTP, PTP and USB charge mode. But that's it. I've rooted numerous phones before, mostly Samsung, but this one has me stumped. Any ideas?

    Is your phone a Verizon Model (VS985)? I'm assuming not because I don't have PTP mode on my G3. If it's not Verizon, the ioroot method suggests using PTP mode.