[SOLVED] Z1 not showing up in Linux ADB devices

Search This thread

EggZenBeanz

Senior Member
Jul 21, 2005
289
92
hi,

trying to flash the breadcrust recovery using my linux pc, but the Z1 doesn't appear in the list of devices when running adb devices. Image attached. Normally I would get a request to accept the RSA key for a trusted pc when enabling usb debug. But I don't get this option.

- Adb tools are loaded and working on my linux laptop
- My nexus 7 responds to ADB devices and shows up ok
- tried on wifes windows laptop with adb/sdk tools loaded and no joy there too
- i have developer USB debug options enabled, i've tripple checked this

could it be the cable? I'm using the one which came with the phone, so that should be ok?!!

cheers

SOLUTION - I ran this One Plus Two script modified with the Z1 device ID and now I can see my device in adb devices and interact with it. I get the SHA screen to allow access and can run commands from linux terminal. YAY!

See the attachments for script.
 

Attachments

  • IMG_20151115_120549.jpg
    IMG_20151115_120549.jpg
    236.6 KB · Views: 1,930
  • ZUK_adb_config_Linux_OSX.sh.tar.gz
    518 bytes · Views: 1,714
Last edited:

MKKLR21

Senior Member
Aug 8, 2013
306
134
ADB doesn't work for me, too. I work around this problem by booting into recovery (simultaneously press Vol+ and Vol- and Power until phone vibrates) and choose "Boot to bootloader" from there. After rooting I installed "Power Toggles" from Play Store and use the toggle to reboot to recovery or bootloader.
By the way, when I boot into recovery, I'm able to ADB sideload. So I don't think there's a driver issue.
 
  • Like
Reactions: gerstavros

EggZenBeanz

Senior Member
Jul 21, 2005
289
92
ADB doesn't work for me, too. I work around this problem by booting into recovery (simultaneously press Vol+ and Vol- and Power until phone vibrates) and choose "Boot to bootloader" from there. After rooting I installed "Power Toggles" from Play Store and use the toggle to reboot to recovery or bootloader.
By the way, when I boot into recovery, I'm able to ADB sideload. So I don't think there's a driver issue.
Good tip - I'll give it a go.

My nexus 7 works as expected on all PCs and laptops Linux/windows so it must be the phone


Sent from my Nexus 7 using Tapatalk
 

Klanac89

Senior Member
Sep 30, 2014
637
134
Maybe sudo or check this:
http://1.bp.blogspot.com/-rDdBnJTh870/U-hxVzxMf3I/AAAAAAAAKwQ/WrZkaMjaReo/s1600/Unlock-Bootloader-linux-terminal-xperia-z.png[img/]
Source: [url]http://linuxwelt.blogspot.de/2014/08/cyanogenmod-unter-linux-installieren.html[/url]
 

EggZenBeanz

Senior Member
Jul 21, 2005
289
92
ok some progress.....

got the trusted device RSA screen to appear on my wifes windows pc. i could then run adb devices and see the device.

I could run adb reboot bootloader, but the device doesn't boot into fastboot, just reboots as normal!

I could also hold down up/down volume buttons and get into the bootloader, but again the device isn't picked by any fastboot oem checks for unlocking!!

arrrgh!!!
 

MKKLR21

Senior Member
Aug 8, 2013
306
134
You'll have to add -i switch followed by the device ID to your fastboot command. I don't have it at hand, so just read the TWRP thread.
 

EggZenBeanz

Senior Member
Jul 21, 2005
289
92
ok! Some progress...ish.

running "adb reboot bootloader"command in windows worked when I switched Cyanogen recovery updates off in developer options. The Z1 reboots into bootloader.

Running "fastboot -i 0x2b4c oem get-device-info" returns nothing just "....."

So I tried "fastboot -i 0x2b4c oem unlock" an error returns cannot unlock use command "fastboot -i 0x2b4c oem unlock-go" which works. The phone wipes data and reboots back into OS.

I re-enable the developer options and adb debug. and reboot into bootloader

Run "fastboot -i 0x2b4c flash recovery z1.twrp.2.8.7.0.By.Breadcrust-UPDATE3.img" - some time stats are retunred and OKAY message. But when I boot into recovery it's still the cyanogen stock recovery. not TWRP.

weird!
 

othe01

Member
Sep 17, 2015
48
13
Your commands are simply wrong, thats why they don´t work.

It is:
fastboot -i 0x2b4c oem device-info
fastboot -i 0x2b4c oem unlock-go

Run "fastboot -i 0x2b4c flash recovery z1.twrp.2.8.7.0.By.Breadcrust-UPDATE3.img" - some time stats are retunred and OKAY message. But when I boot into recovery it's still the cyanogen stock recovery. not TWRP.

Flashing does NOT work on the international version, you have to boot into it directly from fastboot.

fastboot -i 0x2b4c boot z1.twrp.2.8.7.0.By.Breadcrust-UPDATE3.img

Should be correct instead of the flash command.
 

johnyboo

Senior Member
Jul 26, 2010
79
1
ok some progress.....
got the trusted device RSA screen to appear on my wifes windows pc. i could then run adb devices and see the device.
I could run adb reboot bootloader...
...

What made the change? I was able to see the RSA screen only once, but after device restored to defaults I can't get it back. same drivers installed, and it appears in the device manager.
 

EggZenBeanz

Senior Member
Jul 21, 2005
289
92
I honestly don't know, it just worked after many attempts. I read somewhere about USB 3 ports with Linux so might be the same for windows?

Sent from my Z1 using Tapatalk
 

MrColdbird

Senior Member
Nov 25, 2011
1,178
2,195
www.black-seraph.com
It's an USB 3.0 issue. Plug the phone into an USB 2.0 port, or an USB 2.0 hub plugged into an USB 3.0 port and it will magically start working. God knows why this is the case...

Ironically, fastboot works fine even on USB 3.0...
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    This did the trick on Linux (Ubuntu):

    - run on terminal "sudo gedit ~/.android/adb_usb.ini"
    - put "0x2b4c" in
    - run on terminal "adb kill-server" and "adb start-server"

    And run the fastboot commands with "sudo".
    2
    hi,

    trying to flash the breadcrust recovery using my linux pc, but the Z1 doesn't appear in the list of devices when running adb devices. Image attached. Normally I would get a request to accept the RSA key for a trusted pc when enabling usb debug. But I don't get this option.

    - Adb tools are loaded and working on my linux laptop
    - My nexus 7 responds to ADB devices and shows up ok
    - tried on wifes windows laptop with adb/sdk tools loaded and no joy there too
    - i have developer USB debug options enabled, i've tripple checked this

    could it be the cable? I'm using the one which came with the phone, so that should be ok?!!

    cheers

    SOLUTION - I ran this One Plus Two script modified with the Z1 device ID and now I can see my device in adb devices and interact with it. I get the SHA screen to allow access and can run commands from linux terminal. YAY!

    See the attachments for script.
    2
    Your commands are simply wrong, thats why they don´t work.

    It is:
    fastboot -i 0x2b4c oem device-info
    fastboot -i 0x2b4c oem unlock-go

    Run "fastboot -i 0x2b4c flash recovery z1.twrp.2.8.7.0.By.Breadcrust-UPDATE3.img" - some time stats are retunred and OKAY message. But when I boot into recovery it's still the cyanogen stock recovery. not TWRP.

    Flashing does NOT work on the international version, you have to boot into it directly from fastboot.

    fastboot -i 0x2b4c boot z1.twrp.2.8.7.0.By.Breadcrust-UPDATE3.img

    Should be correct instead of the flash command.
    2
    For those having adb problem in windows 10: this morning, a spanish user, Pts1897 posted in htcmania.com, the spanish forum, a way he found to be working in windows 10 to make your PC recognize our z1 in adb mode. I only translate his words:

    1. Go to control panel / Hardware and Sound / Device Manager.
    2. Go to Universal serial bus controllers and find your phone (I do it by unplugging and plugging the phone back to the PC).
    3. Right click on the device and go to "Properties".
    4. Go to "Details" tab and find Hardware Id. You will find something like:
    Code:
    USB\VID_24BC&PID_1005&REV_0232
    5. We will only need what is between "VID_" and the first "&". In this case, it would be "24BC". Copy it.
    6. After that, paste the copied text (check the number in bold) in a new notepad document this way:
    Code:
    # ANDROID 3RD PARTY USB VENDOR ID LIST -- DO NOT EDIT.
    # USE 'android update adb' TO GENERATE.
    # 1 USB VENDOR ID PER LINE.
    
    0x[B]24BC[/B]
    7. Then, save the notepad document as adb_usb.ini in Windows (C:) / Users / YOURNAME / .android.

    I didn't test it yet, but today I will. All the credits are for him, and not for me.

    I really hope it helps,

    Cheers
    1
    ADB doesn't work for me, too. I work around this problem by booting into recovery (simultaneously press Vol+ and Vol- and Power until phone vibrates) and choose "Boot to bootloader" from there. After rooting I installed "Power Toggles" from Play Store and use the toggle to reboot to recovery or bootloader.
    By the way, when I boot into recovery, I'm able to ADB sideload. So I don't think there's a driver issue.