• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Sprint GM1925 Stock ROM

Search This thread

aktiv8d

Member
Mar 27, 2009
26
4
I've tried to restore to Stock using a few of the different ROM's from the Android File Host site, but I'm constantly stuck in a revolving Fastboot mode.

The Sprint bootloader unlock here worked fine:
https://forum.xda-developers.com/on...otloader-unlock-sprint-oneplus-7-pro-t4042145
At one point I had the TWRP zip installed and working fine, so I'm not sure why I can't reboot to recovery anymore. It always boots to fastboot.

I've also tried ADB commands to run from a different slot (A/B/Other). Both slots produce this error when trying to flash the twrp.img to either slot:
FAILED (remote: Failed to load/authenticate boot image: Load Error)

Any ideas are appreciated. I thought all the Stock ROMs provided work for all variants. My phone connects successfully with TOOL_ALL_IN_ONE, and flashing a Stock image seems successful, but the phone reverts back to Fastboot loop.

Edit: I tried the Guac for All unbrick tool and method specified here:
https://forum.xda-developers.com/oneplus-7-pro/how-to/msm-tool-guac-t3934691
I made sure to install the L2 drivers certificate and use the original cable that came with my phone in a USB 2.0 port. However, on the last MSM Tool's Status of Communication called Param Preload, I get an error that says Device does not match image. I'm guessing the Guac for All tool has a unified ROM, but it doesn't seem to work for my SM1925 (Sprint). I'll keep trying other methods and updating.
 
Last edited:

Whoareyou

Senior Member
Jul 7, 2010
2,057
633
Olathe, KS
Motorola Razr 5G
I've tried to restore to Stock using a few of the different ROM's from the Android File Host site, but I'm constantly stuck in a revolving Fastboot mode.

The Sprint bootloader unlock here worked fine:
https://forum.xda-developers.com/on...otloader-unlock-sprint-oneplus-7-pro-t4042145
At one point I had the TWRP zip installed and working fine, so I'm not sure why I can't reboot to recovery anymore. It always boots to fastboot.

I've also tried ADB commands to run from a different slot (A/B/Other). Both slots produce this error when trying to flash the twrp.img to either slot:
FAILED (remote: Failed to load/authenticate boot image: Load Error)

Any ideas are appreciated. I thought all the Stock ROMs provided work for all variants. My phone connects successfully with TOOL_ALL_IN_ONE, and flashing a Stock image seems successful, but the phone reverts back to Fastboot loop.

Edit: I tried the Guac for All unbrick tool and method specified here:
https://forum.xda-developers.com/oneplus-7-pro/how-to/msm-tool-guac-t3934691
I made sure to install the L2 drivers certificate and use the original cable that came with my phone in a USB 2.0 port. However, on the last MSM Tool's Status of Communication called Param Preload, I get an error that says Device does not match image. I'm guessing the Guac for All tool has a unified ROM, but it doesn't seem to work for my SM1925 (Sprint). I'll keep trying other methods and updating.
https://androidfilehost.com/?fid=4349826312261604268

Flash this, install the 9.5.17 ota and try to re-unlock
 
  • Like
Reactions: Ziarc

aktiv8d

Member
Mar 27, 2009
26
4
https://androidfilehost.com/?fid=4349826312261604268

Flash this, install the 9.5.17 ota and try to re-unlock

Thank you so much for your help. I followed your instructions exactly.

After the MSM Tool's flash with the image provided, it no longer fastboot cycled and booted normally to 9.5.12. It paused on the 5G logo for a couple mins and then loaded into the phone setup screen. I think updated to 9.15.17 ota as instructed. Everything is now working properly.

Can I ask where you found this version of the MSM tool's stock image that works for the GM1925? I searched and searched, but couldn't find anything. Even searching for that zip's filename returned 0 results for me. I saved that file, but if new compatible stock ROM's are released, I'd like to be able to find them, too.
 

Whoareyou

Senior Member
Jul 7, 2010
2,057
633
Olathe, KS
Motorola Razr 5G
Thank you so much for your help. I followed your instructions exactly.

After the MSM Tool's flash with the image provided, it no longer fastboot cycled and booted normally to 9.5.12. It paused on the 5G logo for a couple mins and then loaded into the phone setup screen. I think updated to 9.15.17 ota as instructed. Everything is now working properly.

Can I ask where you found this version of the MSM tool's stock image that works for the GM1925? I searched and searched, but couldn't find anything. Even searching for that zip's filename returned 0 results for me. I saved that file, but if new compatible stock ROM's are released, I'd like to be able to find them, too.
They're only sent out by OnePlus when someone needs to restore their phone due to malfunction, not released on any regular basis, but this one has been around for a while.
 

mimat1

New member
Mar 15, 2017
1
0
Hi, I am in the exact same position as you were. I downloaded the .rar file provided, but how do I flash it?
Thanks!

---------- Post added at 03:51 AM ---------- Previous post was at 03:37 AM ----------

Hi, I am in the exact same position as you were. I downloaded the .rar file provided, but how do I flash it?
Thanks!

UPDATE: I flashed it by starting the MSMDownloader while in EDL mode. Much thanks for this method and fix. My phone thanks you for revival!
 

Narwhal73

Senior Member
Oct 22, 2012
304
90
Waterloo, ON
krourke.org
Ok so for future people who run into the same problem and are clueless like me! The RAR file contains the system image and an MSM Tool. Unrar it, open the tool, put your phone in EDL mode, make sure the tool recognizes the device, then click "start".


Cheers!


Alright, sorry for hijacking this thread... It seems like after flashing this image, the phone has been SIM locked to Sprint?! I purchased this phone unlocked, and it was working with Public Mobile prior to trying to unlock the bootloader. @Whoareyou any advice?

---------- Post added at 07:36 PM ---------- Previous post was at 07:22 PM ----------

Alright, sorry for hijacking this thread... It seems like after flashing this image, the phone has been SIM locked to Sprint?! I purchased this phone unlocked, and it was working with Public Mobile prior to trying to unlock the bootloader. @Whoareyou any advice?


Ok, I was really spooked by the Android 9 ROM saying my device was SIM locked when I bought it unlocked.
On point with answering my own questions: applying the OTA update now shows that my phone is unlocked (as it should be!) under Settings > System updates > UICC unlock.
 

schn1tt3r

Senior Member
May 11, 2013
259
30
My phone always reboots to fastboot. I've opened MSM tool and my phone doesn't appear there. It does appear using fastboot devices command on CMD though. How can I flash this? Restart recovery or restart bootloader does nothing, always back to fastboot.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I've tried to restore to Stock using a few of the different ROM's from the Android File Host site, but I'm constantly stuck in a revolving Fastboot mode.

    The Sprint bootloader unlock here worked fine:
    https://forum.xda-developers.com/on...otloader-unlock-sprint-oneplus-7-pro-t4042145
    At one point I had the TWRP zip installed and working fine, so I'm not sure why I can't reboot to recovery anymore. It always boots to fastboot.

    I've also tried ADB commands to run from a different slot (A/B/Other). Both slots produce this error when trying to flash the twrp.img to either slot:
    FAILED (remote: Failed to load/authenticate boot image: Load Error)

    Any ideas are appreciated. I thought all the Stock ROMs provided work for all variants. My phone connects successfully with TOOL_ALL_IN_ONE, and flashing a Stock image seems successful, but the phone reverts back to Fastboot loop.

    Edit: I tried the Guac for All unbrick tool and method specified here:
    https://forum.xda-developers.com/oneplus-7-pro/how-to/msm-tool-guac-t3934691
    I made sure to install the L2 drivers certificate and use the original cable that came with my phone in a USB 2.0 port. However, on the last MSM Tool's Status of Communication called Param Preload, I get an error that says Device does not match image. I'm guessing the Guac for All tool has a unified ROM, but it doesn't seem to work for my SM1925 (Sprint). I'll keep trying other methods and updating.
    https://androidfilehost.com/?fid=4349826312261604268

    Flash this, install the 9.5.17 ota and try to re-unlock