• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[STICKY] I9505G GE GALAXY S IV ( INDEX ) ROM's / LINKS / HOW TO THREAD

Do you think that the I9505G deserves its own Forum

  • Yes

    Votes: 293 86.7%
  • No

    Votes: 45 13.3%

  • Total voters
    338
Search This thread

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
Welcome to the [STICKY] I9505G GE GALAXY S IV ( INDEX ) ROM's / LINKS / HOW TO THREAD formally the DISCUSSION GUIDE

This is the Official Index Roll up thread for the I9505G Google Edition Galaxy S IV. In this Index you will find helpful, links, guides, how to's and instructions for your I9505G.​

Please Post any links or helpful information in this thread or you can PM me so I can link it in the OP ( If your on the I9505/I9500 Please do NOT ASK about development for your device this is for the I9505G ONLY


(DISCLAIMER) As always I nor anyone is responsible if you cannot follow instructions in this or any other thread. We assume NO liability for bricks, loss of job, or the end of life as we know it.


GUIDES & LINKS

How to get CM 10.1 & CM 10.2 working on the I9505G

How Unlock the Bootloader for the I9505G

[OTA] OTA ZIP 4.3 for I9505G

How to Update your Baseband to get the 4.3 OTA

TOUCHWIZ Development Thread Q&A

Camera Save to SD Card for Google Edition ROM's

I9505G How to Set Device Mount Points in Android Kitchen GE S IV

4.3 SD Card Issue Fixed


ROOTING THREADS

How to Root 4.2, 4.3, 4.4 JB, Kit Kat I9505G

ROM's

[ROM][Linaro-4.8] XenonHD-4.4.2 Alpha 1 (5/1/14) *Truly Stable, Fast & Butter​


GOOGLE LITE EDITION 4.2.2 v.2 MFD

GOOGLE LITE EDITION 4.3 I9505GUEUBMH1 Ktoonsez Kernel

TOUCHLITE GE TOUCHWIZ ROM


RECOVERY

How to install TWRP via Odin on the I9505G

TWRP for the I9505G


[ODIN[TAR] Stock Recovery Images

MODEMS

ODIN TAR MODEMS

STOCK FIRMWARE LEAKS

Stock ODIN FIRMWARE Leaked 4.3 MFP

Stock ODIN FIRMWARE Leaked 4.3 MG8​


ODIN AND HEIMDAL PACKAGES​

Stock HEIMDAL 4.2.2 MFD back to Stock​



[ODIN][TAR] 4.4.3 I9505GUEUCNE3 Full Rooted Restore​


[ODIN][TAR] 4.4.4 I9505GUEUCNF3 Full Rooted Restore​
 
Last edited:

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
Reserved

Big Thanks to Illogic6 for being the Very 1st Person to get Touchwiz Booted to the I9505G post #31 and SamuriHL for solving the Baseband Update Issue and Chainfire

Modem Update : Due to the secure boot loader we cannot flash modems via cwm or any other custom recovery. You MUST update your firmware via Odin

Touchwiz Works with some ROM's like BareBones from the I9505 forum being successfully booted on the I9505G. TW Development is ongoing for the I9505G but with the small partition size some issues exist, and are being researched and worked out.

http://forum.xda-developers.com/showthread.php?t=2405273

11/28/2013 : KitKat initial release this week New Updated Odin Packages and ROM's please check A&D section

DONT FORGET TO THANK THE MEMBERS AND DEVS WORKING HARD ON THE I9505G DEVELOPMENT

07/21/2014: I just wanted to make a note that I still get emails and requests for help and although I am no longer doing any sort of work on the I9505G I will try to help you out if you PM me. PLEASE BIG THANK YOU TO @SamuraiHL he is really the one maintaining everything for I9505G Owners and if you have not thanked him please do. Actually without volunteering him he is your best POC for anything current. I will maintain the thread for organization now and then. ALOHA
 
Last edited:

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
Nice to see someone do this. Hope this will build up and morph into ROM's, etc.

How is your ROM coming along?

Right now just standard kitchen tweaks on 4.3 but I am trying to get the whole device mount points set up in Cygwin and I'm having trouble because when I extract everything and open up the recovery.fstab file with notepad ++ it does not show anything but 0p1 nothing for system, boot & data so I'm lost and need help :)

Sent from my GT-I9505G using Tapatalk 2
 
Last edited:

wilbarger

Senior Member
Aug 8, 2012
692
416
USA
Right now just standard kitchen tweaks on 4.3 but I am trying to get the whole device mount points set up in Cygwin and I'm having trouble because when I extract everything and open up the recovery.fstab file with notepad ++ it does not show anything but 0p1 nothing for system, boot & data so I'm lost and need help :)

Sent from my GT-I9505G using Tapatalk 2

One person you might contact is mohan_kr. He has come over to the S4 from the Skyrocket recently. Excellent at working on the ROM's. Sorry I can not be of assistance, but I am not very advanced on Android.
 

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
Nice to see someone do this. Hope this will build up and morph into ROM's, etc.

How is your ROM coming along?

One person you might contact is mohan_kr. He has come over to the S4 from the Skyrocket recently. Excellent at working on the ROM's. Sorry I can not be of assistance, but I am not very advanced on Android.

That's what this thread is for though for everyone to get together share information and collaborate.
 
  • Like
Reactions: sjandro16

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
Right now just standard kitchen tweaks on 4.3 but I am trying to get the whole device mount points set up in Cygwin and I'm having trouble because when I extract everything and open up the recovery.fstab file with notepad ++ it does not show anything but 0p1 nothing for system, boot & data so I'm lost and need help :)

I saw Chahk post and it is helpful this is where I'm at right now read above. I did pm Chahk and a few others for help. I will work on it a little later this weekend
Sent from my GT-I9505G using Tapatalk 2



Sent from my GT-I9505G using Tapatalk 2
 
  • Like
Reactions: sjandro16

illogic6

Senior Member
Jul 10, 2009
1,064
96
Chahk's post about mount points and getting other CM/AOSP ROMs working on I9505G deserves its own link:

http://forum.xda-developers.com/showpost.php?p=43843048&postcount=30

x2
I've found that very useful. Been able to get every AOSP/CM based ROM to boot by editing the updater-script to match the correct partition.

Has anybody noticed that photos taken with the front facing camera on CM sometimes have green distortion? That was the only bug I've found. Unfortunately, that flared up my phone OCD enough to go back to the 4.3 leak.

Thanks for putting this thread together, OP!
 

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
x2
I've found that very useful. Been able to get every AOSP/CM based ROM to boot by editing the updater-script to match the correct partition.

Has anybody noticed that photos taken with the front facing camera on CM sometimes have green distortion? That was the only bug I've found. Unfortunately, that flared up my phone OCD enough to go back to the 4.3 leak.

Thanks for putting this thread together, OP!

Your Welcome. So I read on the other thread and I know myself and others are looking at how we can port other ROMs specifically touchwiz over to the G the partition as you know is an issue but I think with collaboration can be solved soon.

Keep it coming let's solve problems!

Sent from my GT-I9505G using Tapatalk 2
 
  • Like
Reactions: sjandro16

illogic6

Senior Member
Jul 10, 2009
1,064
96
Your Welcome. So I read on the other thread and I know myself and others are looking at how we can port other ROMs specifically touchwiz over to the G the partition as you know is an issue but I think with collaboration can be solved soon.

Keep it coming let's solve problems!

Sent from my GT-I9505G using Tapatalk 2

I took a TW ROM and edited the script for our devices. It boots, but the display never kicks on. You get the boot animation sound and it even mounts the storage on my computer.
 

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
I took a TW ROM and edited the script for our devices. It boots, but the display never kicks on. You get the boot animation sound and it even mounts the storage on my computer.

Wow that's great maybe you can help me with my script it sounds like your further along than some. I wonder what would cause the display bug doesn't sound like a boot issue

Sent from my GT-I9505G using Tapatalk 2
 
  • Like
Reactions: sjandro16

illogic6

Senior Member
Jul 10, 2009
1,064
96
Wow that's great maybe you can help me with my script it sounds like your further along than some. I wonder what would cause the display bug doesn't sound like a boot issue

Sent from my GT-I9505G using Tapatalk 2

Here's the ROM I was messing with. I used the "old firmware" because it was the newest one when I first looked. http://forum.xda-developers.com/showthread.php?t=2349369

I've attached my modded updater script. (You will have to remove the .txt extension. Wouldn't let me upload without it.) All I had to do was edit which /dev/block the script mounts before it copies stuff over. If I recall correctly, I only had to change the dev it flashes the boot.img to. See this post: http://forum.xda-developers.com/showpost.php?p=43843048&postcount=30

include 'standard_disclaimer.php';
 

Attachments

  • updater-script.txt
    4.2 KB · Views: 24
Last edited:
  • Like
Reactions: MJHawaii

illogic6

Senior Member
Jul 10, 2009
1,064
96
Has anybody noticed that photos taken with the front facing camera on CM sometimes have green distortion?

I think this might be fixed in the newest CM nightly. I've took about 20 selfies with the front facing camera and haven't had distortion at all. Before I'd get it every 3 or 4 photos.

Edit: Disregard the above. The problem is back, but I'm thinking it might be the 4.3 camera zip I've been using. Hmmmmmmm......
 
Last edited:

evanstapler

Senior Member
Oct 10, 2010
108
1
I think I jumped the gun a bit on rooting my I9505G right when I got it. I've never successfully rooted it, but I managed to get on the 4.3 ROM with a few quirks here and there. My ultimate goal is to get Paranoid Android with halo running, but I'll have to dedicate a day to the whole process. I'll be keeping track of this thread.
 

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
Here's the ROM I was messing with. I used the "old firmware" because it was the newest one when I first looked. http://forum.xda-developers.com/showthread.php?t=2349369

I've attached my modded updater script. (You will have to remove the .txt extension. Wouldn't let me upload without it.) All I had to do was edit which /dev/block the script mounts before it copies stuff over. If I recall correctly, I only had to change the dev it flashes the boot.img to. See this post: http://forum.xda-developers.com/showpost.php?p=43843048&postcount=30

include 'standard_disclaimer.php';

Thanks a lot I will take a look tomorrow and see what I can do

Sent from my GT-I9505G using Tapatalk 2
 

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
Here's the ROM I was messing with. I used the "old firmware" because it was the newest one when I first looked. http://forum.xda-developers.com/showthread.php?t=2349369

I've attached my modded updater script. (You will have to remove the .txt extension. Wouldn't let me upload without it.) All I had to do was edit which /dev/block the script mounts before it copies stuff over. If I recall correctly, I only had to change the dev it flashes the boot.img to. See this post: http://forum.xda-developers.com/showpost.php?p=43843048&postcount=30

include 'standard_disclaimer.php';

Great work Illogic I wonder why TW will not display I tried as well but I did not get as far as you mine fails during the installation.

Also did you see my post on getting Cygwin to set device mount points that in itself will speed things up

Sent from my GT-I9505G using Tapatalk 2
 

illogic6

Senior Member
Jul 10, 2009
1,064
96
Great work Illogic I wonder why TW will not display I tried as well but I did not get as far as you mine fails during the installation.

Also did you see my post on getting Cygwin to set device mount points that in itself will speed things up

Sent from my GT-I9505G using Tapatalk 2

I haven't used Cygwin before. I'll take a look at it today.

Also going to mess around with TW a little more. Maybe we just need some libs from the stock 9505g rom or something.

Update: I'm afraid I may have mislead you earlier. It appears that you need more than just the updated update-script in order to get touchwiz to boot. You also need a kernel from one of the 4.3 leaks. Here's the one I've been using. (Attached) Not only does it boot, but the soft keys work and you can hear the sound effects of the lock screen. I'm very close.
 

Attachments

  • boot.img
    7.9 MB · Views: 28
Last edited:
  • Like
Reactions: MJHawaii

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
I haven't used Cygwin before. I'll take a look at it today.

Also going to mess around with TW a little more. Maybe we just need some libs from the stock 9505g rom or something.

Update: I'm afraid I may have mislead you earlier. It appears that you need more than just the updated update-script in order to get touchwiz to boot. You also need a kernel from one of the 4.3 leaks. Here's the one I've been using. (Attached) Not only does it boot, but the soft keys work and you can hear the sound effects of the lock screen. I'm very close.

Wow Illogic your close bro thanks for your hard work the libs does sound like it would cause the display problem I'm gonna play around with this too. All I did was unpack stock 4.3 and zip and deo the files with root. The problem I am having is that I am still learning U-scripts and so I cannot get anything to flash. I get failed on 0p21 even though its changed. Maybe I can pm you what I did later and get your feedback cuz your miles ahead of me

Sent from my GT-I9505G using Tapatalk 2
 

illogic6

Senior Member
Jul 10, 2009
1,064
96
I've merged libs from the leaked 4.3 build into the TW ROM without overwriting anything. Didn't seem to change anything. At this point, I'm playing with magic I don't understand so not sure how much farther I'm going to get.

Would really like figure out which files in the system are responsible for the display. Perhaps we need to overwrite those files. Google is failing me so far.

---------- Post added at 04:45 PM ---------- Previous post was at 04:29 PM ----------

Tada! :victory:

The error message goes away. Right now, the web browser force closes... that might be because of the ROM I was modifying. What I did was use the 4.2.2 kernel that shipped with the google play phones. That booted AND activated the display.

http://i.imgur.com/HZaraPK.jpg
 
Last edited:
  • Like
Reactions: MJHawaii

Top Liked Posts