[STOCK][CROSSFLASH][GUIDE] How to install Stock Rom (or crossflash) using LG UP

davebrooks

New member
Oct 28, 2009
2
2
23
EU Firmware on G7 Korean on G710N

Thanks very much for this information, however I still have a problem with Wi-Fi.

Every time I change "ota setting" BR to JP and hitting "Enable" the Wi-Fi starts working perfectly but after a reboot it resets itself and stops working again.
I followed the rest of the instructions including "Block Data Recovery" but it always resets after a reboot.
Any idea how to get it to keep this setting after a reboot? I could not find a way.

I am using the ROM "G710EM20d_00_0905.kdz"

If somebody is flashing EU firmware for Lg G7 Korean version and doesn't have 4g/lte You can chose it manually from network settings --> mobile networks --> network operators --> Your operator: LTE.

But in this ROM works better 3G/4G switch. In Korean ROM I had a lot of missed calls because G7 was too slow with switching from LTE to 3G band (I live in Poland).

Ok, so... I resolved wi-fi problem
- open service mode, dial *#546368#*710#
- field test
- wi-fi test
- ota setting

change country code from BR to JP and click Enable.

Wi-fi is working normal after restart but 4G/LTE is reseting and You have to check it manually again.


Edit:
Solved problem with not connecting to 4g after restart or lost connection/after switching to 3g (after call for example)

Please install VoLTE check and click "Click to know" --> open phone information --> 3 dots in right corner --> Choose radio --> Europe

Now we have to lock network option reseting on reboot so get into Service Menu dial *#546368#*710# --> Field test --> Modem Settings --> PDP Setting --> Block Data Recovery --> Choose Enable and restart phone.

Now You have fully working Wi-Fi and 4G on G7 G710N wit EU ROM.
 

Aseiel

Member
Aug 10, 2017
36
11
0
I really don't know ? for me works fine, maybe because I have unoficially unlocked version.

I have another guide for 4g connection which works better than previous one.

On service mode -->Field test-->modem settings-->band

Select band from 1-41 And click save.

This should repair problem with 4g and weak cellular strenght.
 

shorty.marten

Member
Dec 15, 2013
25
6
23
34
Magdeburg
To fix vibration and enable ARCore on AOSP please install this zip as a magisk module in Magisk manager
https://drive.google.com/open?id=1TTM2m4BwRRebaJn8qxrNo5x-pKLYrmie

Current AOSP Bugs:
  • LED not working
  • Occasional slowdowns (nothing major and clearing recent apps will fix the problem)
  • The display will turnn off for 0.5 secons when the phone gets unlocked (only when AOD is not active)

Current Stock/European Pie Bugs:
  • VoWiFi and VoLTE not working. It should work with European KDZ/Version but need feedback on it.
  • Dual sim not supported

Code:
Keep in mind that i can't do anything about Stock/European pie bugs
Hey, I've used your Carbonrom Vendor from your google dirve instead of GSI vendor and LED bug seems to be solved. The display bug still persist, also with AOD on (after long time without using the phone). No slowdowns so far. Thanks for your great work. My Combination: TWRP 20b, Carbonrom Vendor, Havoc GSI.
 

rcadeace

New member
Jan 7, 2011
1
0
0
Just a note: with the EU kdz you can't use voice/data on Verizon G710VM in the US (this is known in thread).

However, I was able to flash the stock US unlocked kdz (G710ULM20d_00_NAO_US_OP_0612.kdz) and that works fine with all services. You don't have to flash the Verizon specific ROM, or at least I did not.
 

shishishy

Member
Feb 1, 2014
14
0
0
I found how to turn off the Led blinking, first download "Root Browser" Open "sys" folder > class > leds
1.First go to blue > brightness (Open ass.. > Text file > RB Text Editor and change value to 0
-now led lights change to green
2.Back to "leds" folder > repeat the procedure for green
It should be turned off.
thank you!
 

cavcagamgee

Member
Oct 17, 2019
21
2
0
So I'm not using a G7, but I was trying to use this process with my v40 to no avail. I keep getting "SW_PATH is null" regardless of my structure. I am mostly using ".\lgup_cmd.exe comX [DLL location] [image location]" and am in download mode like depicted.

Is it possible that it's not recognizing the kdz as an image file?
 

rrwg

New member
Nov 18, 2019
1
0
0
That's cool, where can I get carbon ROM vendor though?
On the telegram group

---------- Post added at 04:44 PM ---------- Previous post was at 04:34 PM ----------

Yes, me. I am using Evolution-X_3.3_20191111_ARM64-AB.img.xz made by ExpressLuke as may daily driver
With carbon rom vendor (thanks to LameMonster82) its running like stock (except vibration).
Hey Can you tell me how to flash it (i have twrp and bootloader unlocked) I need the right steps like format data reboot flash vendor etc (someone on the telegram group tried this without success). And also can you review the rom like what works what not. Does it has any advantages over carbon pie? Quad dac probably doesn't work right? and does it come with gapps?

Thanks in advance
 

shorty.marten

Member
Dec 15, 2013
25
6
23
34
Magdeburg
On the telegram group

---------- Post added at 04:44 PM ---------- Previous post was at 04:34 PM ----------


Hey Can you tell me how to flash it (i have twrp and bootloader unlocked) I need the right steps like format data reboot flash vendor etc (someone on the telegram group tried this without success). And also can you review the rom like what works what not. Does it has any advantages over carbon pie? Quad dac probably doesn't work right? and does it come with gapps?

Thanks in advance
Carbonrom Vendor also can be found here:
https://drive.google.com/drive/folders/11XNXjsdDfjufX5ZiOyC3I0lk0B2r2nuY
(Thanks to LameMonster82)

The steps are the same as on first page, just replace vendor with Carbon Vendor. Use twrp from this site:
https://forum.xda-developers.com/lg-g7-thinq/development/twrp-twrp-3-3-1-0-lg-g7-thinq-t3954012
You need to format data in twrp (with type 'yes')

What works (Evolution X 3.3 and Carbon Vendor): - everything except following bugs
- also LED is working
- no slowdowns
Bugs:
- The display will turn off for 0.5 seconds when the phone gets unlocked (only when AOD is not active). Sometimes this happens also with AOD on.
- Vibration not working. If you try to install ARCore, the rom doesn't start (like most of AOSP GSI). This happens cause the build.prop file changes completly to google pixel 2.

You can use also gsi vendor mentioned on first page with more bugs:
- LED not working (can be disabled by magisk module)
- The display will turn off for 0.5 seconds when the phone gets unlocked (only when AOD is not active)
- Vibration not working. If you try to install ARCore, the rom doesn't start (like most of AOSP GSI).

Evolution X 3.3 is basically the same as PixelExpierenceRom. It comes with gapss, has November patch, fully working navigation (with included Pixel launcher) and some more tweaks as PixelExpierenceRom.
 
Last edited:

phenomarc

Senior Member
Nov 17, 2011
218
119
73
Is there an AOSP ROM ( Android 9 or 10) with a working QUAD DAC and a similar audio quality than stock?
Is possible to have 4K recording on AOSP?
Thanks.

Enviado desde mi LM-G710 mediante Tapatalk
 

lolwatpear

Senior Member
Nov 24, 2011
287
42
0
Just a note: with the EU kdz you can't use voice/data on Verizon G710VM in the US (this is known in thread).

However, I was able to flash the stock US unlocked kdz (G710ULM20d_00_NAO_US_OP_0612.kdz) and that works fine with all services. You don't have to flash the Verizon specific ROM, or at least I did not.
sorry, im confused. How do you get stock pie on to the verizon G7? you flash the US stock unlocked rom, and then you follow the guide "1st How to install Stock European pie."?
 

leodiavata

Senior Member
Mar 13, 2016
87
6
0
just installed the evolution x Android q rom and trying it out. battery seems to be draining rather quick. I know it's early still. Has anybody has a good experience with aosp 9.0 roms?
 

allinkiran

Senior Member
Jun 27, 2011
87
4
0
Just to confirm if I want AOSP on my EAW oreo(bootloader unlocked) I would have to install EM pie rom then flash the files in the op and proceed to install the AOSP rom, right?