[STOCK] D851 30D KDZ + Flashable ZIPs + All IMGs (Marshmallow!!)

Four2zero

Member
Dec 2, 2009
32
5
0
Orange County 714
!!!Hidden menu not accessing!!!

Okay, guys....I have a problem.
I bought this phone from a third party on swappa website. When I received it in very pristine condition however, it had been updated to the Latest Marshmallow 6.0 D85130E version. So, I went on an adventure to find out how i can get root and twrp up and running on T-Mobile D85130E, however, there was none available. Now, I decided to Downgrade to Stock rom with LGUP + .Tot file (official) of course running (KitKat 4.4.2) everything worked great. So, then i went head and Added SuperSu + TRWP 3.0 latest which the install procedure was flawless. From there on I went ahead and Upgraded to Marshmallow 6.0 D85130D, So now I come to this problem where I can not access the LG HiddenMenu.
When I insert the code " 3845#*851# " I now get Connection problem or invalid MMI Code
Any reason as to why.

Could this be related to APN settings not properly setup ever since i flashed the phone?
If anyone have default settings for APN on T-Mobile Service (US) only could you please Post them so I can verify if they match up with my settings thanks!
 

Four2zero

Member
Dec 2, 2009
32
5
0
Orange County 714
why cant this stock rom bring up hidden menu?

i flashed this rom however it will not bring up lg hidden menu. why is it missing ?
when entering proper lg hidden code pop up says starting mmi......then 2nd pop up says.....invalid or missing mmi? anyone experience this since flashing from these supposedly stock rom?:confused:



T-Mobile LG G3 D851 30D


y u quote OP?

Follow me on twitter for future updates on LG-related things - twitter.com/@utoprime

Find this thread helpful? Hit the Thanks button!
Feeling extra generous? Click my name at the top of any post and hit donate or click here.


#TEAMCODEFIRE
 

jdmst77

Senior Member
Feb 19, 2012
244
37
48
Okay, guys....I have a problem.
I bought this phone from a third party on swappa website. When I received it in very pristine condition however, it had been updated to the Latest Marshmallow 6.0 D85130E version. So, I went on an adventure to find out how i can get root and twrp up and running on T-Mobile D85130E, however, there was none available. Now, I decided to Downgrade to Stock rom with LGUP + .Tot file (official) of course running (KitKat 4.4.2) everything worked great. So, then i went head and Added SuperSu + TRWP 3.0 latest which the install procedure was flawless. From there on I went ahead and Upgraded to Marshmallow 6.0 D85130D, So now I come to this problem where I can not access the LG HiddenMenu.
When I insert the code " 3845#*851# " I now get Connection problem or invalid MMI Code
Any reason as to why.

Could this be related to APN settings not properly setup ever since i flashed the phone?
If anyone have default settings for APN on T-Mobile Service (US) only could you please Post them so I can verify if they match up with my settings thanks!
*#546368#*851#

Out of curiosity, what exactly are you trying to update?
 

CripLe

New member
Oct 4, 2016
1
0
0
when i enter the the first code (adb push LG-D85130D-Flashable.Boot-AUTOREPACK.zip /sdcard/) it says "cannot start 'LG.........' no such file or directory.. how t solve this problem ? may it cause bcz i dont have sdcard and there writes "sdcard".. ? i also tried insted of sdcard "InternalStorage" but it didnt work :/ ??
 

jdmst77

Senior Member
Feb 19, 2012
244
37
48
when i enter the the first code (adb push LG-D85130D-Flashable.Boot-AUTOREPACK.zip /sdcard/) it says "cannot start 'LG.........' no such file or directory.. how t solve this problem ? may it cause bcz i dont have sdcard and there writes "sdcard".. ? i also tried insted of sdcard "InternalStorage" but it didnt work :/ ??
same here but I did everything from the phone in a terminal emulator. Make a note of where files download from your browser. my commands were as follows, yours might be similar:
Code:
su
dd if=/storage/emulated/0/Download/twrp-3.0.0-0-d851.img of=/dev/block/platform/msm_sdcc.1/by-name/recovery
reboot recovery
and if you are going to use this method, make it easier on yourself and download all files that you need on the phone. You can path out to the Download directory and install them from TWRP after you overwrite the stock recovery and reboot into recovery
 
Last edited:

danam

Senior Member
May 18, 2010
104
24
0
default apps

I am running 30d, rooted, per this thread and after several months have only one persistent bug. The phone won't remember any default apps. I have to choose an app for every function and despite checking the box to use as a default it never works. I have cleared cache on apps and whole device several times and rebooted, but new selections still don't hold.
Any ideas?
 

Four2zero

Member
Dec 2, 2009
32
5
0
Orange County 714
At that point i was trying to throttle down Heat issues and fix lag issues off the stock rom 85130D. So i found some tips via xda site and other sites as well which mentioned to access the hidden menu area, but it kept giving me wrong invalid code or mmi service error.

*#546368#*851#

Out of curiosity, what exactly are you trying to update?
 

jdmst77

Senior Member
Feb 19, 2012
244
37
48
At that point i was trying to throttle down Heat issues and fix lag issues off the stock rom 85130D. So i found some tips via xda site and other sites as well which mentioned to access the hidden menu area, but it kept giving me wrong invalid code or mmi service error.
personally, I reverted the HiddenMenu changes back to default because I didn't notice much of a difference and the risk was greater than the reward. With Tweaksbox, I was able to reduce animations to either .75 or .25 instead of only 1, .5, or off. Since you are rooted, it might be a better option to research some apps that control the processor speed and raise the peak temperature levels instead of completely disabling the phone's ability to govern itself when it gets to hot. That's the route that I want to explore when I have time.
 
Last edited:

forevergone

Member
Aug 21, 2011
34
0
0
I have a LG G3 D851 running CloudyROM 2.5 on Android 5.0 and I would like to revert back to the stock boot image. The phone is unrooted but has TWRP custom recovery.
What stock boot image can I flash that won't brick the phone? Or are there any precautions I should be aware of?
 

christoophat

Senior Member
May 20, 2011
1,214
377
113
SoCal
I bought a used Tmo G3 yesterday, with the intent to root & run custom ROM. It updated to MM d85130d via OTA. I tried several methods to get it rooted - purpledrake - (saw phone, rebooted phone, then it just sat there "waiting for device"), KingRoot (installed a bunch of unneeded crap, was rooted briefly, but when I tried to install super SU, it kept saying there was a conflict with another rooting app, and then I couldn't get it to temproot again), LG_root (followed the script, but got FAIL at the end), and finally StumpRoot (which said "system is patched" fail) I'm assuming I munged something up by now
So I wish to restore to clean MM 30d stock before trying again. I've read thru several threads, but they are either listing older .kdzs or require root or TWRP first, which I do not have . Can anyone advise the best method? I rooted my wifes D851 a few months back easily, for some reason this one is not "easy" :silly:
Thanks for any suggestions!

"We wuz all noobies once" - some old fart.
 

christoophat

Senior Member
May 20, 2011
1,214
377
113
SoCal
I cannot for the life of me figure out how to get this to work.
I have adb installed on my Win10 PC, (I have 30D on phone, unrooted, so I put the AUTOREPACK.zip & the TWRP.img on root of an sd card in phone), and ran KingRoot to get temproot first.
So I open adb command window after plugged in phone ("adb devices" lists it) & attempt to run the first command:
adb push LG-D85130D-Flashable.Boot-AUTOREPACK.zip /sdcard/
but it tells me no such file or directory. What am I missing here? :confused::confused:
 

boulos

Senior Member
May 7, 2012
95
11
0
I cannot for the life of me figure out how to get this to work.
I have adb installed on my Win10 PC, (I have 30D on phone, unrooted, so I put the AUTOREPACK.zip & the TWRP.img on root of an sd card in phone), and ran KingRoot to get temproot first.
So I open adb command window after plugged in phone ("adb devices" lists it) & attempt to run the first command:
adb push LG-D85130D-Flashable.Boot-AUTOREPACK.zip /sdcard/
but it tells me no such file or directory. What am I missing here? :confused::confused:
It can't find the files on your PC. You need to have the zip file in the same directory/folder as the adb.exe or include the full path "adb push c:\newfolder\LG-D85130D-Flashable.Boot-AUTOREPACK.zip /sdcard/ " for example...
 
  • Like
Reactions: christoophat

christoophat

Senior Member
May 20, 2011
1,214
377
113
SoCal
It can't find the files on your PC. You need to have the zip file in the same directory/folder as the adb.exe or include the full path "adb push c:\newfolder\LG-D85130D-Flashable.Boot-AUTOREPACK.zip /sdcard/ " for example...
d'oh! Hmm, well the instructions in the OP do not mention this. OK, so the "sdcard" is actually the install destination, not the location to find & install it from.
Obviously, adb is not my forte. :laugh:

thanks!
 

christoophat

Senior Member
May 20, 2011
1,214
377
113
SoCal
Well, I got farther than I did before, until the dd part:
dd if=/sdcard/twrp-3.0.0-0-d851.img of=/dev/block/platform/msm_sdcc.1/by-name/recovery
only to see "no such file or directory".
Now I'm scared to unplug phone, in case this would brick it. What did I do wrong here, I tried it twice with the same results. Do I need to add the c:\adbfolder wording in it somewhere in that command string?
Please can anyone advise? Before I attempted this just now I did a reset on the phone, noticed that KingRoot was still installed after that. I would have thought that the reset wiped it back to stock again..
An Update: Finally figured it all out, started over by =>KingRoot=>Flashify=>install TWRP=>flash the 3 files in post 1=> profit- rooted 30D!
 
Last edited:
  • Like
Reactions: marcdw